Subject: Re: [TR] Restoration source

From: "Andrew Uprichard" <[email-masked]>
Date: Fri, 30 Nov 2012 13:00:59 -0500

"This outfit" is Lawrie Rhoads - a WW2 vet.

I know Lawrie well - we went to the same church when I lived in
Massachusetts.  He does great work.  All my horns and wipers are a tribute
to him.  I don't know if it is still the case, but if you sent your wiper
motors or horns to Moss, they subcontracted it all to Lawrie.

If you contact him, say hi from me.

Andrew Uprichard

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, November 30, 2012 12:50 PM
To: [email-masked]
Subject: [TR] Restoration source

I was just put onto this outfit.  It looks like they only do horns and wiper
motors.

http://www.british-car-part-restoration.com/index.html

Dave

** [email-masked] **

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Don Hiscock <[email-masked]>
Date: Fri, 30 Nov 2012 14:47:51 -0500

Lawrie recently rebuilt the original Lucas DR2 motor from my TR3B, and did
a fine job.  It had a heavily corroded end plate and frozen rear bushing.
 All of it was taken care of perfectly.

Before:
http://www.smugmug.com/photos/i-M4DpN4X/0/L/i-M4DpN4X-L.jpg

After:
http://4xdog.smugmug.com/photos/i-3hTH63j/0/L/i-3hTH63j-L.jpg

Don

On Fri, Nov 30, 2012 at 1:00 PM, Andrew Uprichard
<[email-masked]>wrote:

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/triumphs/[email-masked]