Subject: Re: [TR] A time-warp 1968 Triumph 2000 on eBay UK

From: Geo Hahn <[email-masked]>
Date: Thu, 1 Nov 2012 15:52:39 -0700

*"...It is in running driving condition, although there are no brakes."*
**
That's the spirit!

Geo

On Thu, Nov 1, 2012 at 10:57 AM, Don Hiscock <[email-masked]> wrote:
>
> As they say, something can be restored many times, but can only be
original
> once...
> http://tinyurl.com/bj6kue9
>
> Don

** [email-masked] **

Archive: http://www.team.net/archive

---

From: Chris Simo <[email-masked]>
Date: Thu, 1 Nov 2012 19:50:59 -0400

I remember what that's like!!!!