Subject: [TR] Brake & Clutch Pedal Bushings

From: George Haynes <[email-masked]>
Date: Wed, 17 Oct 2012 10:03:38 -0400 (EDT)

While investigating a friend's (1970) TR6 heavy clutch pedal operation, we
found quite a bit of side play in the pedal pivots.  After removing the pedal
box from the car and disassembling, we found no bushings in the brake and
clutch pedal pivots.  No trace of busings ever being there, either.
Moss shows bushings (330-285) at each end of the pivot tubes, apparently for
all TR6's.  Has anyone else found these bushings missing?  Do other cars
exhibit the sloppy pedal symptoms?  We're baffled but will install the
bushings to improve pedal operation.
George

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Dean Tetterton <[email-masked]>
Date: Wed, 17 Oct 2012 16:38:35 -0500 (CDT)

This is common to most pedal assy. They are soft
bushings and disappear quickly. Does make the pedals work
better. 
 
Dean

On 10/17/12, George Haynes wrote:

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]