Subject: Re: [TR] Non TR question

From: Frank Fisher <[email-masked]>
Date: Mon, 22 Oct 2012 11:29:47 -0700 (PDT)

personally i have no problems with the original wiring of LBC's.
put in a new
harness from British wire.
be sure the bullet connectors are good and that
ground wires are properly grounded.
if you want added peace of mind shrink
tape over the bullet connectors
use the electric grease because of where you
are.
 
that the old lucas electric was bad was more myth than fact. it was
about non maintenance.

From: John Wise <[email-masked]>
To: car
discussion Sports Triumph <[email-masked]> 
Sent: Monday, October 22,
2012 11:10 AM
Subject: [TR] Non TR question

My daughter is thinking about an
E-type Jag (hopefully she will let her dad
drive it once in a while).

I told
her my biggest concern would be the "classic" british wiring problems.
I was
wondering if any one knows of Dan Masters like modern wiring redo for
the
e-Type??  The one I put in my TR-3A has made it as reliable as my wife's
Honda.

Thanks

John

John Wise
Ormond Beach, FL

1960 TR3A
http://wisegroupllc.org/_/TR3A.html

1977 Porsche 911S ('86 3.2 engine)
http://wisegroupllc.org/_/Porsche.html

** [email-masked] **

Donate:
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Archive: http://www.team.net/archive

---

From: "Wbeech" <[email-masked]>
Date: Mon, 22 Oct 2012 14:00:29 -0500

I agree with Frank, I am running an Auto Spark harness (also sold by BW)
with no problems four years in.  Have a friend with a 1970 E-Type, probably
stock or original harness, no problems reported from him over ten years.

Bill

Bill Beecher
'58 TR3A TS/30766L "Tarbaby"
'62 TR3B TCF/2549L " Aunt B" (in rehab)
www.triumphowners.com/1566
'68 Land Rover Series IIa 88" "The Beast"
"If you think you have everything under control... You're driving too slow"
M.Andretti

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Frank Fisher
Sent: Monday, October 22, 2012 1:30 PM
To: John Wise; car discussion Sports Triumph
Subject: Re: [TR] Non TR question

personally i have no problems with the original wiring of LBC's.
put in a new
harness from British wire.
be sure the bullet connectors are good and that ground wires are properly
grounded.
if you want added peace of mind shrink
tape over the bullet connectors
use the electric grease because of where you are.
 
that the old lucas electric was bad was more myth than fact. it was about
non maintenance.

My daughter is thinking about an
E-type Jag (hopefully she will let her dad drive it once in a while).

I told
her my biggest concern would be the "classic" british wiring problems.
I was
wondering if any one knows of Dan Masters like modern wiring redo for the
e-Type??  The one I put in my TR-3A has made it as reliable as my wife's
Honda.

Thanks

John

John Wise
Ormond Beach, FL

1960 TR3A

Donate:

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Geo Hahn <[email-masked]>
Date: Mon, 22 Oct 2012 12:27:49 -0700

I, too, would favor a stock harness.  Considering that this may be a
$70,000 to $100,000 car, I would think it's value might be diminished by an
non-original wiring loom.

IMO, there are a lot of mods where a tired original is replaced by a new
upgrade and the upgrade gets a lot of credit for the resulting improvement
when, in fact, simply rebuilding or replacing with 'as original' would have
also yielded similar improvement.

Geo

On Mon, Oct 22, 2012 at 11:10 AM, John Wise <[email-masked]> wrote:

> My daughter is thinking about an E-type Jag (hopefully she will let her dad
> I told her my biggest concern would be the "classic" british wiring
> problems.
> I was wondering if any one knows of Dan Masters like modern wiring redo for
> the e-Type??