Subject: [TR] Club Triumph track day at Goodwood

From: Don Hiscock <[email-masked]>
Date: Mon, 22 Oct 2012 16:40:15 +0300

One and a half hours of running at Goodwood in my TR for a couple hundred
bucks?  You bet I'm jealous of some of the options across the water!

http://www.tr-register.co.uk/forums/index.php?showtopic=37696#entry285882

Don
1962 TR3B TSF202L

** [email-masked] **

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Mon, 22 Oct 2012 14:20:11 -0400 (EDT)

About the best we can do over here is an autocross.  Slower speeds but 
still a hoot.  And no real noise limit.

Dave