Subject: [TR] 89mm pistons & liners

From: Allen Hess <[email-masked]>
Date: Tue, 9 Oct 2012 15:58:34 -0400

Has anyone used the 89mm piston and liner set? (available from Moss  
and BPNW) It would be for a "street" engine and the improved piston  
design and made in the UK is what interests me more than the  
additional 2mm. It's cheaper now than a year or two ago, but still  
around 2x the standard 87mm set of unknown origin. (anyone know where  
these are coming from these days?)

Any other opinions on engine parts appreciated.

Allen
TR4
Bethlehem, PA

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Randall <[email-masked]>
Date: Tue, 9 Oct 2012 18:41:08 -0400

---- Allen Hess <[email-masked]> wrote: 
> design and made in the UK

I haven't installed mine yet, but it sounds like maybe you have a different set than I do.  Do Moss & BPNW really claim they are made in the UK?

I got mine from BFE (who didn't recommend them for street use) and AFAIK all the components were made right here in the USA.  Deves piston rings, Venolia pistons, and custom liners by LA Sleeve.  I don't recall if Ken said where the gaskets came from, but I wouldn't be surprised if they were made by GasketWorks.  These are all very well respected companies, practically legendary in the high performance engine parts business.

Randall

---

From: Robert Jones <[email-masked]>
Date: Tue, 9 Oct 2012 17:54:05 -0500

Hi All

Need some advice on A/C.  Took my TR8  to a shop for replacement of
Compressor, Dryer and Expansion Valve.  A/C was cooling but compressor was
making noise.  The shop mechanic (?) installed the  compressor and dryer but
while trying to install the new expansion valve twisted the nut connecting the
condenser off and bent the copper tubing.  Needless to say I brought home a
wounded car.
This was in March.  The car has been stored since in the closed garage.  i
undertook to fix it last week.  Expansion valve very hard to get to,
especially trying to repair connection.  Found the mechanic had left the
condenser line open.  I have purchased a line repair connection and trimmed
the twisted line and now I am  ready to install a new expansion valve.I am now
looking at flushing the system, evac the lines and filling with freon.  I have
a new dryer also as the previous new one was left open.  Question:  Should the
expansion valve be installed before flushing?  Is flushing worth it?  If so,
any recommended solvent?  Wouldn't the new dryer be installed after flushing
and before evac and filling with freon?

Thanks for the help.

---

From: Randall <[email-masked]>
Date: Tue, 9 Oct 2012 21:01:08 -0400

---- Robert Jones <[email-masked]> wrote: 
> Question:  Should the

No need for flushing, IMO.  That's for when you've had a compressor failure that dumped garbage in the system, or have too much oil or something.

If you do flush, don't flush through either the receiver/dryer or the expansion valve.  Disconnect the evaporator and condenser and flush them independently.  And unless you flush with refrigerant, be darn sure to get all of the solvent back out.

Randall

---

From: "J.C. Hassall" <[email-masked]>
Date: Thu, 11 Oct 2012 20:51:19 -0400

> Any other opinions on engine parts appreciated.
I bought a set from BPNW 2 years ago.  The package had a Union Jack on 
it.  One wrist pin clip was missing, which took forever to be replaced 
by BPNW.  They didn't include ring setting dimensions, and, 
interestingly, the rings were a mixed set.  The compression rings were 
Deves units, but not the oil ring.  The pistons were feather-light and 
very easy to balance dead nuts.  One thing that I ****hated**** about 
the pistons was the lack of quality control on the compression 
distance.  Since I'm A.R. to a fault, I had to face 3 of them, so they 
are all now 0.019 below the deck.  That's a HUGE loss of cylinder 
volume.  I was NOT happy.

That said, in two years they may have fixed those issues.

hth

jim

-- 
Jim Hassall
Blacksburg VA
'63 TR4 in autox preparation
99% finished, 90% to go