Subject: [TR] Window outer seal issue

From: "G.D. Huggins" <[email-masked]>
Date: Mon, 15 Oct 2012 13:37:16 -0500

All,

I recently replaced the outer seal on my driver's side door.  (Hate those
damned clips!)
When I roll the window down, the glass "pulls" the seal down along with it,
folding the seal over making it very difficult to continue.

Unlike the seal I had before, these seals from Moss have no "fuzz", which
allows the glass to glide nicely.

Any advice other than to replace the seal with one that has fuzz?

Cheers,

Guy D. Huggins
1965 Triumph TR4A
CTC 63569LO

Online project diary at http://www.genfiniti.com/triumph

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Geo Hahn <[email-masked]>
Date: Mon, 15 Oct 2012 12:10:09 -0700

Perhaps the 4A is different but I don't think the TR4 had any fuzz on the
outer seal, just plain rubber that presses and curves up a bit against the
glass.

Geo

---

From: "Carl-TR" <[email-masked]>
Date: Mon, 15 Oct 2012 15:19:36 -0400

Could the seal be installed upside down or inside out?  The curve (as George
says) should be pointed away from the glass and out from the channel.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Geo Hahn
Sent: Monday, October 15, 2012 3:10 PM
To: G.D. Huggins
Cc: Triumphs
Subject: Re: [TR] Window outer seal issue

Geo

On Mon, Oct 15, 2012 at 11:37 AM, G.D. Huggins <[email-masked]> wrote:

> Unlike the seal I had before, these seals from Moss have no "fuzz", 
> which allows the glass to glide nicely.
>

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Bud Rolofson <[email-masked]>
Date: Mon, 15 Oct 2012 17:14:46 -0600

Try a little dish washing soap (Dawn, etc.) on the seal a few times  
and wash the window with it too. It really makes things slick and  
it'll wash away after your window and the seal become friends.

Bud Rolofson

71TR6 CC57365 (Good 6)
71 Spitfire MK IV Race Car #3
66TR4A CTC57529 (The Project)
71F-250 Camper Special (Triumph Support Vehicle)
Z-50A Hardly Davidson 1977 Honda Mini-Trail Bike (Triumph Pit Bike)

On Oct 15, 2012, at 12:37 PM, G.D. Huggins wrote:

> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]