Subject: [TR] Rocker Arm

From: marty sukey <[email-masked]>
Date: Mon, 1 Oct 2012 20:45:37 -0400

Many years ago I had a set of TR6 rockers rebuilt. I was thinking the place
was called ROCKER ARM EXCHANGE" but I must be wrong because I cannot find
anything under that name. Any suggestions?

Thanks,

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Mark J Bradakis <[email-masked]>
Date: Mon, 01 Oct 2012 19:14:05 -0600

Did you check the Monster list at http://www.dimebank.com/monster for a 
listing?

mjb.

---

From: "Greg Lemon" <[email-masked]>
Date: Mon, 1 Oct 2012 20:11:51 -0500

Rocker Arm Specialists? who I think now have morphed into rockerarms.com ot 
something like that?

---

From: Randall <[email-masked]>
Date: Mon, 1 Oct 2012 23:07:10 -0400

Any chance you are thinking of:

Rocker Arm Specialist
19841 Hirsch Court
Anderson, CA 96007
Tel (530) 378-1075
(800)747-2767
fax (530) 378-1177
mailto:[email-masked]
http://www.rockerarms.com/index.htm

It has been a few years now, but I was very pleased with the work they did on my TR3A rocker shaft.  The cost was modest as well, roughly the same I would have paid for just the parts.  All new adjusters, locknuts, springs, bushings and the shaft itself.  The rockers I'm not certain about, they certainly looked new.  Only the pedestals, end caps and locking screw were clearly the original parts.  (They had been nicely cleaned up, but not remachined or anything.)

I've lost track of how many miles I've got on that rocker shaft; the only issue I have ever had is that the roll pin they used on the rear cap started to work it's way out (which I discovered when I moved it from the wrecked 3A to the current TR3).  I replaced it with a stock solid pin and all seems to be well.

Randall

---

From: "TeriAnn J. Wakeman" <[email-masked]>
Date: Tue, 02 Oct 2012 06:05:58 -0700

> anything under that name. Any suggestions?
Most any automotive machine shop can radius rocker arm ends and ream out 
new rocker arm bushings.  I just bought new bushings and a new rocker 
shaft and took them over to my local automotive machine shop.

TeriAnn