Subject: [TR] Bondo substitute. What are fellow Triumph owners using to fill small rusty spots?

From: Sujit Roy <[email-masked]>
Date: Mon, 8 Oct 2012 07:42:14 -0700

Regards, Roy

-- 
Sujit Roy, Realtor
Cupertino, CA
(408) 839-8359

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Frank Fisher <[email-masked]>
Date: Mon, 8 Oct 2012 07:55:41 -0700 (PDT)

just for fun, i did some lead work when i was restoring my TR3.
i would not
suggest it for whole project use. its really tough to do.
remember you must
get rid of the rust, unless its just a surface scrape then you can use one of
the better rust converters. but i prefer grinding it out till its all gone.
Frank 

From: Sujit Roy <[email-masked]>
To: Triumphs
<[email-masked]> 
Sent: Monday, October 8, 2012 7:42 AM
Subject: [TR]
Bondo substitute. What are fellow Triumph owners using to fill small rusty
spots?

Regards, Roy

-- 
Sujit Roy, Realtor
Cupertino, CA
(408) 839-8359

**
[email-masked] **

Donate: http://www.team.net/donate.html
Archive:
http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Andrew Uprichard" <[email-masked]>
Date: Mon, 8 Oct 2012 16:58:17 -0400

Depends what you mean by rusty spots:  if they are holes, they should
ideally be welded, fiberglass as an alternative.  If you are just talking
about the dimpling you get with age, bondo is fine.

Andrew Uprichard

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Sujit Roy
Sent: Monday, October 08, 2012 10:42 AM
To: Triumphs
Subject: [TR] Bondo substitute. What are fellow Triumph owners using to fill
small rusty spots?

Regards, Roy

-- 
Sujit Roy, Realtor
Cupertino, CA
(408) 839-8359

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Dave Connitt" <[email-masked]>
Date: Mon, 8 Oct 2012 19:49:13 -0400

U had real good results ( after practicing..) using a hammer and dolly and a 
shrinking disc I bought off of Ebay. No filler at all.
Dave Connitt
'67 TR4A IRS
http://home.fuse.net/davestr4a

---

From: Randall <[email-masked]>
Date: Mon, 8 Oct 2012 19:52:01 -0400

I'm curious, what's wrong with Bondo?

As far as I know, used according to directions, it works very well.  The problems arise mostly when people try to glop it on too thick or fill large holes.  Ideally it should not be more than 1/8" thick.

Of course you have to get _all_ the rust out first or it will just come back.

--- Randall