Subject: [TR] New lift followed me home

From: Chris Simo <[email-masked]>
Date: Tue, 4 Sep 2012 20:53:31 -0400

A rusty vehicle lift followed me home today. Its a qp-6000 quick lift.  The
new tr6 seems to ride it just fine.

It picked up my truck just fine. It looks very rough and there is
rustoleum  in its future.

It fits the six just great and hits the frame fully. Now to see how it
works with the 4 and the 2.

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Wbeech" <[email-masked]>
Date: Tue, 4 Sep 2012 23:42:43 -0500

Congratulations, if you see any more strays out there give a call and I will
help you round them up.
B 

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Chris Simo
Sent: Tuesday, September 04, 2012 7:54 PM
To: list Triumph
Subject: [TR] New lift followed me home

It picked up my truck just fine. It looks very rough and there is rustoleum
in its future.

It fits the six just great and hits the frame fully. Now to see how it works
with the 4 and the 2.

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Wbeech" <[email-masked]>
Date: Tue, 4 Sep 2012 23:42:43 -0500