Subject: [TR] steering wheel

From: "Andrew Uprichard" <[email-masked]>
Date: Sun, 23 Sep 2012 21:22:17 -0400

List:

I am trying to restore a small-mouth on a budget - it's going to be
interesting to see what a nice frame-off is going to end up costing. No
fast-road car this time - just a standard TR3 with overdrive.   I am doing
everything but chroming, upholstery, machining and final paint.  Oh - and I
got Nisonger to restore the gauges.

But I digress:  the steering wheel 's bakelite is cracked.  Anyone have any
suggestions as to who could restore this for me?

Really appreciate any help.

Andrew Uprichard

1962 TR3B - few upgrades

1968 TR250- fast road

1957 small-mouth.  Getting there

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: George Richardson <[email-masked]>
Date: Mon, 24 Sep 2012 06:14:24 -0400

Eastwood sells a steering wheel restoration kit:

http://www.eastwood.com/complete-steering-wheel-restoration-kit-26003.html

I used this myself on the adjustable steering wheel of my '57 TR3. It 
was great. It comes with instructions, epoxy, paint prep, and adhesion 
promoter. All you'll need is black paint.

George Richardson
Key Men - Keys for Classics
www.key-men.com

On 9/23/2012 9:22 PM, Andrew Uprichard wrote:
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Andrew Uprichard" <[email-masked]>
Date: Mon, 24 Sep 2012 08:53:13 -0400

Thank you to all who replied.  I actually have a couple of wheels, so I
think I'll take a shot at one myself and if I screw up, I'll take one of you
up on your (several) recommendations for the other.

Andrew.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of George Richardson
Sent: Monday, September 24, 2012 6:14 AM
To: [email-masked]
Subject: Re: [TR] steering wheel

I used this myself on the adjustable steering wheel of my '57 TR3. It was
great. It comes with instructions, epoxy, paint prep, and adhesion promoter.
All you'll need is black paint.

George Richardson

On 9/23/2012 9:22 PM, Andrew Uprichard wrote:
> everything but chroming, upholstery, machining and final paint.  Oh - 
> and I got Nisonger to restore the gauges.
>
>   
>
> But I digress:  the steering wheel 's bakelite is cracked.  Anyone 
> have any suggestions as to who could restore this for me?
>
>   
>
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/triumphs/[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Don Hiscock <[email-masked]>
Date: Mon, 24 Sep 2012 09:17:32 -0400

Eastwood also offers a POR-15 steering wheel kit (on sale for $72, good for
several wheels they say).  This kit seems to be disappearing from the
POR-15 website, so maybe being discontinued  POR-15 products I've used in
the past have worked exactly as advertised.

http://www.eastwood.com/por-15-steering-wheel-repair-kit.html?srccode=ga220010&utm_source=google&utm_medium=cpc&utm_campaign=zzproduct_ads&adtype=pla&kw=&gclid=COz52MqizrICFcxcMgodlDIAPg

Don
1962 TR3B TSF202L

On Mon, Sep 24, 2012 at 8:53 AM, Andrew Uprichard
<[email-masked]>wrote:

> http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: George Richardson <[email-masked]>
Date: Mon, 24 Sep 2012 06:14:24 -0400

George Richardson

---

From: "Andrew Uprichard" <[email-masked]>
Date: Mon, 24 Sep 2012 08:53:13 -0400

Andrew.

-----Original Message-----

George Richardson

---

From: Don Hiscock <[email-masked]>
Date: Mon, 24 Sep 2012 09:17:32 -0400

Don
1962 TR3B TSF202L