Subject: [TR] Uncle Dave at TRF picnic, condition?

From: Janis Dabars <[email-masked]>
Date: Wed, 8 Aug 2012 09:35:56 -0700 (PDT)

Been some mention about Uncle , Perfesser DAVE
of TRF, after/during the summer
picnic--in a few recent posts.  WHAT IS GOING 
ON?  pleasse inform the rest of
the posters/readers who are in the dark about 
Daves' condition, if you know
the honest skinney.  How about Charles, Albert OR
Tomy Beaver of Indy?  PLEASE
RSVP ASAP.
Johny with meny broken limbs in Indianapolis, Indiana, U.S.A. 
RACING CAPITAL OF 
THE WORLD

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Anthony Cascio <[email-masked]>
Date: Wed, 08 Aug 2012 14:21:41 -0400

OK here is the scoop.
Dave as you all know works the summer party in almost every area from greeting campers to organizing all sorts of things, including selling parts and answering questions for the masses.
He worked the autocross and it was pretty hot out there, when he returned to TRF that same day and before the dinner, collapsed and was taken to the hospital by the paramedics. There he remained until yesterday I believe, to get fully checked out, heat exhaustion was the diagnosis and he is back to work today so I am told.
I haven't spoken to him yet today but I will.
Some of this info was passed to me from his daughter so it's pretty accurate.
We all hope he is in great health and feels much better.

Tony Cascio
58 TR3A
TS27093L
[email-masked]
www.triumphowners.com/1489