Subject: [TR] Caliper O-Ring

From: "Wbeech" <[email-masked]>
Date: Sat, 4 Aug 2012 16:53:08 -0500

OK, I know we are not supposed to split the calipers but they were really
old and nasty on this TR3B, I had to scrape the rust and crud out of the
groves along with the bits of rubber seals. 
 
The re-build kit does not include the O-Ring between the calipers, TRF does
not sell them, guessing that Moss does not either as they are not listed.
Does anyone have a source for these to little o-rings?  Maybe Mc-Carr?
 
Thanks,
Bill B

Bill Beecher
'58 TR3A TS/30766L "Tarbaby"
'62 TR3B TCF/2549L " Aunt B"
www.triumphowners.com/1566
'68 Land Rover Series IIa 88" "The Beast"
"If you think you have everything under control... You're driving too slow"
M.Andretti

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: rod Trunnell <[email-masked]>
Date: Sat, 4 Aug 2012 15:11:33 -0700

I see the seal is still listed by Moss,
61	583-821	$7.95
SEAL, between caliper halves
caliper illus. "B" - TR3A from TS56337 (wire wheels), TS56384 (disc wheels),
TR3B (TSF series), TR4 to CT4689 (wire wheel	2
I used this seal when I rebuilt my calipers and have not had any issues with
it.

Rod

---

From: Geo Hahn <[email-masked]>
Date: Sat, 4 Aug 2012 15:22:02 -0700

This?
http://www.mossmotors.com/Shop/SearchResults.aspx?SearchText=583-820&WebCatalogID=0

G

---

From: "Randall" <[email-masked]>
Date: Sat, 4 Aug 2012 15:27:10 -0700

Moss does have them listed.  Either 583-821 or 583-820, depending on whether
you have the first or second generation split calipers.  (According to Moss,
your TCF series would have the 2nd gen caliper and take 583-820.)

IIRC the later seal is a standard size O-ring; while the earlier seal had a
rectangular cross section.  That may explain why the early seal is almost 3
times the price of the later one!

-- Randall

---

From: "Wbeech" <[email-masked]>
Date: Sat, 4 Aug 2012 17:41:19 -0500

There it is, too late in the day I guess.  Mine is a TCF so 583-820 is right
for me.
Many thanks!
Bill 

  Trunnell [mailto:[email-masked]] 
Sent: Saturday, August 04, 2012 5:12 PM
To: Wbeech
Cc: <[email-masked]>
Subject: Re: [TR] Caliper O-Ring

61 <http://www.mossmotors.com/Shop/ViewProducts.aspx?PlateIndexID=29146#top>
583-821	 $7.95	 

Rod 

Thanks,
Bill B

Bill Beecher