Subject: [TR] TR4 brake light switch

From: Angelo Graham <[email-masked]>
Date: Mon, 27 Aug 2012 15:36:40 -0400

Hello List:
Wondering if anyone has found a brake light switch that will work on the 
TR4/4A master cylinder bracket. I have used a big 3 'replacement' switch 
with very early failure. Has anyone sourced a readily available switch 
(FLAPS) that might work on the bracket?
Thanks for any help with this one - before I order another switch.
Angelo Graham

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Bob" <[email-masked]>
Date: Mon, 27 Aug 2012 16:28:22 -0400

If the TR4 switch is like the TR6 switch, here's a couple of inexpensive yet 
quality alternatives http://tr6.danielsonfamily.org/AltBrakeSwitch.htm

Bob

Bob Danielson
http://tr6.danielsonfamily.org/

1975 TR6 modified with:
-Throttle Body Injection
-Toyota 5 Speed
-Nissan Differential
-AAW Wire Harness
-CVJs... and more

-----Original Message----- 
From: Angelo Graham
Sent: Monday, August 27, 2012 3:36 PM
To: [email-masked]
Subject: [TR] TR4 brake light switch

Hello List:

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: 
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: <[email-masked]>
Date: Mon, 27 Aug 2012 18:29:37 -0400

FWIW, I had early failure with the one I got from my FLAPS.  Sorry I don't know the application.  When I tried to buy a replacement (different FLAPS) they couldn't figure out what it was from either.

The repro switch I got from TRF has been working well for a couple of years now.

Also FWIW, I kind of suspect the FLAPS switch failed because it got contaminated with DOT 5.

-- Randall