Subject: [TR] TR3 Coil Spring Length?

From: <[email-masked]>
Date: Sun, 29 Jul 2012 23:25:17 -0500

Measured my 3B front coil springs and they are 10.75" long, relaxed.  The
Moss catalog says they should be 9.75" or 10.25"(TR4) in length.  Any I
running any risk with this longer spring or should I just expect a little
stiffer front suspension?
 
Thanks,
Bill
 
Bill Beecher
'58 TR3A TS/30766L "Tarbaby"
'62 TR3B TCF/2549L " Aunt B"
 <http://www.triumphowners.com/1566> www.triumphowners.com/1566
'68 Land Rover Series IIa 88" "The Beast"
"If you think you have everything under control... You're driving too slow"
M.Andretti

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Randall" <[email-masked]>
Date: Mon, 30 Jul 2012 11:45:06 -0700

> stiffer front suspension?

The risks would be being too stiff, or too soft, or too low, or too high.
Since they are the wrong springs, just the free length doesn't tell you very
much.

But changing springs isn't a horrible job, so they might be worth a try.

Just curious, do they have the spacers?

-- Randall