Subject: [TR] Rimmer Bros - question about shipping charges to US

From: aribert neumann <[email-masked]>
Date: Fri, 20 Jul 2012 22:01:46 -0400

Greetings:

For those of you who have ordered small parts from Rimmer Brothers - do
they offer a slower, discounted shipping via Royal Mail to the US?  I am
considering buying a trans gear from them but I really do not need it in
two or three days if I can save some money.  RImmers was aprox $50 +
shipping).  I also checked at TRF (NLS), SpitBits (not available), BPNW (no
listings for individual internal trans parts)  & Vicky Brit ($99 +
shipping).  I figure that all the parts combined that I am considering
buying would easily fit in a modest size shoe box and weigh less than 10
lbs.

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Chad <[email-masked]>
Date: Fri, 20 Jul 2012 19:12:57 -0700 (PDT)

It seems to me that 2 pounds is the break point for UK - US shipments.  From
there up, the price goes astronomical.
 
I can't figure out why their postal
costs are so high.  I don't recall them having "slow" service.
 
Chad in Tulsa
________________________________
 From: aribert neumann <[email-masked]>
To: [email-masked] 
Sent: Friday, July 20, 2012 9:01 PM
Subject: [TR]
Rimmer Bros - question about shipping charges to US
  
Greetings:

For those
of you who have ordered small parts from Rimmer Brothers - do
they offer a
slower, discounted shipping via Royal Mail to the US?  I am
considering buying
a trans gear from them but I really do not need it in
two or three days if I
can save some money.  RImmers was aprox $50 +
shipping).  I also checked at
TRF (NLS), SpitBits (not available), BPNW (no
listings for individual internal
trans parts)  & Vicky Brit ($99 +
shipping).  I figure that all the parts
combined that I am considering
buying would easily fit in a modest size shoe
box and weigh less than 10
lbs.

Donate:
http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Randall" <[email-masked]>
Date: Sat, 21 Jul 2012 00:08:07 -0700

> they offer a slower, discounted shipping via Royal Mail to 
> the US? 

When I asked a few years ago, they flat refused to ship by any means other
than airmail.  IIRC, Royal Mail will only handle packages under 2kg (4.4
pounds); anything larger has to go through ParcelForce.

When I talked another UK vendor into sending by ParcelForce economy
(surface), the package disappeared for about 3 weeks and then got returned
to them.  No refunds, I wound up paying for delivery twice in order to get
my parts.

-- Randall

---

From: John Macartney <[email-masked]>
Date: Sat, 21 Jul 2012 11:09:30 +0100 (BST)

Randall wrote:
When I talked another UK vendor into sending by ParcelForce
economy
(surface), the package disappeared for about 3 weeks and then got
returned
to them.  
 
Which perhaps goes some way to explaining why that
august organisation is known in the UK as ParcelFarce............?
 
Jonmac