Subject: [TR] Cleaning Fluid

From: <[email-masked]>
Date: Fri, 1 Jun 2012 11:41:08 -0500

I think we have always brought the subject of lube & hydro fluifs to a
pretty fine point on this list.  But, what about cleaning, degreasing,
fluids?  As I begin a new project I am starting to have to fight the 50
years of buildup on this latest acquisition.
 
I bought the ZEP Purple degreaser, this stuff seems to work real good, wear
gloves and don't let it get into an open cut.  My only complaint is that it
has a slick film residue that really requires some clean water scrubbing
after you have degreased your part.
 
So what EPA compliant(or not) compound are you using?  Pros & Cons?
 
Inquiring minds need to know,
Bill

Bill Beecher
'58 TR3A TS/30766L "Tarbaby"
'62 TR3B TCF/2549L
 <http://www.triumphowners.com/1566> www.triumphowners.com/1566
'68 Land Rover Series IIa 88" "The Beast"
"Hello, my name is Bill and I own an old British car.  Now...What are the
next 11 steps?"

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Dave" <[email-masked]>
Date: Fri, 1 Jun 2012 13:40:16 -0500

I have had great success with (depending upon the severity)

carb cleaning fluid (buy from walmart, not flaps); add fine steel wool 
(0000) where necessary

orange cleaning fluid from the dollar store

a couple gallons of that cleaning solution (comes in a 1 gal can; has a 
little plastic parts holder in it)

and for a more macro approach, buy a good power washer.

---

From: "Mack, Michael (Rochester)" <[email-masked]>
Date: Fri, 1 Jun 2012 18:58:47 +0000

I've had good success with Simple Green.  I used it undiluted on the outside
of my Spitfires tranny and cleaned up some vinyl GT6 seats.  I bought a gallon
pretty cheap at BJs wholesale club.  Sam's Club probably has it also.

Mike Mack
80 TR8
73 Stag
79 Spit
70 GT6