Subject: Re: [TR] Float bowls overflowing

From: [email-masked]
Date: Thu, 10 May 2012 15:50:00 -0400 (EDT)

Roger,
 
Cracked floats would do it!  The floats get saturated with fuel and  don't 
"float" anymore!  I would suspect your fuel pump pressure but you  said it 
ran fine with that fuel pump until now.  I assume you're  using a fuel filter 
so we can rule out nasty bits of dirt clogging the  valves....if the float 
level is set to spec and the pump hasn't suddenly decided  to put out 8 or 
10psi, I'm guessing that there's a crack in one of your  floats.
 
Chip Krout
Delaware Valley Triumphs, Ltd.
Skippack,  PA
1976 TR6 CF57822U

In a message dated 5/10/2012 12:07:24 P.M. Eastern Daylight Time,  
[email-masked] writes:

Assuming  I haven't botched installing the needle valves and floats, is 
there anything  besides excess fuel pressure that would cause the bowls to  
overflow?

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Frank Fisher <[email-masked]>
Date: Thu, 10 May 2012 14:53:28 -0700 (PDT)

im leaning away from fuel pump pressure as he only has one bowl leaking
Frank
From: "[email-masked]" <[email-masked]>
To: [email-masked];
[email-masked] 
Sent: Thursday, May 10, 2012 12:50 PM
Subject: Re:
[TR] Float bowls overflowing

Roger,

Cracked floats would do it!  The floats
get saturated with fuel and  don't 
"float" anymore!  I would suspect your
fuel pump pressure but you  said it 
ran fine with that fuel pump until now. 
I assume you're  using a fuel filter 
so we can rule out nasty bits of dirt
clogging the  valves....if the float 
level is set to spec and the pump hasn't
suddenly decided  to put out 8 or 
10psi, I'm guessing that there's a crack in
one of your  floats.

Chip Krout

In a message dated 5/10/2012 12:07:24 P.M. Eastern
Daylight Time,  
[email-masked] writes:

Assuming  I haven't botched
installing the needle valves and floats, is 
there anything  besides excess
fuel pressure that would cause the bowls to  
overflow?

**
[email-masked] **

Donate: http://www.team.net/donate.html
Archive:
http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Roger Elliott <[email-masked]>
Date: Sat, 12 May 2012 12:21:58 -0500

I want to thank everyone for the suggestions and ideas.

I hooked up a pressure gauge today - fuel pressure was almost 10 psi.  I 
put in a pressure regulator and the pressure is now just over 2 1/2 psi.

I now have it set so it is running about 95% right. I think I just need 
to make the carbs a little richer.

Just to follow up on a couple of suggestions.  I could not detect any 
gas in the floats that were originally in the carbs.   I replaced them 
and still had the overflow problem.

The floats are the solid plastic ones - no metal arms. I set them so a 
drill bit between 1/8" and 3/16" inches (per Spit manual) would just 
roll under the float.

So I think I am all set.  Thanks again for all of the ideas.

Roger Elliott

On 05/10/2012 04:53 PM, Frank Fisher wrote:
> imleaning away from fuel pump pressure as he only has one bowl leaking
> Frank
>
> *From:* "[email-masked]" <[email-masked]>
> *To:* [email-masked]; [email-masked]
> *Sent:* Thursday, May 10, 2012 12:50 PM
> *Subject:* Re: [TR] Float bowls overflowing
>
> Roger,
>
> [email-masked] <mailto:[email-masked]> writes:
>