Subject: [TR] Float bowls overflowing

From: Roger Elliott <[email-masked]>
Date: Thu, 10 May 2012 09:56:34 -0500 (GMT-05:00)

Hi,

I have a 1980 Spitfire with dual SU HS4 carbs.  I noticed while trying to get to run correctly that the front fuel bowl had gas coming out the top vent hole.  

Figuring that it was the needle valve sticking, I replaced the needle valves and floats in both fuel bowls.  

The front bowl (second in fuel line) contined to overflow.  I thought that there may be a crack or something in the lid, so I dug out different lid, put the new bowls and valves in the lids, made sure the float adjustment is correct. 

These lids have vent tubes, which I have connected with fuel hose - above the carbs.
 
Well, gas is coming out of the vent hose connected to the vent tubes  - not sure which carb is overflowing at this point as I did not think to disconnect them until after I stopped working on them for the evening. 

The fuel line now has a T-connector to get gas to both carbs.  Previously, the rear carb had a fuel pass through.

I have a mechanical fuel pump, not original.  But one sold by one of the big vendors - don't remember which now.

Can the mechanical pumps put out too much pressure?  The pump has been on for a few years and it has run correctly in the past.

Assuming I haven't botched installing the needle valves and floats, is there anything besides excess fuel pressure that would cause the bowls to overflow?

Thanks,
Roger Elliott
1980 Spitfire

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Randall" <[email-masked]>
Date: Thu, 10 May 2012 09:25:56 -0700

> Can the mechanical pumps put out too much pressure?  The pump 
> has been on for a few years and it has run correctly in the past.

Definitely a possibility, but I've never heard of them going up on their
own.  Might be worth checking with a gauge, though.  Most vacuum test gauges
will also read fuel pump pressure.

> Assuming I haven't botched installing the needle valves and 
> floats, is there anything besides excess fuel pressure that 
> would cause the bowls to overflow?

Most common cause for me is crud in the fuel.  Sometimes the soft fuel lines
can fail and shed bits into the fuel (after the filter) that jam the valve
open.

Defective new parts is also a possibility.  In particular, many plastic
floats don't get along well with gasohol.  And I've seen several "Grose
Jets" that leak for no apparent reason.

One easy test is to hold the lid upside down with the float and valve
installed, and try to blow into the inlet.  The weight of the float should
be enough to hold the valve closed.

-- Randall

---

From: Frank Fisher <[email-masked]>
Date: Thu, 10 May 2012 10:00:55 -0700 (PDT)

Roger
there is an adjustment to be made that sets the height the float bowl
comes to and closes the needle valve.
on my TR3 there is a 2 finger hinge like
device that is curved.
you set the height by checking it with a specific drill
diameter.
i cant recall the exact diameter but im sure some one will tell us.
check your workshop manual, it will have pictures.
Frank

From: Roger Elliott
<[email-masked]>
To: [email-masked] 
Sent: Thursday, May 10, 2012
7:56 AM
Subject: [TR] Float bowls overflowing

Hi,

I have a 1980 Spitfire
with dual SU HS4 carbs.  I noticed while trying to get to run correctly that
the front fuel bowl had gas coming out the top vent hole.  

Figuring that it
was the needle valve sticking, I replaced the needle valves and floats in both
fuel bowls.  

The front bowl (second in fuel line) contined to overflow.  I
thought that there may be a crack or something in the lid, so I dug out
different lid, put the new bowls and valves in the lids, made sure the float
adjustment is correct. 

These lids have vent tubes, which I have connected
with fuel hose - above the carbs.

Well, gas is coming out of the vent hose
connected to the vent tubes  - not sure which carb is overflowing at this
point as I did not think to disconnect them until after I stopped working on
them for the evening. 

The fuel line now has a T-connector to get gas to both
carbs.  Previously, the rear carb had a fuel pass through.

I have a
mechanical fuel pump, not original.  But one sold by one of the big vendors -
don't remember which now.

Can the mechanical pumps put out too much
pressure?  The pump has been on for a few years and it has run correctly in
the past.

Assuming I haven't botched installing the needle valves and floats,
is there anything besides excess fuel pressure that would cause the bowls to
overflow?

Thanks,
Roger Elliott
1980 Spitfire

Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Wbeech <[email-masked]>
Date: Thu, 10 May 2012 13:32:31 -0500

Should be 3/8", easy measure is to hold the lid upside down and lay a 3/8".
Bolt across it. Your wishbone should just touch it where it meets the float.

Sent from mobile Bill

> Forums: http://www.team.net/forums
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: John Macartney <[email-masked]>
Date: Thu, 10 May 2012 21:52:56 +0100 (BST)

Just found this titbit of info from the SU website if it helps anyone?
B 
Jonmac
B 
B 
"There are several different float settings depending on which
type of 
carburetter/float set up you have. Listed below are the most common
options.

T1 (1 7/8b OD) and T2 (2 1/4" OD) Float chambers. With the float
chamber lid inverted and the hinge lever resting on the float needle, it
should 
be possible to just slide a 7/16b diameter between the radius of the
hinge lever 
and the face of the float chamber lid. 
T4 (3b OD). A 5/8b
test bar should be used. Early HS carburetters with brass floats. A 5/16b
test 
bar should be used.
HS carbs with the early nylon float and steel
needle. 
The gap between the lever and the face of the lid should be between
0.125b and 
0.187b.
HS carbs with the later all nylon float and delrin
type needle. 
The gap between the float and the lid face should be between
0.062b and 0.187b 
with the float resting on the needle but not depressing
it. This type is non 
adjustable."