Subject: [TR] correct color question

From: "Dave" <[email-masked]>
Date: Tue, 15 May 2012 07:47:40 -0500

valve cover 63 tr4
valve cover 75 spitfire
air cleaner 75 spitfire
hood prop rod 75 spitfire

thank you!

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Bob Labuz <[email-masked]>
Date: Tue, 15 May 2012 11:18:01 -0400

Dave,

Cant answer for the Spits, but the 63 TR4 is chrome plated like the TR3 
but with the oil fill/breather at the rear of the cover.

Bob

On 05/15/2012 08:47 AM, Dave wrote:
> Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]