Subject: Re: [TR] K & N air filters

From: Dennis Culligan <[email-masked]>
Date: Fri, 18 May 2012 10:19:23 -0400

OK, that explains it b Ibve never seen one wrapped in plastic. I wondered
how

they kept the oil from running all over and damaging the packagingb&

Dennis Culligan, Highland, NY / Land of the dry K & N filters

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, May 18, 2012 8:49 AM
To: Al Salvatore; Dennis Culligan; [email-masked]
Subject: Re: [TR] K & N air filters

If they're  red and wrapped in plastic, they're oiled.
So far, I've got them on the mg, the triumph, the tiger, the suburban, the
mini, the morris, the Riley, and the highlander.
All came ready to go. I suppose its POSSIBLE they sell some somewhere that
aren't.  I buy them on line.
Perhaps k&n sells a cheap, non oiled filter over the counter and the premier
ready to go variety only to me!  ;-)

Sent from my Verizon Wireless Phone

----- Reply message -----
From: "Al Salvatore" <[email-masked]>
To: "Dennis Culligan" <[email-masked]>, <[email-masked]>,
<[email-masked]>
Subject: [TR] K & N air filters
Date: Fri, May 18, 2012 06:18

I haven't seen them pre oiled either.

Al

----- Original Message ----- From: <[email-masked]>
To: "Dennis Culligan" <[email-masked]>; <[email-masked]>
Sent: Thursday, May 17, 2012 11:14 PM
Subject: Re: [TR] K & N air filters

> Huh...every k&n I ever bought had the oil already applied to the filter. > I
don't think they sell them dry.
>
> Sent from my Verizon Wireless Phone
>
> ----- Reply message -----
> From: "Dennis Culligan" <[email-masked]>
> To: <[email-masked]>
> Subject: [TR] K & N air filters
> Date: Thu, May 17, 2012 17:04
>
>
> Re:  K & N air filters:
>
> The cleaner stuff is very similar to Formula 409.
>
> My local FLAPS sold me both the cleaner and the oil for $10.95.
>
> No new K & N air filter I have ever seen is pre-oiled. The oil is red so >
you
> can tell if you've
>
> completely covered the entire surface area.
>
> YMMV.
>
> Dennis Culligan, Highland NY / 1976 TR6 CF57948U

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Frank Fisher <[email-masked]>
Date: Fri, 18 May 2012 10:18:17 -0700 (PDT)

Dennis
there not all sloppy drippy wet.
there just moist
Frank

From: Dennis
Culligan <[email-masked]>
To: [email-masked]; 'Al Salvatore'
<[email-masked]>; [email-masked] 
Sent: Friday, May 18, 2012
7:19 AM
Subject: Re: [TR] K & N air filters

OK, that explains it b Ibve never
seen one wrapped in plastic. I wondered
how

they kept the oil from running
all over and damaging the packagingb&

Dennis Culligan, Highland, NY / Land
of the dry K & N filters

From: [email-masked]
[mailto:[email-masked]]
Sent: Friday, May 18, 2012 8:49 AM
To: Al
Salvatore; Dennis Culligan; [email-masked]
Subject: Re: [TR] K & N
air filters

If they're  red and wrapped in plastic, they're oiled.
So far,
I've got them on the mg, the triumph, the tiger, the suburban, the
mini, the
morris, the Riley, and the highlander.
All came ready to go. I suppose its
POSSIBLE they sell some somewhere that
aren't.  I buy them on line.
Perhaps
k&n sells a cheap, non oiled filter over the counter and the premier
ready to
go variety only to me!  ;-)

----- Reply
message -----
From: "Al Salvatore" <[email-masked]>
To: "Dennis
Culligan" <[email-masked]>, <[email-masked]>,
<[email-masked]>
Subject: [TR] K & N air filters
Date: Fri, May 18, 2012
06:18

Al

----- Original Message
----- From: <[email-masked]>
To: "Dennis Culligan" <[email-masked]>;
<[email-masked]>
Sent: Thursday, May 17, 2012 11:14 PM
Subject: Re:
[TR] K & N air filters

>
> My local FLAPS sold me
both the cleaner and the oil for $10.95.
>
> No new K & N air filter I have
ever seen is pre-oiled. The oil is red so >
you

Donate:
http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Randall" <[email-masked]>
Date: Fri, 18 May 2012 11:38:03 -0700

I know there are some folks out there who buy "raw" K&N filters and then
repackage them along with the metal parts to mount to SU & ZS carbs.
Perhaps the repackagers are the ones that oil them and wrap in plastic?  

Just a thought.  Personally I intend to stick with paper elements for the
street, as I believe they do a better job of keeping dirt out of the engine
and I'm willing to sacrifice a horsepower or two to avoid having to re-ring
every few years.  But then I drive probably 10,000 miles/year, while some
folks will never put that much on their TRs.

-- Randall