Subject: [TR] Brake light switch

From: Robert Jones <[email-masked]>
Date: Sat, 26 May 2012 19:41:55 -0500

Does anyone have a good original round brake light switch for a TR6 they would
be willing to part with?
 I got one of the current square Lucas switches and it fell apart installing
it.  The round one lasted for 37 years.
Thanks

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: Mark J Bradakis <[email-masked]>
Date: Sat, 26 May 2012 19:02:52 -0600

If it doesn't offend your sensibilities, go to a Honda dealer and
get one for an '87 Civic Si.

mjb.

---

From: Chad <[email-masked]>
Date: Sun, 27 May 2012 04:32:11 -0700 (PDT)

Go to O'Reilly's Auto Parts and get one to fit a '71 Ford truck.  It runs
about $6 and has a lifetime warranty.

Chad in Tulsa
________________________________
 From: Robert Jones <[email-masked]>
To:
[email-masked] 
Sent: Saturday, May 26, 2012 7:41 PM
Subject: [TR]
Brake light switch
 
Does anyone have a good original round brake light switch
for a TR6 they would
be willing to part with?
I got one of the current square
Lucas switches and it fell apart installing
it.  The round one lasted for 37
years.
Thanks

Donate:
http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums:
http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Bob Danielson" <[email-masked]>
Date: Sun, 27 May 2012 08:19:28 -0400

I just picked these two up on eBay to compare the quality and posted the 
results on my site (http://tr6.danielsonfamily.org/AltBrakeSwitch.htm)  Both 
appear to be of excellent quality with all metal construction except for the 
plastic insulator at the connection end. They're also easy to install and 
infinitely adjustable. No need to bend the mounting tab with these guys.

If you want to give a shot at repairing the original switch here's how I did 
that and it lasted for about a year 
(http://tr6.danielsonfamily.org/BrakeSwitch.htm)

Bob

Bob Danielson
http://tr6.danielsonfamily.org
1975 TR6 with:
Throttle Body Injection
Toyota 5 Speed
Nissan Diff & CVJs

-----Original Message----- 
From: Robert Jones
Sent: Saturday, May 26, 2012 8:41 PM
To: [email-masked]
Subject: [TR] Brake light switch

Does anyone have a good original round brake light switch for a TR6 they 
would
be willing to part with?
I got one of the current square Lucas switches and it fell apart installing
it.  The round one lasted for 37 years.
Thanks

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: 
http://autox.team.net/mailman/options/triumphs/[email-masked]