Subject: [TR] Experience with PRIRace.com?

From: David Ljung Madison <[email-masked]>
Date: Thu, 03 May 2012 20:06:30 -0700

Looking into options for rebuilding my TR3 engine I came across:

  http://prirace.com/page/triumph-tr3-engines

Has anyone on the list used them for an engine rebuild?

Dave

---------------------------------------------------------------------------
Dave Ljung Madison          http://GetDave.com/                415.341.5555
--------------------------- 1+1=3 for large 1 -----------------------------

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "TeriAnn J. Wakeman" <[email-masked]>
Date: Fri, 04 May 2012 08:00:27 -0700

> Has anyone on the list used them for an engine rebuild?
Not I.  But looking at their list of things they do and the price they 
ask my first thought is that they may not know the TR fours very well 
and my second thought is that you will still get a better rebuild from 
Greg Solow's engine Room in Santa Cruz for the price.  Since Greg races 
a Morgan and has had one for ever that is the one engine they know the 
most about.  It is THE place I trust to build a TR2-4A engine properly 
and to know how to address inherent weaknesses.

Any automotive machine shop can rebuild a TR engine and have it run at 
the end of the process.  But if you want the engine to run its best for 
an extended period of time, sometimes it is best to seek out someone who 
specialized in that particular engine.

Just my own biased opinion,

Teriann