Subject: Re: [TR] Float bowls overflowing

From: Cliff Hansen <[email-masked]>
Date: Thu, 10 May 2012 10:34:34 -0600 (GMT-06:00)

Roger,

I had the same problem with a 4A with HS6 carbs and an electrical pump.  Turned out that the fuel pressure was too high.  I added a fuel pressure regulator and dialed it down to 1.5lbs, car ran fine and no more fuel leaks (plenty of other leaks but that's a different story).

That was 20 years ago and the regulator was about $12.  I don't know where to get one today.

Best,

Cliff

-----Original Message-----
>From: Roger Elliott <[email-masked]>
>Sent: May 10, 2012 8:56 AM
>To: [email-masked]
>Subject: [TR] Float bowls overflowing
>
>Hi,
>
>I have a 1980 Spitfire with dual SU HS4 carbs.  I noticed while trying to get to run correctly that the front fuel bowl had gas coming out the top vent hole.  
>
>Figuring that it was the needle valve sticking, I replaced the needle valves and floats in both fuel bowls.  
>
>The front bowl (second in fuel line) contined to overflow.  I thought that there may be a crack or something in the lid, so I dug out different lid, put the new bowls and valves in the lids, made sure the float adjustment is correct. 
>
>These lids have vent tubes, which I have connected with fuel hose - above the carbs.
> 
>Well, gas is coming out of the vent hose connected to the vent tubes  - not sure which carb is overflowing at this point as I did not think to disconnect them until after I stopped working on them for the evening. 
>
>The fuel line now has a T-connector to get gas to both carbs.  Previously, the rear carb had a fuel pass through.
>
>I have a mechanical fuel pump, not original.  But one sold by one of the big vendors - don't remember which now.
>
>Can the mechanical pumps put out too much pressure?  The pump has been on for a few years and it has run correctly in the past.
>
>Assuming I haven't botched installing the needle valves and floats, is there anything besides excess fuel pressure that would cause the bowls to overflow?
>
>Thanks,
>Roger Elliott
>1980 Spitfire
>
>** [email-masked] **
>
>Donate: http://www.team.net/donate.html
>Archive: http://www.team.net/archive
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: "Dave Connitt" <[email-masked]>
Date: Thu, 10 May 2012 19:34:11 -0400

In rebuilding my SU HS-6 carburetors, I came across some information myself..
If you remove the vacumn domes and pistons, with the float bowls full the fuel
should to sit just below the main jets. If the bridge in the carb where the
main jet sits is wet, then the floats are set too high. I haven't had a chance
to actually prove this since my TR is not running yet but it does kind of make
sense in the simplicity of it..
Dave Connitt

---

From: Roger Elliott <[email-masked]>
Date: Fri, 11 May 2012 08:55:17 -0500 (GMT-05:00)

/local/mailman/lynxXXXXUegFf3: Permission denied