Subject: [TR] need door handle

From: Robert Hendricks <[email-masked]>
Date: Fri, 20 Apr 2012 10:23:36 -0600

Hello all. Im new to this mailing list. I hope this is an appropriate request. 

After a two year frame off complete restoration - the tub is at the paint shop and I discover that a piece in one of my doors is broken.  I am looking for the left exterior door handle with mechanism for a 1972 Triumph Spitfire.  A little plastic gizmo inside the mechanism is broken.  I am hoping to purchase a used handle so I can retrieve the broken piece from it.

Thanks

Bob

** [email-masked] **

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/triumphs/[email-masked]

---

From: <[email-masked]>
Date: Fri, 20 Apr 2012 11:35:19 -0500

Bob,

Welcome to the list, odd parts, advice and sources are what we do best.
Wish I could help but I don't have Spit.

All the best,
Bill

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Robert Hendricks
Sent: Friday, April 20, 2012 11:24 AM
To: [email-masked]
Subject: [TR] need door handle

Hello all. Im new to this mailing list. I hope this is an appropriate
request. 

After a two year frame off complete restoration - the tub is at the paint
shop and I discover that a piece in one of my doors is broken.  I am looking
for the left exterior door handle with mechanism for a 1972 Triumph
Spitfire.  A little plastic gizmo inside the mechanism is broken.  I am
hoping to purchase a used handle so I can retrieve the broken piece from it.

Thanks

Bob

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage:
http://autox.team.net/mailman/options/triumphs/[email-masked]