Subject: Re: [Tigers] Carburetor input

From: H B Elam via Tigers <[email-masked]>
Date: Wed, 21 Apr 2021 17:54:47 -0400

Have used both Holly and parts store standard. My problem had been fuel boil over after returning to garage. It seemed that the boil over defeated the float valve and emptied that float chambers. I solved the problem with heat spacers from a guy out of Pittsburgh. 

Regards,
Harry 

> On Apr 21, 2021, at 5:48 PM, Gary <[email-masked]> wrote:
> 
> Harry,
> What kind of check valves?
> Photos?
> Thanks,
> Gary
> 
> 
> Sent from my iPhone
> 
>> On Apr 21, 2021, at 2:09 PM, H B Elam via Tigers <[email-masked]> wrote:
>> 
>> Hi all!
>> I have had elex fuel pump problems since 1964 & an MGA. In my Tiger I have two pumps piped in parallel. There is no shifting valve as both have check valves. I only shift them electrically. The stock SU idles at 3.5 psi and the aftermarket at 4.2 psi. While I really can not notice any performance change I only use the aftermarket for troubles or autocrossing. The issue is not the carb but the float valve. My research indicated that most float valves are good for 7 psi. 
>> 
>> Harry Elam
>> B382000471
>> _______________________________________________
>> 
>> [email-masked]
>> 
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive
>> 
>> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
>> 
>> 
> 
_______________________________________________

[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: Terry Lawell via Tigers <[email-masked]>
Date: Wed, 21 Apr 2021 20:35:22 -0500

Thanks for the inputs. The volume on this pump is 38 gal/hr and I think 
the standard su is about 28gal/hr, so that should not be a problem. I 
will probably install a good regulator and set the psi to about 5psi.
On 4/21/21, 4:54 PM, H B Elam via Tigers wrote:
> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
>
>

[email-masked]

---

From: Ron Fraser via Tigers <[email-masked]>
Date: Wed, 21 Apr 2021 23:04:12 -0400

Terry
	The Shop Manual indicates that the Tiger SU fuel pump delivers 15 Gal/ hour.
That rate of fuel is adequate for about 200 HP so it easily covers the fuel requirements for the MK I and Mk II.

I believe the Tiger's 5/16" fuel line has the capacity to supply up to 300 HP, around 400 HP you need 3/8" line to supply adequate amount of fuel.
Ron Fraser

-----Original Message-----
From: Tigers <[email-masked]> On Behalf Of Terry Lawell via Tigers
Sent: Wednesday, April 21, 2021 9:35 PM
To: [email-masked]
Subject: Re: [Tigers] Carburetor input

Thanks for the inputs. The volume on this pump is 38 gal/hr and I think the standard su is about 28gal/hr, so that should not be a problem. I will probably install a good regulator and set the psi to about 5psi.

[email-masked]

Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

[email-masked]