Subject: [Tigers] Carburetor input

From: H B Elam via Tigers <[email-masked]>
Date: Wed, 21 Apr 2021 17:03:36 -0400

Hi all!
I have had elex fuel pump problems since 1964 & an MGA. In my Tiger I have two pumps piped in parallel. There is no shifting valve as both have check valves. I only shift them electrically. The stock SU idles at 3.5 psi and the aftermarket at 4.2 psi. While I really can not notice any performance change I only use the aftermarket for troubles or autocrossing. The issue is not the carb but the float valve. My research indicated that most float valves are good for 7 psi. 

Harry Elam
B382000471
_______________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: Gary via Tigers <[email-masked]>
Date: Wed, 21 Apr 2021 14:48:16 -0700

Harry,
What kind of check valves?
Photos?
Thanks,
Gary

Sent from my iPhone

> On Apr 21, 2021, at 2:09 PM, H B Elam via Tigers <[email-masked]> wrote:
> 
> Hi all!
> Donate: http://www.team.net/donate.html
> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
> 
> 

[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive