Subject: Re: [Tigers] Tigers Digest, Vol 14, Issue 50

From: JAMES ARMSTRONG via Tigers <[email-masked]>
Date: Sat, 17 Apr 2021 14:28:18 -0400

I too use Haggerty and have had good luck with one claim some 20 years ago. Most of the time they allow a 5% discount for TEAE, but not in Massachusetts as well as a few other states.
Jim Armstrong

Sent from my iPhone

> On Apr 17, 2021, at 1:47 PM, [email-masked] wrote:
> 
> Send Tigers mailing list submissions to
>    [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    http://autox.team.net/mailman/listinfo/tigers
> or, via email, send a message with subject or body 'help' to
>    [email-masked]
> 
> You can reach the person managing the list at
>    [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Tigers digest..."
> 
> 
> Today's Topics:
> 
>   1. Insurance (Paul Sheahan)
>   2. Re: Insurance (Tom Parker)
>   3. Re: Insurance (jimdamelio)
>   4. Re: Insurance (Dr. T. Y. McDowell)
>   5. Re: Insurance (Bob Wanty)
>   6. Re: Insurance (James Lindner)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Sat, 17 Apr 2021 08:57:27 -0400
> From: Paul Sheahan <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: [Tigers] Insurance
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=us-ascii
> 
> Tigers Owners,
>     I need to change my insurance on my Tigers.  I am currently with Nationwide.  Any suggestions would be appreciated including any experience with claims.  
> Thanks,
> Paul
> Sent from my iPad
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Sat, 17 Apr 2021 09:18:06 -0400
> From: Tom Parker <[email-masked]>
> To: Paul Sheahan <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: [Tigers] Insurance
> Message-ID:
>    <CAE3_YO8zLP6Acd=[email-masked]>
> Content-Type: text/plain; charset="utf-8"
> 
> Both Grundy and Haggarty specialize in "collector cars." I use Grundy, have
> never had a claim.
> 
> Tom
> '67 Mark 2
> 
>> On Sat, Apr 17, 2021 at 8:57 AM Paul Sheahan via Tigers <
>> [email-masked]> wrote:
>> 
>> Tigers Owners,
>>     I need to change my insurance on my Tigers.  I am currently with
>> Nationwide.  Any suggestions would be appreciated including any experience
>> with claims.
>> Thanks,
>> Paul
>> Sent from my iPad
>> _______________________________________________
>> 
>> [email-masked]
>> 
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/pipermail/tigers
>> http://autox.team.net/archive
>> 
>> Unsubscribe:
>> http://autox.team.net/mailman/options/tigers/[email-masked]
>> 
>> 
>> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://autox.team.net/pipermail/tigers/attachments/20210417/7af2abb8/attachment-0001.htm>
> 
> ------------------------------
> 
> Message: 3
> Date: Sat, 17 Apr 2021 09:33:47 -0400
> From: jimdamelio <[email-masked]>
> To: Paul Sheahan <[email-masked]>, "[email-masked]"
>    <[email-masked]>
> Subject: Re: [Tigers] Insurance
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
> 
> I use Hagerty. No claims yet. They give TEAE members a 5% discount.? I have Allstate for my daily drivers and they arranged it for me.? You tell them what you think it's worth and send pictures.? Pay once a year.Jim DSent from my Galaxy
> -------- Original message --------From: Paul Sheahan via Tigers <[email-masked]> Date: 4/17/21  8:57 AM  (GMT-05:00) To: [email-masked] Subject: [Tigers] Insurance Tigers Owners,???? I need to change my insurance on my Tigers.? I am currently with Nationwide.? Any suggestions would be appreciated including any experience with claims.? Thanks,PaulSent from my [email-masked]: http://www.team.net/donate.htmlArchive: http://www.team.net/pipermail/tigers http://autox.team.net/archiveUnsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://autox.team.net/pipermail/tigers/attachments/20210417/e30fae07/attachment.htm>
> 
> ------------------------------
> 
> Message: 4
> Date: Sat, 17 Apr 2021 09:37:34 -0400 (EDT)
> From: "Dr. T. Y. McDowell" <[email-masked]>
> To: Paul Sheahan <[email-masked]>, Paul Sheahan via Tigers
>    <[email-masked]>
> Subject: Re: [Tigers] Insurance
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=UTF-8
> 
> I've used Grundy for years.  I've never had a claim.
> 
> Tym McDowell
>> On 04/17/2021 8:57 AM Paul Sheahan via Tigers <[email-masked]> wrote:
>> 
>> 
>> Tigers Owners,
>>     I need to change my insurance on my Tigers.  I am currently with Nationwide.  Any suggestions would be appreciated including any experience with claims.  
>> Thanks,
>> Paul
>> Sent from my iPad
>> _______________________________________________
>> 
>> [email-masked]
>> 
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive
>> 
>> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
> 
> 
> ------------------------------
> 
> Message: 5
> Date: Sat, 17 Apr 2021 13:36:56 -0400
> From: Bob Wanty <[email-masked]>
> To: "Dr. T. Y. McDowell" <[email-masked]>
> Cc: Paul Sheahan <[email-masked]>, Paul Sheahan via Tigers
>    <[email-masked]>
> Subject: Re: [Tigers] Insurance
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=utf-8
> 
> I use Grundy for my Porsche and Tiger no claims yet.
> 
> Sent from my iPhone
> 
>> On Apr 17, 2021, at 9:39 AM, Dr. T. Y. McDowell <[email-masked]> wrote:
>> 
>> ?I've used Grundy for years.  I've never had a claim.
>> 
>> Tym McDowell
>>>> On 04/17/2021 8:57 AM Paul Sheahan via Tigers <[email-masked]> wrote:
>>> 
>>> 
>>> Tigers Owners,
>>>    I need to change my insurance on my Tigers.  I am currently with Nationwide.  Any suggestions would be appreciated including any experience with claims.  
>>> Thanks,
>>> Paul
>>> Sent from my iPad
>>> _______________________________________________
>>> 
>>> [email-masked]
>>> 
>>> Donate: http://www.team.net/donate.html
>>> Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive
>>> 
>>> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
>> _______________________________________________
>> 
>> [email-masked]
>> 
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive
>> 
>> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
>> 
>> 
> 
> 
> ------------------------------
> 
> Message: 6
> Date: Sat, 17 Apr 2021 13:43:25 -0400
> From: James Lindner <[email-masked]>
> To: Paul Sheahan <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Tigers] Insurance
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=utf-8
> 
> Paul
> 
> I use Hagerty. I have had one claim for some paint damage I caused through my own stupidity. They paid the claim without question. Yes, Hagerty does give TEAE members a 5% discount.
> 
> Jim L.
> 
> Sent from my iPad
> 
>> On Apr 17, 2021, at 12:34 PM, Paul Sheahan via Tigers <[email-masked]> wrote:
>> 
>> ?Tigers Owners,
>>    I need to change my insurance on my Tigers.  I am currently with Nationwide.  Any suggestions would be appreciated including any experience with claims.  
>> Thanks,
>> Paul
>> Sent from my iPad
>> _______________________________________________
>> 
>> [email-masked]
>> 
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive
>> 
>> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]
>> 
>> 
> 
> 
> 
> ------------------------------
> 
> Subject: Digest Footer
> 
> _______________________________________________
> Tigers mailing list
> [email-masked]
> http://autox.team.net/mailman/listinfo/tigers
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive
> 
> 
> ------------------------------
> 
> End of Tigers Digest, Vol 14, Issue 50
> **************************************

_______________________________________________

[email-masked]

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/pipermail/tigers http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: "Darrell Mountjoy" <[email-masked]>
Date: Sat, 17 Apr 2021 16:24:50 -0700

My 2 cents:

Stay away from Hagerty.  They screwed me on the Le Mans Tiger (long story).
They screwed a friend on his original Cobra.  Just my experience with that
company.

Darrell
B9499998, B94701035

Today's Topics:

[email-masked]