Subject: [Tigers] Limited slip diff lube

From: [email-masked]
Date: Thu, 3 Jul 2014 08:53:19 +0100

Question for Tom Hall or others. What do people recommend for LSDs? Tom built
mine so I am sure he knows. Mine has a slight leak.
Bill
_______________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: Sandy <[email-masked]>
Date: Thu, 03 Jul 2014 11:17:10 -0700

I have used Redline for Limited slip in a few cars, and in others Royal 
Purple.  If you are only a little low just top it off with what's in it. 
If a lot low you might need some additive if a clutch style to keep 
things happy.

Sandy
On 7/3/2014 12:53 AM, [email-masked] wrote:
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

[email-masked]