Subject: [Tigers] BTM Continuation Cheetahs

From: Derek Daily <[email-masked]>
Date: Wed, 8 Jan 2014 11:57:02 -0800 (PST)

Great read and pictures...
http://www.speedhunters.com/2013/08/fast-cat-the-bill-thomas-cheetah/

http://www.speedhunters.com/2013/08/btm-continuation-cheetah-up-close-and-personal/

And controversies...
http://www.cheetahcars.com

Derek Daily 
[email-masked] 
_______________________________________________

[email-masked]

Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/tigers/[email-masked]

---

From: "Bob Dixon" <[email-masked]>
Date: Wed, 8 Jan 2014 20:55:32 -0700

These little guys look awesome!  I bet they are a real handfull to drive.

----- Original Message ----- 
From: "Derek Daily" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, January 08, 2014 12:57 PM
Subject: [Tigers] BTM Continuation Cheetahs

> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe: 
> http://autox.team.net/mailman/options/tigers/[email-masked]

[email-masked]