Subject: Re: [Spridgets] Spridgets Digest, Vol 143, Issue 4

From: Gerard via Spridgets <[email-masked]>
Date: Fri, 10 Feb 2023 15:58:02 -0800

Oh man, So sorry to hear this, Ron! I communicated with Jim periodically over the years and we first met in person at the LotO 50th event (2008). We had a lot of interaction over during the run up to the Midget 50th (2011) when I was creating the graphic content and badge design for this anniversary. Most recently I helped him with advice when needed on his most recent Midget project, so this really comes as a shock.

Great guy... He contributed so much to the hobby and to everyone affiliated. Tremendous loss; He will definitely be missed by so many.

RIP JIM

Gerard 

Sent from my iPhone

On Feb 10, 2023, at 11:00 AM, [email-masked] wrote:

>>  On 02/10/2023 7:45 AM Ron Soave via Spridgets <[email-masked]> wrote:
>> 
>> 
>>    Just heard from Tiffany Clarici that Jim Johnson passed away several days ago. Jim was a huge contributor to the OSHITs, BusterCluster, Holy Sprite and many of the elements that made this list the most generous collection of people imaginable for so many years. Godspeed, Jim, and may all of your weather forecasts will be 100% spot-on. 
>> 
>>    Ron Soave
>> 
>>     https://www.swaimfuneralhome.com/obituary/james-johnson?lud=EF47675606633C434DF2E7B68245CA03 https://www.swaimfuneralhome.com/obituary/james-johnson?lud=EF47675606633C434DF2E7B68245CA03
>>    ------------------------
------------------------

[email-masked]

Archive: http://www.team.net/pipermail/spridgets  http://autox.team.net/archive

---

From: Chris Manuel via Spridgets <[email-masked]>
Date: Fri, 10 Feb 2023 18:22:35 -0600

terrible news, bummer he never got his last project done.  Many fun and informative conversations throughout all the years.  There was a fun adventure sending him a rib case transmission via Greyhound one summer where I wish I kept the email exchange as tracking was messed up.

fond memories of those times.  Safety Fast Jim.

Chris

> On Feb 10, 2023, at 1:00 PM, [email-masked] wrote:
> 
> 
> 
> --Apple-Mail-128B3B52-38BC-448A-98A3-A0BED2791029-- 
> 
> 
> 
> --Apple-Mail-432EE3ED-CF23-4249-8413-7701056F355D
> X-Apple-Content-Length: 909
> Content-Type: TEXT/HTML;
> 	charset=utf-8
> Content-Transfer-Encoding: QUOTED-PRINTABLE
> 
> 
> --Apple-Mail-432EE3ED-CF23-4249-8413-7701056F355D--
> 
> 
> 
> 
> Ryan
> 
>>    Donate: http://www.team.net/donate.html
>>    Suggested annual donation: $12.75
>> 
>>    Unsubscribe/Manage: http://autox.team.net/mailman/options/spridgets/[email-masked]
>> 
> 

------------------------

[email-masked]