Subject: Re: [Spridgets] Aluminum (or Aluminium if your in the UK) radiator

From: Rick Fisk via Spridgets <[email-masked]>
Date: Thu, 19 May 2022 19:37:13 -0400

I run my Chinese aluminum downflow radiator with a 13 pound cap.  No heater and no problems.

> On May 19, 2022, at 6:16 PM, Michael MacLean via Spridgets <[email-masked]> wrote:
> 
> 
> Bought an aluminum radiator from EBay for the Bugeye.  It's very well made with beautiful welding everywhere.  The problem is, it comes with it's own radiator cap rated at 15 pounds.  As you guys well know the Bugeye system is a 7 pound system.  Will this cause a problem somewhere else in the system because of the high pressure?  Geesh, this radiator even comes with a hex plug in the temp probe bung!  My probe is in the head of my 1275.  How convenGeese,
> Mike MacLean 
> ------------------------
> 
> [email-masked]
> 
> Donate: http://www.team.net/donate.html
> Suggested annual donation: $12.75
> 
> Archive: http://www.team.net/pipermail/spridgets  http://autox.team.net/archive
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/spridgets/[email-masked]

------------------------

[email-masked]

Donate: http://www.team.net/donate.html
Suggested annual donation: $12.75

Archive: http://www.team.net/pipermail/spridgets  http://autox.team.net/archive

Unsubscribe/Manage: http://autox.team.net/mailman/options/spridgets/[email-masked]

---

From: Billy Zoom via Spridgets <[email-masked]>
Date: Thu, 19 May 2022 16:03:44 -0700

I’m sure Soave would know the boiling temp of a 15lb system at sea level. I don’t see any reason to go that high, but what do I know.  Can't you get another cap?

------------------------

[email-masked]