Subject: Re: [Spridgets] Aluminum Radiators

From: crusaderchuck55--- via Spridgets <[email-masked]>
Date: Mon, 26 Apr 2021 16:20:44 -0400

--===============2989495240850259385==
	boundary="--_com.lge.email_4838972328099020"

----_com.lge.email_4838972328099020
   charset=utf-8
Content-Transfer-Encoding: 8bit

Ok after reading all the responses I have 1 HUGE question!! ONE!   HOW OLD is your fan belt ( read that hardened ones time which can slip) AND.... how right or loose is your belt?They slip against engine torque and against water resistance in the engine.  If your coolant is not circulating at the correct rate , it builds heat rather than dissipates it.   Also remember a 50/50 mixture of coolant & water is the professed best heat exchange ratio for a normal cooling system.   Ok fellow racers I know restrictions on antifreeze in race cars on race tracks..A simple test on the belt is grab the fan ( of course not running!   33 stitches at Summit piont a few years ago ...aw..never mind!) and rock the fan both ways.  Does it slip at all?  Even then retension your fan belt and go for a drive and see how hot it runs.   If it still runs hot , water pump impeller , improper opening thermostat or a restriction in the radiator are all possible.  But!  If it worked at 1 time there must be a fly in the ointment!  Do not just throw money at it until you diagnose it.   If you have acess to an infrared thermometer....read radiator core temperatures when hot and check top & bottom radiator hose temperatures AND CHECK the temperature of the thermostat housing!   Make notes on what is hot or cooler and you might find something wrong with circulation.Honestly I have no idea what I'm saying....but it crazy enough ... It just might work....Chuck!It's be kind to virgins month so DO NOT throw a virgin into a volcano!!!   LOL!Sent from my LG Mobile------ Original message------From: Michael MacLean via SpridgetsDate: Mon, Apr 26, 2021 12:35 PMTo: [email-masked];Cc: Subject:[Spridgets] Aluminum Radiators     My Bugeye has been running hot in any ambient temperature over 80 degrees lately.  I have the original radiator that was re-cored with an OEM type core almost 25 years ago.  I have been leaning towards getting an aluminum radiator.  Moss sells a two row aluminum radiator for $300.  You can get a Chinese made Bugeye type radiator on Fleabay for $165 with free shipping.  Nevermind the fact Moss charges a $10 oversize fee on top of a shipping charge of $27 and then of course California has to get their cut ($24).  It adds up.       A call to Moss just now was not all that helpful.  I was told that all they know is their aluminum radiator comes from Moss Europe.  Other than that, they have no idea country of manufacture.  Since both radiators are just about the same in construction and core size I am not sure what to do here.  With Frank's words on Chinese made crap echoing in my head might I be better off getting my original radiator re-cored with an up to date core that will have more cooling fin area?  Do the aluminum radiators make that much difference?Mike MacLean

----_com.lge.email_4838972328099020
   charset=utf-8
Content-Transfer-Encoding: 8bit

<html><head>

</head>
<body>
    <div style="font-size: 10pt;"><div dir="auto">Ok after reading all the responses I have 1 HUGE question!! ONE!&nbsp; &nbsp;HOW OLD is your fan belt ( read that hardened ones time which can slip) AND.... how right or loose is your belt?</div><div dir="auto">They slip against engine torque and against water resistance in the engine.&nbsp; If your coolant is not circulating at the correct rate , it builds heat rather than dissipates it.&nbsp; &nbsp;</div><div dir="auto">Also remember a 50/50 mixture of coolant &amp; water is the professed best heat exchange ratio for a normal cooling system.&nbsp; &nbsp;</div><div dir="auto">Ok fellow racers I know restrictions on antifreeze in race cars on race tracks..</div><div dir="auto">A simple test on the belt is grab the fan ( of course not running!&nbsp; &nbsp;33 stitches at Summit piont a few years ago ...aw..never mind!) and rock the fan both ways.&nbsp; Does it slip at all?&nbsp; Even then retension your fan belt and go for a drive and see how hot it runs.&nbsp; &nbsp;If it still runs hot , water pump impeller , improper opening thermostat or a restriction in the radiator are all possible.&nbsp; But!&nbsp; If it worked at 1 time there must be a fly in the ointment!&nbsp;&nbsp;</div><div dir="auto">Do not just throw money at it until you diagnose it.&nbsp; &nbsp;If you have acess to an infrared thermometer....read radiator core temperatures when hot and check top &amp; bottom radiator hose temperatures AND CHECK the temperature of the thermostat housing!&nbsp; &nbsp;Make notes on what is hot or cooler and you might find something wrong with circulation.</div><div dir="auto">Honestly I have no idea what I'm saying....but it crazy enough ... It just might work....</div><div dir="auto">Chuck!</div><div dir="auto">It's be kind to virgins month so DO NOT throw a virgin into a volcano!!!&nbsp; &nbsp;LOL!</div><div dir="auto"><br></div><div><div dir="auto" style="font-size:9pt;"><i>Sent from my LG Mobile</i></div></div></div><div style="font-size: 10pt;"><div id="LGEmailHeader" dir="auto"><div dir="auto"><br></div><div dir="auto">------ Original message------</div><div dir="auto"><b>From: </b>Michael MacLean via Spridgets<[email-masked]></[email-masked]></div><div dir="auto"><b>Date: </b>Mon, Apr 26, 2021 12:35 PM</div><div dir="auto"><b>To: </b><a href="mailto:[email-masked]">[email-masked]</a>;</div><div dir="auto"><b>Cc: </b></div><div dir="auto"><b>Subject:</b>[Spridgets] Aluminum Radiators</div><div dir="auto"><br></div></div><div dir="auto">&nbsp; &nbsp; &nbsp;My Bugeye has been running hot in any ambient temperature over 80 degrees lately.&nbsp; I have the original radiator that was re-cored with an OEM type core almost 25 years ago.&nbsp; I have been leaning towards getting an aluminum radiator.&nbsp; Moss sells a two row aluminum radiator for $300.&nbsp; You can get a Chinese made Bugeye type radiator on Fleabay for $165 with free shipping.&nbsp; Nevermind the fact Moss charges a $10 oversize fee on top of a shipping charge of $27 and then of course California has to get their cut ($24).&nbsp; It adds up.&nbsp;&nbsp;<div dir="auto">&nbsp; &nbsp; &nbsp;A call to Moss just now was not all that helpful.&nbsp; I was told that all they know is their aluminum radiator comes from Moss Europe.&nbsp; Other than that, they have no idea country of manufacture.&nbsp; Since both radiators are just about the same in construction and core size I am not sure what to do here.&nbsp; With Frank's words on Chinese made crap echoing in my head might I be better off getting my original radiator re-cored with an up to date core that will have more cooling fin area?&nbsp; Do the aluminum radiators make that much difference?</div><div dir="auto">Mike MacLean</div></div>
</div>

</body></html>
----_com.lge.email_4838972328099020--

--===============2989495240850259385==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

------------------------

[email-masked]

Archive: http://www.team.net/pipermail/spridgets  http://autox.team.net/archive

--===============2989495240850259385==--

---

From: brian S via Spridgets <[email-masked]>
Date: Mon, 26 Apr 2021 22:43:55 +0000

--===============5664441833683093997==
Content-Language: en-US
	boundary="_000_BL0PR13MB42768696AC853A3AFF7D05D2C2429BL0PR13MB4276namp_"

--_000_BL0PR13MB42768696AC853A3AFF7D05D2C2429BL0PR13MB4276namp_
Content-Transfer-Encoding: base64

--_000_BL0PR13MB42768696AC853A3AFF7D05D2C2429BL0PR13MB4276namp_
Content-Transfer-Encoding: base64

--_000_BL0PR13MB42768696AC853A3AFF7D05D2C2429BL0PR13MB4276namp_--

--===============5664441833683093997==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

------------------------

[email-masked]

--===============5664441833683093997==--