Subject: [Spridgets] carb cleaner

From: Rick Fisk via Spridgets <[email-masked]>
Date: Wed, 15 Jul 2020 15:38:20 -0400

A couple of weeks ago Chuck asked what everyone was using for carb cleaner in these EPA mandated safety "causes cancer in California" days.  I replied that I was still using an old can of Berryman's Chem-Dip I believe.  Stuff takes the skin off your fingers.  Got it out today to clean some brake master pistons that had petrified rubber seals on them and found out the stuff had nearly eaten through the gallon can and was about ready to set itself free.  Luckily my local hardware store sells empty one gallon resealable paint cans.  Good for another few years.  :-)

Rick

Sent from my keyboard
------------------------

[email-masked]

Archive: http://www.team.net/pipermail/spridgets  http://autox.team.net/archive

---

From: JMFangio via Spridgets <[email-masked]>
Date: Thu, 16 Jul 2020 08:14:56 -0500

That is what happened to mine, went to use it and the top half of the can with the wire handle pulled away from the rest of it…  like an old British car or something.  ;-)

Lester

Now I use an ultrasonic and, standby here," LA’s Most Awesome" cleaner.  Only available at Dollar stores.  Takes off most crud and quickly.  Stronger than Simple Green.  Use it on dry things, after you rinse wait for the carb to dry before you reapply.  

> On Jul 15, 2020, at 2:38 PM, Rick Fisk via Spridgets <[email-masked]> wrote:
> 
> Donate: http://www.team.net/donate.html
> Suggested annual donation: $12.75
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/spridgets/[email-masked]

------------------------

[email-masked]

Donate: http://www.team.net/donate.html
Suggested annual donation: $12.75

Unsubscribe/Manage: http://autox.team.net/mailman/options/spridgets/[email-masked]