Subject: Re: [Spridgets] Corrosion inhibitors

From: dwoerpel <[email-masked]>
Date: Sat, 06 Dec 2014 10:56:43 -0600

Tim,

I apologize for leading the group astray.  I change the felt inhibitors 
every season when I reconnect the battery in spring. They can probably 
go longer but while it's apart it's convenient to do.

If anyone wishes a photo of the original battery tray let me know as I 
have one but as it is only a tray I don't use it.  NFS though. ;-)

Dave W.
'59 :{)
'59 MGA 1500
Burlington WI

On 12/5/2014 12:05 PM, Tim Collins wrote:
> Well, thanks for all the info about battery boxes & trays, but does 
> anyone have any info about the red & green corrosion inhibitors for 
> battery terminal posts? How long do they last? I'm beginning to think 
> that the people who use them are also the people who maintain their 
> batteries so those things APPEAR to work, but do they really work?
> Tim
> Oh, and Ron. Thanks for the tip about milk jugs. ------------------------
>
> [email-masked]
>
> Donate: http://www.team.net/donate.html
> Suggested annual donation: $12.75
>
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: 
> http://autox.team.net/mailman/options/spridgets/[email-masked]
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: derf <[email-masked]>
Date: Sat, 6 Dec 2014 11:33:55 -0600

Corrosion will occur wherever dissimilar metal conductors are in contact.
You can inhibit all you want but what's best is probably just periodic
inspection and cleaning as necessary.  Clean, airtight connections are
best.  Any method, product, or gimmick that helps connections stay clean
and airtight is probably good.  I've seen the little felt donuts in use but
haven't noticed any spectacular differences between the use of them and the
non use of them.

On Sat, Dec 6, 2014 at 10:56 AM, dwoerpel <[email-masked]> wrote:

> every season when I reconnect the battery in spring. They can probably go
> longer but while it's apart it's convenient to do.
>
>> anyone have any info about the red & green corrosion inhibitors for battery
>> terminal posts? How long do they last? I'm beginning to think that the
>> people who use them are also the people who maintain their batteries so
>> those things APPEAR to work, but do they really work?
>> Tim
>> Unsubscribe/Manage: http://autox.team.net/mailman/
>> options/spridgets/[email-masked]
>>
> ------------------------
>
> [email-masked]
>
> Unsubscribe/Manage: http://autox.team.net/mailman/
> options/spridgets/[email-masked]
------------------------

[email-masked]