Subject: Re: [Spridgets] Fuel Pump ?

From: Michael MacLean <[email-masked]>
Date: Fri, 19 Dec 2014 13:47:13 -0800

Just get a Facet solid state pump.  Moss sells them for $75.  or you can go to Aircraft Spruce and order the very same pump for $32.95.  Go to the link below and order the pump at the very bottom of the Facet pump chart.  Exactly the same specs, exactly the same pump.  I have on on my Bugeye with a 1275 and it works perfectly.  Mount it near the tank.  Have a filter before or after the pump or ideally both places.

http://www.aircraftspruce.com/catalog/eppages/facetpumps.php?clickkey=14306

Mike MacLean
60 Sprite
56 BN2

On Friday, December 19, 2014 12:34 PM, "[email-masked]" <[email-masked]> wrote:

>
>
>There is a local fuel pump epidemic, I think. I have a '65 Sprite and a '79 MGB, both with tired and non-operating fuel pumps. I have looked at various options, and asking for suggestions as to replacement/rebuild. For the MGB, I can rebuild the contacts, replace with a similar pump, or would a "solid state" replacement be better? I am not like my uncle who had to be totally original. He replaced the hydraulic brakes with OE mechanical brakes on his '32 Ford. And for the Sprite, suggestions? The sprite has set a bit, and the fuel has become a bit gelled. Nothing like napalm in the fuel system.
>
>Thanks, John
>
>John Kitchens
>POB 178
>Somis, CA  93066
>805 216-2569
>805 482-2895 fax
>[email-masked]
>------------------------
>
>[email-masked]
>
>Donate: http://www.team.net/donate.html
>Suggested annual donation: $12.75
>
>Archive: http://www.team.net/archive
>Forums: http://www.team.net/forums
>Unsubscribe/Manage: http://autox.team.net/mailman/options/spridgets/[email-masked]
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: David Lieb <[email-masked]>
Date: Fri, 19 Dec 2014 16:00:33 -0600

And order an GMB transmission mount from PPP to reduce the noise, right?
------------------------

[email-masked]

---

From: Michael MacLean <[email-masked]>
Date: Fri, 19 Dec 2014 15:39:17 -0800

Facet actually makes two rubber mounts for the pump.  I bought mine from Holden parts in England, but I suppose the trans mount is easier to acquire.

Mike MacLean

------------------------

[email-masked]