Subject: Re: [Spridgets] New Mini Cooper

From: Kirk Hargreaves <[email-masked]>
Date: Sat, 28 Jun 2014 15:59:51 -0700

This is indeed a bullet to dodge unless one has deep pockets and wants one
of these bad enough, and does not mind the down time involved.

This thing makes the reliability of a mid 60's Type E on par with a Toyota
or a Honda.

Such a shame as it is such a cool looking fun car (I like the early models
best).

Amazed that BMW put this car out to the public.  Nearly all the reviews I
have read parrot David's review . . almost all displaying the same high
dollar repairs.

Thought comes to mind.  Does anyone know how the new Fiat 500 models are
holding up?

Thanks,

Kirk

PS
As for me and my house . . .I'll go with the Fiesta.

On Fri, Jun 27, 2014 at 10:04 AM, David Ambrose <[email-masked]> wrote:

> I realize this is only one data point, but the owner of the repair shop I
> use said that the BMW built Minis needed a lot of repairs and advised me
> not to get one. He's been honest for the last 20 years, and I'm confident
> that what he's telling me is true.
>
>
> On 6/23/2014 7:24 PM, Kirk Hargreaves wrote:
>
>> I have always admired this car and as we are approaching the need for a
>> new
>> or newer car I have had this car in mind . . the turbo I hear
>> is the way to go for the added performance.
>>
>> However I recently came across Consumer Reports 10 worst cars where they
>> put the Mini towards the top of their list for reliability problems.
>>
>> Built by BMW (right?) I was surprise to read things like:
>>
>> *Bought my Mini Cooper S, std shift, new in 2007. It was a fun & happy
>> ride
>> for a very short time. Since owning this money-sucking imp, I have spent
>> approx $5K in repairs (not maintenance) . .  less than 50k miles and a
>> litany of repairs. *
>>
>> Is this common or sour grapes or what?  Or limited to certain models to
>> avoid or years to avoid?
>>
>> I believe that there are some on our list that own this car . . .
>>
>> Please advise . . .
>>
>> Kirk
>> 1959 1275
>> ------------------------
>>
>> [email-masked]
>>
>> Donate: http://www.team.net/donate.html
>> Suggested annual donation: $12.75
>>
>> Archive: http://www.team.net/archive
>> Forums: http://www.team.net/forums
>> Unsubscribe/Manage: http://autox.team.net/mailman/
>> options/spridgets/[email-masked]
>>
> ------------------------
>
> [email-masked]
>
> Donate: http://www.team.net/donate.html
> Suggested annual donation: $12.75
>
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/spridgets/
> [email-masked]
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: Bill L <[email-masked]>
Date: Sat, 28 Jun 2014 16:08:40 -0700

Hello Kirk,

     You will NOT be disappointed in the dynamics of the Fiesta ST.
     Turn in is amazing, brakes are like anchors, the shifter is
     smooooth, and the engine sweet as can be... ...

     That said, I can hardly wait myself for the CARB to approve the
     mountune 215 kit. .. enough power to get to 60 in under 6.5 sec,
     (as fast or faster than most Muscle cars of the era, including
     the Boss 302 Mustang and the 73 Firebird 455) yet still retains
     the factory warranty. .. they just came out with a set of springs
     to drop the car about an inch all around... ..  $$$$$$$$$$$$$

     but the car is incredible without any of the aftermarket stuff... 

-- 
Best regards,
 Bill L.                           mailto:[email-masked]
 
 '66 Sprite MKIII HAN8L49403   "the red thing"
 
  "There's someone in my head, but its not me." -Pink Floyd 
------------------------

[email-masked]

---

From: David Lieb <[email-masked]>
Date: Sat, 28 Jun 2014 18:32:01 -0500

Trish and I bought a Focus ST last year. We love this car. It is
comfortable, the brakes are scary, and it is the sweetest engine!
------------------------

[email-masked]