Subject: [Spridgets] Spitfire steering rack mount

From: Larry & Sandi Mller <[email-masked]>
Date: Mon, 2 Sep 2013 20:55:24 -0700

A friend has a race car that uses a Spit steering rack. 
We blew out the mounts at the Monterey Reunion last week.
The MOSS number for the rack mounting rubber is 680-070. 
Where can I find a performance type replacement?

Larry Miller
1959 Sprite, BUGZUKI.
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: Mark J Bradakis <[email-masked]>
Date: Mon, 02 Sep 2013 22:10:35 -0600

> Where can I find a performance type replacement?

There are a number of sources for poly or solid aluminum rack mounts.  
First place
I'd check would be http://www.tsimportedautomotive.com - Ted Schumacher 
is quite
familiar with racing Triumphs, and can no doubt help out.  But he'll be 
heading to
ELVF in a day or so.  Also try http://www.spitbits.com for steering rack 
bits.  If you
like Moss, check out 667-288.

mjb.
------------------------

[email-masked]