Subject: [Spridgets] Elkhart Lake last Sunday

From: Ron Soave <[email-masked]>
Date: Thu, 12 Sep 2013 17:49:38 -0500

Pardon the redundancy if some of you are on facebook's Spridget list...

On today's installment of Narcissist Theater: Sunday's Sheldon Cup, Road
America at Elkhart Lake. Because I had no qualifying time, Trash Too was
gridded 41st, finished 17th. Was still working my way up when the pesky
checkered flag came out. There is still so much time in that car once the
driver trusts it a bit more. What a blast...

http://www.youtube.com/watch?v=9UX3uHImQXs

Ron Soave
Roscoe, IL

"It only goes one way."
"Pay it forward."

----------------
"The truth knocks on the door and you say, 'Go away, I'm looking for the
truth,' and so it goes away. Puzzling."

(Robert M. Pirsig, "Zen and the Art of Motorcycle Maintenance")
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: "rrengineer.mike" <[email-masked]>
Date: Thu, 12 Sep 2013 19:40:29 -0700

Damn Ron, that looks like a blast! B Love the sound of your car.
Mike MacLean
60 Sprite
56 BN2

-------- Original message --------
From: Ron Soave <[email-masked]> 
Date:  
To: Spridgets <[email-masked]> 
Subject: [Spridgets] Elkhart Lake last Sunday 

Ron Soave
Roscoe, IL

"It only goes one way."
"Pay it forward."

----------------

[email-masked]

[email-masked]