Subject: [Spridgets] USA/British WW2 aviation story - no LBC

From: [email-masked]
Date: Wed, 5 Jun 2013 14:21:07 -0400 (EDT)

I thought this was a real treat and brought a lump to my throat.
 
http://www.youtube.com/watch?v=ie3SrjLlcUY
 
Weslake Monza 1330
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: "Adrian Jones" <[email-masked]>
Date: Thu, 6 Jun 2013 16:12:08 -0400

Wow!  Thanks for posting.
The look on the guy's face is priceless.
Very cool video indeed.
------------------------

[email-masked]