Subject: Re: [Spridgets] Aluminum Radiators

From: derf <[email-masked]>
Date: Fri, 22 Mar 2013 13:59:45 -0500

Also, I've seen some good quality air/air intercoolers that were made in
China.
If they can make intercoolers then they can make radiators, IMO.
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: Rick Fisk <[email-masked]>
Date: Fri, 22 Mar 2013 15:25:16 -0400

Everybody tell John "Happy birthday, ya old fart".

Sent from my keyboard

On Mar 22, 2013, at 1:29 PM, JohnD <[email-masked]> wrote:

> I'm running a Spridgetech radiator from Rod Hahneman as well. He told me he
> gets them from Ron Davis and from somebody in Indianapolis. The one he sold
> me came from Winners Circle but he said it was a Ron Davis without the name
> stenciled on the fins....therefore cheaper. However, without a tank on the
> radiator, I had to add a custom-fabricated remote tank on the firewall,
> which was an unexpected expense.
> --JohnD
>
> *Driving in the past lane!*
> JohnsfollyVintageRacing <http://www.johnsfolly.webs.com>
>
>>> Date: Wed, 20 Mar 2013 19:52:00 -0700 (PDT)
> From: Ron Soave <[email-masked]>
> To: Dean Hedin <[email-masked]>, "[email-masked]"
>        <[email-masked]>
> Subject: Re: [Spridgets] Aluminium Radiators - From China
> Message-ID:
>        <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
>
> As Jay said, Ron Davis is the very best. I have a downflow Bugeye unit on
> White Trash 1 and it is absolutely drop in and amazing quality. Speedwell
> just uses Ron's, doesn't even take the labels off. But I have a "Made in
> USA"
> excellent quality one from Rod at Spridgetech for a lot less $$ ave on
White
> Trash 2. Talk to Rod, 810-229-8639. www.spridgetech.com
>
> Ron Soave
> Roscoe, IL
> "It only goes one way."
> "Pay it forward."
> ------------------------
>
> [email-masked]
>
> Donate: http://www.team.net/donate.html
> Suggested annual donation: $12.75
>
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/spridgets/[email-masked]
------------------------

[email-masked]