Subject: Re: [Spridgets] Aluminium Radiators - From China

From: Jay <[email-masked]>
Date: Wed, 20 Mar 2013 12:11:03 -0700 (PDT)

Ron Soave has info on the subject of aluminium radiators for Sprites.

I would wait for confirmation from Ron, but this may be who he has used:
http://www.rondavisradiators.com

 jay fishbein
wallingford, ct
63 Pink Sprite Mk II
61 Innocenti 950 Spider 

________________________________
From: Martyn Ridley <[email-masked]>
To: [email-masked]
Sent: Wed, March 20, 2013 2:50:44 PM
Subject: [Spridgets] Aluminium Radiators - From China

Has anybody any experience with the aluminium radiators being advertised by 
several groups on E-Bay.  Its time for the Frog to get a replacement so I 
checked about and there seem to be several different firms selling but, and this 
is a big but, not from the places I where expected to buy - Moss US/UK, Brown& 
Gammons, AH Spares, Head 4 Healeys etc. - not even Vicky B.  All I found was a 
strong denouncement from Speedwell - and their version looks very different and 
at twice the price.

Appreciate any feedback you may have.
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 20 Mar 2013 12:27:54 -0700 (PDT)

I have been using a $170 one off of ebay for nearly three years now.  Not a
problem at all.
 
Mike

________________________________
From: Jay
<[email-masked]>
To: [email-masked] 
Sent: Wednesday, March 20,
2013 3:11 PM
Subject: Re: [Spridgets] Aluminium Radiators - From China

Ron
Soave has info on the subject of aluminium radiators for Sprites.

I would
wait for confirmation from Ron, but this may be who he has used:
http://www.rondavisradiators.com

jay fishbein
wallingford, ct
63 Pink Sprite
Mk II
61 Innocenti 950 Spider 

________________________________
From:
Martyn Ridley <[email-masked]>
To: [email-masked]
Sent: Wed,
March 20, 2013 2:50:44 PM
Subject: [Spridgets] Aluminium Radiators - From
China

Has anybody any experience with the aluminium radiators being
advertised by 
several groups on E-Bay.  Its time for the Frog to get a
replacement so I 
checked about and there seem to be several different firms
selling but, and this 
is a big but, not from the places I where expected to
buy - Moss US/UK, Brown& 
Gammons, AH Spares, Head 4 Healeys etc. - not even
Vicky B.  All I found was a 
strong denouncement from Speedwell - and their
version looks very different and 
at twice the price.

Appreciate any feedback
you may have.
------------------------
------------------------

[email-masked]

---

From: "Dean Hedin" <[email-masked]>
Date: Wed, 20 Mar 2013 21:30:40 -0400

Maybe I'm wrong, but I don't think the ones on ebay are from China.
For a while there was only the guy in New York selling them for $500.

Now I think there are a bunch of other radiator guys in the US getting 
in on the action.  Free market at work and we all win.

Like this..

http://tinyurl.com/cujls6j 
------------------------

[email-masked]

---

From: Ron Soave <[email-masked]>
Date: Wed, 20 Mar 2013 19:48:09 -0700 (PDT)

talk to Rod @ www.spridgetech.com
 
Ron Soave
Roscoe, IL

"It only goes one
way."
"Pay it forward."

>Sent: Wednesday,
March 20, 2013 1:41 PM
>Has anybody any experience with the aluminium radiators being advertised
by several groups on E-Bay.  Its time for the Frog to get a replacement so I
checked about and there seem to be several different firms selling but, and
this is a big but, not from the places I where expected to buy - Moss US/UK,
Brown& Gammons, AH Spares, Head 4 Healeys etc. - not even Vicky B.  All I
found was a strong denouncement from Speedwell - and their version looks very
different and at twice the price.
>Cheers,
>Martyn
>Donate: http://www.team.net/donate.html
>Suggested annual donation: $12.75
>
>Forums: http://www.team.net/forums
>Unsubscribe/Manage:
http://autox.team.net/mailman/options/spridgets/[email-masked]
------------------------

[email-masked]

---

From: Ron Soave <[email-masked]>
Date: Wed, 20 Mar 2013 19:52:00 -0700 (PDT)

As Jay said, Ron Davis is the very best. I have a downflow Bugeye unit on
 White Trash 1 and it is absolutely drop in and amazing quality. Speedwell
just uses Ron's, doesn't even take the labels off. But I have a "Made in USA"
excellent quality one from Rod at Spridgetech for a lot less $$ ave on White
Trash 2. Talk to Rod, 810-229-8639. www.spridgetech.com
 
Ron Soave
Roscoe, IL
"It only goes one way."
"Pay it forward."

> From: Dean Hedin <[email-masked]>
>Sent:
Wednesday, March 20, 2013 8:30 PM
>Like
this..

[email-masked]

---

From: Glen Byrns <[email-masked]>
Date: Thu, 21 Mar 2013 09:59:40 -0700

> I've got the Speedwell rad and it's excellent.  Mine also came with a cool
Speedwell shift knob. My Moto Lita wheel scorched in the fire, but the
Speedwell knob just needed a bit of scrubbing.
------------------------

[email-masked]

---

From: "Dean Hedin" <[email-masked]>
Date: Thu, 21 Mar 2013 23:02:26 -0400

I just want to add to this...

The guy in New York was Wizard Cooling. That is a quality aluminum unit.
There was the later model green Sprite with the Judson at the 50th that had
one installed.

It was very nicely welded together.   

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Dean Hedin
Sent: Wednesday, March 20, 2013 9:31 PM
To: [email-masked]
Subject: Re: [Spridgets] Aluminium Radiators - From China

Now I think there are a bunch of other radiator guys in the US getting in on
the action.  Free market at work and we all win.

Like this..

[email-masked]

Archive: http://www.team.net/archive
http://autox.team.net/mailman/options/spridgets/[email-masked]
------------------------

[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 22 Mar 2013 04:49:40 -0700 (PDT)

How do I tell if I have one of the bad Chinese aluminum radiators, by the
welds?  Everything about the radiator looks over built even with great
welding.  It was an exact fit.  I think the brand was Champion Radiators if
that rings a bell with anyone.  I really couldn't bother to clean or repair an
older original radiator for the price and have run exceptionally for three
years.
 
Thanks,
 
Mike

________________________________
From: Dean Hedin
<[email-masked]>
To: 'Dean Hedin' <[email-masked]>;
[email-masked] 
Sent: Thursday, March 21, 2013 11:02 PM
Subject: Re:
[Spridgets] Aluminium Radiators - From China

I just want to add to this...
The guy in New York was Wizard Cooling. That is a quality aluminum unit.
There
was the later model green Sprite with the Judson at the 50th that had
one
installed.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Dean Hedin
Sent:
Wednesday, March 20, 2013 9:31 PM
To: [email-masked]
Subject: Re:
[Spridgets] Aluminium Radiators - From China

Maybe I'm wrong, but I don't
think the ones on ebay are from China.
For a while there was only the guy in
New York selling them for $500.

Now I think there are a bunch of other
radiator guys in the US getting in on
the action.  Free market at work and we
all win.

Like this..

[email-masked]

---

From: John Farley <[email-masked]>
Date: Sat, 23 Mar 2013 15:11:01 -0400

I have been interested in an aluminum radiator since Leo S. ran a proposal
past the group in Feb. 2010.  I have a bugeye with a 1275.  I retained the
stock bugeye Downflow radiator.

I also looked on eBay and found they listed a Superadiator at I think
$299.99 plus shipping.  They also list two from GPI Racing.  Both are
$273.24 plus $75.90 shipping.  One says the manufacturer is Opel / Vauxhall
 ???  and cooling capacity is increased 30% to 40%.  The other says the
manufacturer is Austin ??? and the cooling capacity is increased.  Both are
2 Row and the pictures look identical.  Anybody have any knowledge about
these?

I am debating the choice of spending much more for the best recommended
ones, or going a less expensive route.

Also, what's the consensus of replacing the metal 4 blade fan with a
plastic 6 blade one?

Thanks,  John

On Fri, Mar 22, 2013 at 7:49 AM, [email-masked] <
[email-masked]> wrote:

> http://autox.team.net/mailman/options/spridgets/[email-masked]
------------------------

[email-masked]

---

From: Bill L <[email-masked]>
Date: Sat, 23 Mar 2013 15:34:39 -0700

Hello John,

     The extra blades steal horsepower. ...At high speeds you don't
     need the extra .. and at low speeds you don't overheat...

-- 
Best regards,
 Bill L.                           mailto:[email-masked]
 
 '66 Sprite MKIII HAN8L49403   "the red thing"
 
      * "Happy Halloween!" Tom said gravely. (*2)
------------------------

[email-masked]

---

From: "Dean Hedin" <[email-masked]>
Date: Sat, 23 Mar 2013 21:59:36 -0400

It's a matter of opinion.
I'm liking the 6 blade fan.  I could care less how much power it eats.
I'm not racing in H-production.  I want reliability. 

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Bill L
Sent: Saturday, March 23, 2013 6:35 PM
To: [email-masked]
Subject: Re: [Spridgets] Aluminium Radiators - From China

Hello John,

[email-masked]