Subject: [Spridgets] Machine Mart...

From: "Dean Hedin" <[email-masked]>
Date: Tue, 20 Nov 2012 22:19:17 -0500

Daniel,

Is "Machine Mart" the UK's equivalent to our "Harbor Freight"?
------------------------

[email-masked]

Archive: http://www.team.net/archive

---

From: [email-masked]
Date: Wed, 21 Nov 2012 12:52:32 -0500 (EST)

Yes, though I think there is someone else as well (who I bought my engine  
crane from).

In a message dated 21/11/2012 03:19:47 Coordinated Universal Time,  
[email-masked] writes:

Daniel,

[email-masked]