Subject: Re: [Mgs] Car cleaners, polishes & waxes

From: Richard Lindsay <[email-masked]>
Date: Tue, 07 Jun 2022 06:39:06 -0500

--===============2615370599908678765==
Content-Transfer-Encoding: base64

--===============2615370599908678765==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________

[email-masked]

Archive: http://www.team.net/pipermail/mgs http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

--===============2615370599908678765==--

---

From: John DiFede <[email-masked]>
Date: Tue, 7 Jun 2022 11:00:44 -0400

Meguiars gets my vote also.  I use their Mirror Glaze 205 Ultra Finishing Polish for light scratches and swirl marks and paint defects.  It should remove your oxidation

John D 

Sent from my iPhone

> On Jun 7, 2022, at 10:54 AM, dave northrup <[email-masked]> wrote:
> 
> +1 on Meguiars
> 
> -----Original Message-----
> From: Mgs <[email-masked]> On Behalf Of Mark Bradakis
> Sent: Monday, June 6, 2022 8:34 PM
> To: [email-masked]
> Subject: Re: [Mgs] Car cleaners, polishes & waxes
> 
> 
>> On 6/6/22 3:11 PM, Joseph Cianciotti wrote:
>> Hey folks,
>> 
>> It’s been ages since I’ve given my car a good cleaning, polishing and waxing. As a result, my mineral blue finish, while still shiny, is now pretty oxidized — almost to barn-find levels. I used to use 3M products. But they’re nowhere to be found near me. Any suggestions of more readily available products? Going to do it by hand and need something that can cut though the oxidation without damaging the paint (too much).
>> 
> 
> I'd recommend Meguiar's products, if they are available in your area. I've had good results with their cleaners, waxes, etc.
> 
> mjb.
> 
> 
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.75
> 
> Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.75
> 
> Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.75