Subject: [Mgs] Car cleaners, polishes & waxes

From: Joseph Cianciotti <[email-masked]>
Date: Mon, 6 Jun 2022 17:11:09 -0400

Hey folks,

It’s been ages since I’ve given my car a good cleaning, polishing and waxing. As a result, my mineral blue finish, while still shiny, is now pretty oxidized — almost to barn-find levels. I used to use 3M products. But they’re nowhere to be found near me. Any suggestions of more readily available products? Going to do it by hand and need something that can cut though the oxidation without damaging the paint (too much). 

Joseph 
1967 MGB Roadster
_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.75

Archive: http://www.team.net/pipermail/mgs http://autox.team.net/archive

Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Mark Bradakis <[email-masked]>
Date: Mon, 6 Jun 2022 19:33:54 -0600

> It’s been ages since I’ve given my car a good cleaning, polishing and waxing. As a result, my mineral blue finish, while still shiny, is now pretty oxidized — almost to barn-find levels. I used to…

I'd recommend Meguiar's products, if they are available in your area.  
I've had good results with their cleaners, waxes, etc.

mjb.

[email-masked]

---

From: dave northrup <[email-masked]>
Date: Tue, 7 Jun 2022 14:53:53 +0000

+1 on Meguiars

-----Original Message-----
From: Mgs <[email-masked]> On Behalf Of Mark Bradakis
Sent: Monday, June 6, 2022 8:34 PM
To: [email-masked]
Subject: Re: [Mgs] Car cleaners, polishes & waxes

> It’s been ages since I’ve given my car a good cleaning, polishing and waxing. As a result, my mineral blue finish, while still shiny, is now pretty oxidized — almost to barn-find levels. I used to…

I'd recommend Meguiar's products, if they are available in your area. I've had good results with their cleaners, waxes, etc.

mjb.

[email-masked]

Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]
_______________________________________________

[email-masked]