Subject: [Mgs] Opinion on seats

From: Max Heim via Mgs <[email-masked]>
Date: Tue, 7 Apr 2015 16:56:19 -0700

Here’s a question…

My project car came with a set of 1970-71 seats. The upholstery and foams were beyond repair, but I was intrigued by the frames. They have a locking backrest and a handy backrest adjustment, neither of which are features of my 66 seats. Not to mention a provision for headrests (unfortunately not included).

I was thinking of restoring them with the Moss deluxe leather seat kits, which have more of a vintage look than the stock replacements. I was already going to install shoulder belts on this car (my co-drivers are tired of being tossed around on my backroad forays), so going to solid backrests with headrests is just a further step toward some degree of safety.

It’s not quite authentic, but this build is going to be a Frankenstein, anyway. And it’s absolutely a rally driver and not a show car.

Anyone have experience with these later seats pro or con?

And does anyone have a set of used “eared” headrests (1970-76)? They can be tatty since I would be recovering them.

--
Max Heim
'66 MGB GHN3L76149
If you're near Menlo Park, CA,
it's the primer red one with chrome wires
And now 67 MGB GHN3U137949G
Old English White, off-premises for restoration

_______________________________________________

[email-masked]
Donate: http://www.team.net/donate.html
Suggested annual donation  $12.75
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Barrie Robinson via Mgs <[email-masked]>
Date: Wed, 08 Apr 2015 11:00:38 -0400

Hello Max,

A small thought !   I was suffering from 
posterior ache when driving for over an 
hour.  When I had the seats done (1970) I had the 
chap put in 3" of memory foam -WOW what a difference !!!!!! No more aches

At 04:56 PM 4/7/2015 -0700, Max Heim via Mgs wrote:
>Here’s a question� My project car came with a 
>set off 1970-71 seats. The upholstery and foams 
>were beyond repair, but I was intrigued by the 
>frames. They have a locking backrest and a handy 
>backrest adjustment, neither of which are 
>features of my 66 seats. Not to mention a 
>provision for headrests (unfortunately not 
>included). I was thinking of restoring them with 
>the Moss deluxe leather seat kits, which have 
>more of a vintage look than the stock 
>replacements. I was already going to install 
>shoulder belts on this car (my co-drivers are 
>tired of being tossed around on my backroad 
>forays), so going to solid backrests with 
>headrests is just a further step toward some 
>degree of safety. It’s not quite authentic, 
>but this build is going to be a Frankenstein, 
>anyway. And it’s absolutely a rally driver and 
>not a show car. Anyone have experience with 
>these later seats pro or con? And does anyone 
>have a set of used “eared” headrests 
>(1970-76)? They can be tatty since I would be 
>recovering them. -- Max Heim '66 MGB GHN3L76149 
>If you're near Menlo Park, CA, it's the primer 
>red one with chrome wires And now 67 MGB 
>GHN3U137949G Old English White, off-premises for 
>restoration 
>[email-masked] Donate: 
>http://www.team.net/donate.html Suggested annual 
>donation  $12.75 Archive: 
>http://www.team.net/archive Forums: 
>http://www.team.net/forums Unsubscribe: 
>http://autox.team.net/mailman/options/mgs/[email-masked]

Regards,
Barrie

Barrie Robinson                         Go with the flow - but paddle hard
MGB GT V8 in concours condition
Aston Martin DB 2/4 MkII under restoration
www.AMFClub.com
www.britcot.com
www.vectisgroup.ca
[email-masked]
Barrie, Ontario
705-721-9060 

[email-masked]