Subject: [Mgs] awesome customer service

From: "Eric J Russell" <[email-masked]>
Date: Wed, 8 Oct 2014 21:43:29 -0400

A few days ago I called Joe Curto to purchase a few grommets for the carbs in
my MGA. Joe quoted me a price and then says, "I will put them in an envelope
with an invoice. You send me a check when they arrive."

Amazing!

Eric Russell
Mebane, NC
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 9 Oct 2014 01:57:58 GMT

You are not the first to complement him on his prompt, expeditious service.
In our club, he is thought of very highly for this, and for his good work
too.Bob

---------- Original Message ----------
From: "Eric J Russell" <[email-masked]>
To: <[email-masked]>
Subject: [Mgs] awesome customer service
Date: Wed, 8 Oct 2014 21:43:29 -0400

Amazing!

Eric Russell
Mebane, NC

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]
_______________________________________________

[email-masked]

---

From: "W. David Houser" <[email-masked]>
Date: Thu, 9 Oct 2014 14:36:51 -0400

That is how Joe works. Quite a friend for over 35 years...
Cheers
Dave Houser
Brooksville, FL

On Oct 8, 2014, at 9:43 PM, Eric J Russell wrote:

> Donate: http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
> Unsubscribe:
http://autox.team.net/mailman/options/mgs/[email-masked]
_______________________________________________

[email-masked]