Subject: [Mgs] : brake pressure failure switch '72 MGB

From: John Di Fede <[email-masked]>
Date: Mon, 13 Oct 2014 15:46:29 -0400

Sam,

I had this happen on my 1973 MGB.   You said you replaced the switch.  Was
the switch new? 

I fixed mine by rebuilding the switch with new rubber o rings.   For what it
is worth,  I also use silicone brake fluid.   

John Di Fede

 

"Whether you think you can, or you think you can't, you're right".   Henry
Ford 

---
This email is free from viruses and malware because avast! Antivirus protection is active.
http://www.avast.com
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: "Hans Duinhoven" <[email-masked]>
Date: Mon, 13 Oct 2014 22:02:49 +0200

I have had a similar issue and replaced the o-rings with success as well.
My problem is where can I obtain a new switch assembly.
For over 10 years the local suppliers tell me, that the switch is NLA.

Hope I can find one ever...

Cheers,
Hans
71 BGT

-----Oorspronkelijk bericht-----
Van: Mgs [mailto:[email-masked]] Namens John Di Fede
Verzonden: maandag 13 oktober 2014 21:46
Aan: [email-masked]
Onderwerp: [Mgs] : brake pressure failure switch '72 MGB

Sam,

John Di Fede

 

---
This email is free from viruses and malware because avast! Antivirus
protection is active.
http://www.avast.com
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---
Dit e-mailbericht bevat geen virussen en malware omdat avast! Antivirus-bescherming actief is.
http://www.avast.com
_______________________________________________

[email-masked]