Subject: [Mgs] MGB Hardtop Gasket Replacement

From: "Ray Graham" <[email-masked]>
Date: Wed, 2 Oct 2013 18:46:27 -0500

Hey Gang:
Where can I buy a replacement gasket for a Snugfit hardtop rear to deck for
my MGB?  Or, suggestion(s) about what might work?

Thanks,
Ray
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive
Unsubscribe: http://autox.team.net/mailman/options/mgs/[email-masked]

---

From: Max Heim <[email-masked]>
Date: Wed, 02 Oct 2013 17:17:13 -0700

Steele Rubber has a catalog where you can look for your gasket profile.

http://steelerubber.com/sponge-extrusions

My Snugtop pretty much needs all the seals, just haven't got around to it.

--

Max Heim
'66 MGB GHN3L76149
If you're near Menlo Park, CA,
it's the primer red one with chrome wires
_______________________________________________

[email-masked]