Subject: Re: [Lotus-cars] Hey, is anybody here?

From: Rob Pennington <[email-masked]>
Date: Fri, 20 Feb 2015 18:03:15 -0600

Yes.  :)

> On Feb 20, 2015, at 16:51, Philip Ethier <[email-masked]> wrote:
>
> Since LOTUSCARS is overrun by spammers, I suggest we use this.
>
> --
> [email-masked] still works also
> Phil Ethier West Side Saint Paul Minnesota USA
> 1973 Triumph Stag LE22439UBW "uncle jack", Sapphire Blue
> 2004 Suburban 8.1, Sport Red, the only automatic of the bunch
> 2005 Lotus Elise, Bordeaux Red Pearl
> 2005 Subaru Legacy GT Limited, Regal Blue Pearl
> http://www.mnautox.com
> _______________________________________________
>
> [email-masked]
> Donate: http://www.team.net/donate.html
> Suggested annual donation  $11.47
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/lotus-cars/[email-masked]
_______________________________________________

[email-masked]
Archive: http://www.team.net/archive

---

From: Philip Ethier <[email-masked]>
Date: Fri, 20 Feb 2015 21:34:55 -0600

Hey, how's that Europa coming along?