Subject: [Healeys] Cleaner

From: Don via Healeys <[email-masked]>
Date: Fri, 13 May 2022 15:38:11 -0400

Hi all 
    Has anyone used the ultrasonic cleaner offered by Harbor Freight to clean SU carb parts . I know size is everything. I’m looking at HD8 carbs that have sat for 20 years. . The cleaner is a 2.5 ltr size . $85  I can take the carbs apart and see if they fit . If they don’t I’ll just bring it back . I wonder what Joe Curto would think ?   Other wise I’ll be using a moto tool with small wire brushes. And cans of carb spray cleaner. 
Any thoughts would be appreciated. 
      
         Don ,  1967 BJ 8 

Sent from my iPhone
_______________________________________________
Support Team.Net http://www.team.net/donate.html
Suggested annual donation  $12.75

Archive: http://www.team.net/pipermail/healeys http://autox.team.net/archive/healeys

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

---

From: Richard Collins <[email-masked]>
Date: Fri, 13 May 2022 20:07:35 +0000

I used it to clean carbs off my old Honda motorcycle last winter.
However the first one broke its heat cycle on its second use so I took it back for another one. It worked OK but not as good as one you find in a motor or machine shop. And it must be disassembled as well as possible but it still requires manual effort

Regards,
Richard C
BN7 #440

> On May 13, 2022, at 14:38, Don via Healeys <[email-masked]> wrote:
> 
> Hi all 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]
> 

[email-masked]