Subject: Re: [Healeys] BJ 8 Carb Needles

From: "R. Lindsay via Healeys" <[email-masked]>
Date: Fri, 17 Sep 2021 09:37:45 -0400

--===============2868109594224485556==
Content-Transfer-Encoding: 7bit

--Apple-Mail-1E54C71B-8B65-402B-A708-3F91DAB6EB56
	charset=utf-8
Content-Transfer-Encoding: quoted-printable

Thank you Alan.=20

Price Lindsay

Cell: 630-841-6300
Email: [email-masked]

Sent from my iPhone

> On Sep 16, 2021, at 10:06 PM, Alan Seigrist <[email-masked]> wrote:
>=20
> =EF=BB=BF
> Hi Price -
>=20
> Yeah there are two balls in there, a big one and a small one.  They don't m=
ove much. Grose jets are very good provided you have decent fuel filter keep=
ing dirt out of the carbs... otherwise they are useless.  Also Grose jets do=
n't do all that well if the car sits for long periods.  I actually found the=
 old style jets are a bit less finicky, but you do need to tap the carbs wit=
h a plastic mallot from time to time to keep them from overflowing.
>=20
> Best,
>=20
> Alan
>=20
>> On Thu, Sep 16, 2021 at 11:11 PM R. Lindsay via Healeys <[email-masked]=
am.net> wrote:
>> I installed the Grose-Jet needle assembly in my carbs some time back. Whe=
n disassembling the float chambers to clean them, I see that the ball in the=
 bottom moves VERY little, but does rattle. Is this type of valve supposed t=
o move up like the old =E2=80=9Cneedle and seat=E2=80=9D type??
>>=20
>> Thank you for your help.=20
>>=20
>> Price Lindsay
>>=20
>> Cell: 630-841-6300
>> Email: [email-masked]
>>=20
>> Sent from my iPhone
>> _______________________________________________
>> Support Team.Net http://www.team.net/donate.html
>> Suggested annual donation  $12.75
>>=20
>> Archive: http://www.team.net/pipermail/healeys http://autox.team.net/arch=
ive
>>=20
>> [email-masked]
>> http://autox.team.net/mailman/listinfo/healeys
>>=20
>> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/healey.=
[email-masked]
>>=20

--Apple-Mail-1E54C71B-8B65-402B-A708-3F91DAB6EB56
	charset=utf-8
Content-Transfer-Encoding: quoted-printable

<html><head><meta http-equiv=3D"content-type" content=3D"text/html; charset=3D=
utf-8"></head><body dir=3D"auto">Thank you Alan.&nbsp;<br><br><div dir=3D"lt=
r">Price Lindsay<div><br></div><div>Cell: 630-841-6300</div><div>Email: 050.=
[email-masked]</div><div><br></div><div>Sent from my iPhone</div></div><div d=
ir=3D"ltr"><br><blockquote type=3D"cite">On Sep 16, 2021, at 10:06 PM, Alan S=
eigrist &lt;[email-masked]&gt; wrote:<br><br></blockquote></div><block=
quote type=3D"cite"><div dir=3D"ltr">=EF=BB=BF<div dir=3D"ltr">Hi Price -<di=
v><br></div><div>Yeah there are two balls in there, a big one and a small on=
e.&nbsp; They don't move much. Grose jets are very good provided you have de=
cent fuel filter keeping dirt out of the carbs... otherwise they are useless=
.&nbsp; Also Grose jets don't do all that well if the car sits for long peri=
ods.&nbsp; I actually found the old style jets are a bit less finicky, but y=
ou do need to tap the carbs with a plastic mallot from time to time to keep t=
hem from overflowing.</div><div><br></div><div>Best,</div><div><br></div><di=
v>Alan</div></div><br><div class=3D"gmail_quote"><div dir=3D"ltr" class=3D"g=
mail_attr">On Thu, Sep 16, 2021 at 11:11 PM R. Lindsay via Healeys &lt;<a hr=
ef=3D"mailto:[email-masked]">[email-masked]</a>&gt; wrote:<b=
r></div><blockquote class=3D"gmail_quote" style=3D"margin:0px 0px 0px 0.8ex;=
border-left:1px solid rgb(204,204,204);padding-left:1ex">I installed the Gro=
se-Jet needle assembly in my carbs some time back. When disassembling the fl=
oat chambers to clean them, I see that the ball in the bottom moves VERY lit=
tle, but does rattle. Is this type of valve supposed to move up like the old=
 =E2=80=9Cneedle and seat=E2=80=9D type??<br>
<br>
Thank you for your help. <br>
<br>
Price Lindsay<br>
<br>
Cell: 630-841-6300<br>
Email: <a href=3D"mailto:[email-masked]" target=3D"_blank">050.rpl@gmail.=
com</a><br>
<br>
Sent from my iPhone<br>
_______________________________________________<br>
er" target=3D"_blank">http://www.team.net/donate.html</a><br>
<br>
Archive: <a href=3D"http://www.team.net/pipermail/healeys" rel=3D"noreferrer=
" target=3D"_blank">http://www.team.net/pipermail/healeys</a> <a href=3D"htt=
p://autox.team.net/archive" rel=3D"noreferrer" target=3D"_blank">http://auto=
x.team.net/archive</a><br>
<br>
<a href=3D"mailto:[email-masked]" target=3D"_blank">[email-masked]=
am.net</a><br>
<a href=3D"http://autox.team.net/mailman/listinfo/healeys" rel=3D"noreferrer=
" target=3D"_blank">http://autox.team.net/mailman/listinfo/healeys</a><br>
<br>
/[email-masked]" rel=3D"noreferrer" target=3D"_blank">http://autox.tea=
m.net/mailman/options/healeys/[email-masked]</a><br>
<br>
</blockquote></div>
</div></blockquote></body></html>=

--Apple-Mail-1E54C71B-8B65-402B-A708-3F91DAB6EB56--

--===============2868109594224485556==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________

Archive: http://www.team.net/pipermail/healeys http://autox.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

--===============2868109594224485556==--

---

From: Bob Spidell <[email-masked]>
Date: Fri, 17 Sep 2021 08:29:07 -0700

This is a multi-part message in MIME format.
--===============6890312666141453861==
 boundary="------------09ACD520125B5423FC2D7D37"
Content-Language: en-US

This is a multi-part message in MIME format.
--------------09ACD520125B5423FC2D7D37
Content-Transfer-Encoding: 8bit

Always the contrarian, and FWIW I've run Grose Jets in my BJ8 with no 
fuel filter for well over 100K miles with no issues. OTOH, I got a newer 
set for my BN2 and didn't like the way they operated (the little ball on 
top would get stuck). Rumor has it the company was bought out and 
quality suffered (shocking, I know--looking at you, County).

I'm not a big believer in fuel filters for Healeys; I figure anything 
that gets by the little brass 'thimbles' in the carbs will settle in the 
float bowls or pass through; better to invest in a clean tank and new 
lines if necessary. I cut my Ranger's fuel filter open at over 100K 
miles, and all I found was some tiny black flakes, which I figured came 
from the plastic tank (filters are absolutely necessary in FI engines).

Bob

On 9/17/2021 6:37 AM, R. Lindsay via Healeys wrote:
> Thank you Alan.
>> Yeah there are two balls in there, a big one and a small one.  They 
>> don't move much. Grose jets are very good provided you have decent 
>> fuel filter keeping dirt out of the carbs... otherwise they are 
>> useless.  Also Grose jets don't do all that well if the car sits for 
>> long periods. I actually found the old style jets are a bit less 
>> finicky, but you do need to tap the carbs with a plastic mallot from 
>> time to time to keep them from overflowing.
>>
>> Best,
>>
>> Alan
>>
>> On Thu, Sep 16, 2021 at 11:11 PM R. Lindsay via Healeys 
>>
>>     I installed the Grose-Jet needle assembly in my carbs some time
>>     back. When disassembling the float chambers to clean them, I see
>>     that the ball in the bottom moves VERY little, but does rattle.
>>     Is this type of valve supposed to move up like the old “needle
>>     and seat” type??
>>
>>     Thank you for your help.
>>
>>     Price Lindsay
>>
>>     Cell: 630-841-6300
>>
>>     Sent from my iPhone
>>     <http://www.team.net/donate.html>
>>     Archive: http://www.team.net/pipermail/healeys
>>     <http://www.team.net/pipermail/healeys>
>>     http://autox.team.net/archive <http://autox.team.net/archive>
>>
>>     <http://autox.team.net/mailman/listinfo/healeys>
>>
>>     Unsubscribe/Manage:
>>     http://autox.team.net/mailman/options/healeys/[email-masked]
>>     <http://autox.team.net/mailman/options/healeys/[email-masked]>
>>
>
> Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]
>

--------------09ACD520125B5423FC2D7D37
Content-Transfer-Encoding: 8bit

<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  </head>
  <body>
    Always the contrarian, and FWIW I've run Grose Jets in my BJ8 with
    no fuel filter for well over 100K miles with no issues. OTOH, I got
    a newer set for my BN2 and didn't like the way they operated (the
    little ball on top would get stuck). Rumor has it the company was
    bought out and quality suffered (shocking, I know--looking at you,
    County). <br>
    <br>
    I'm not a big believer in fuel filters for Healeys; I figure
    anything that gets by the little brass 'thimbles' in the carbs will
    settle in the float bowls or pass through; better to invest in a
    clean tank and new lines if necessary. I cut my Ranger's fuel filter
    open at over 100K miles, and all I found was some tiny black flakes,
    which I figured came from the plastic tank (filters are absolutely
    necessary in FI engines).<br>
    <br>
    Bob<br>
    <br>
    <div class="moz-cite-prefix">On 9/17/2021 6:37 AM, R. Lindsay via
      Healeys wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:[email-masked]">
      <meta http-equiv="content-type" content="text/html; charset=UTF-8">
      Thank you Alan. <br>
      <br>
      <div dir="ltr">Price Lindsay
        <div><br>
        </div>
        <div>Cell: 630-841-6300</div>
        <div>Email: <a class="moz-txt-link-abbreviated" href="mailto:[email-masked]">[email-masked]</a></div>
        <div><br>
        </div>
        <div>Sent from my iPhone</div>
      </div>
      <div dir="ltr"><br>
        <blockquote type="cite">On Sep 16, 2021, at 10:06 PM, Alan
          Seigrist <a class="moz-txt-link-rfc2396E" href="mailto:[email-masked]">&lt;[email-masked]&gt;</a> wrote:<br>
          <br>
        </blockquote>
      </div>
      <blockquote type="cite">
        <div dir="ltr">
          <div dir="ltr">Hi Price -
            <div><br>
            </div>
            <div>Yeah there are two balls in there, a big one and a
              small one.  They don't move much. Grose jets are very good
              provided you have decent fuel filter keeping dirt out of
              the carbs... otherwise they are useless.  Also Grose jets
              don't do all that well if the car sits for long periods. 
              I actually found the old style jets are a bit less
              finicky, but you do need to tap the carbs with a plastic
              mallot from time to time to keep them from overflowing.</div>
            <div><br>
            </div>
            <div>Best,</div>
            <div><br>
            </div>
            <div>Alan</div>
          </div>
          <br>
          <div class="gmail_quote">
            <div dir="ltr" class="gmail_attr">On Thu, Sep 16, 2021 at
              11:11 PM R. Lindsay via Healeys &lt;<a
                href="mailto:[email-masked]"
                moz-do-not-send="true">[email-masked]</a>&gt;
              wrote:<br>
            </div>
            <blockquote class="gmail_quote" style="margin:0px 0px 0px
              0.8ex;border-left:1px solid
              rgb(204,204,204);padding-left:1ex">I installed the
              Grose-Jet needle assembly in my carbs some time back. When
              disassembling the float chambers to clean them, I see that
              the ball in the bottom moves VERY little, but does rattle.
              Is this type of valve supposed to move up like the old
              “needle and seat” type??<br>
              <br>
              Thank you for your help. <br>
              <br>
              Price Lindsay<br>
              <br>
              Cell: 630-841-6300<br>
              Email: <a href="mailto:[email-masked]" target="_blank"
                moz-do-not-send="true">[email-masked]</a><br>
              <br>
              Sent from my iPhone<br>
              _______________________________________________<br>
              Support Team.Net <a
                href="http://www.team.net/donate.html" rel="noreferrer"
                target="_blank" moz-do-not-send="true">http://www.team.net/donate.html</a><br>
              Suggested annual donation  $12.75<br>
              <br>
              Archive: <a href="http://www.team.net/pipermail/healeys"
                rel="noreferrer" target="_blank" moz-do-not-send="true">http://www.team.net/pipermail/healeys</a>
              <a href="http://autox.team.net/archive" rel="noreferrer"
                target="_blank" moz-do-not-send="true">http://autox.team.net/archive</a><br>
              <br>
              <a href="mailto:[email-masked]" target="_blank"
                moz-do-not-send="true">[email-masked]</a><br>
              <a href="http://autox.team.net/mailman/listinfo/healeys"
                rel="noreferrer" target="_blank" moz-do-not-send="true">http://autox.team.net/mailman/listinfo/healeys</a><br>
              <br>
              Unsubscribe/Manage: <a
href="http://autox.team.net/mailman/options/healeys/[email-masked]"
                rel="noreferrer" target="_blank" moz-do-not-send="true">http://autox.team.net/mailman/options/healeys/[email-masked]</a><br>
              <br>
            </blockquote>
          </div>
        </div>
      </blockquote>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <pre class="moz-quote-pre" wrap="">_______________________________________________

Archive: <a class="moz-txt-link-freetext" href="http://www.team.net/pipermail/healeys">http://www.team.net/pipermail/healeys</a> <a class="moz-txt-link-freetext" href="http://autox.team.net/archive">http://autox.team.net/archive</a>

<a class="moz-txt-link-abbreviated" href="mailto:[email-masked]">[email-masked]</a>
<a class="moz-txt-link-freetext" href="http://autox.team.net/mailman/listinfo/healeys">http://autox.team.net/mailman/listinfo/healeys</a>

</pre>
    </blockquote>
    <br>
  </body>
</html>

--------------09ACD520125B5423FC2D7D37--

--===============6890312666141453861==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

[email-masked]

--===============6890312666141453861==--