Subject: Re: [Healeys] Fuel pump flustered

From: [email-masked]
Date: Sat, 08 Oct 2016 09:49:33 -0500 (CDT)

Hello all and thanks for all the replies on this.  It has been a bit exasperating.

After extensive investigation I installed a new pump - problem solved.  I suppose there was something internal going on with the pump like maybe cracked diaphragm or some probs with the one way valves.  Well now to sit back and wait on the next issue . . . . . .... 

Keith

On 09/28/16, [email-masked] wrote:

Listers,

This one has really got me stumped. A couple weeks ago went on a 40 or so mile ride. Car ran great. No probs. At one point I was stopped and I could hear the fuel pump clicking away, 3-4 clicks per second. This was true whether at idle or higher rpm. I knew that normally at idle there was an occasional click.

Once back home I restarted the car and same thing. Then over several days I attempted to fix the prob. A different pump gave the same results. I replaced the filter and still same thing. Oh BTW there was no fuel underneath as is the case when a float needle is stuck and fuel comes out the overflow. No fuel shows up anywhere.

Why does the pump continue to click so fast????? Why does it NOT slow to an occasional click????? What is the fix???? I am flustered.

Keith 
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Bob Spidell <[email-masked]>
Date: Sat, 8 Oct 2016 09:20:29 -0700

You will, of course, repair the old one and keep it in the boot; if, for 
nothing else, to make sure the new one behaves?

[email-masked]

---

From: Tom Felts <[email-masked]>
Date: Sun, 9 Oct 2016 9:04:01 -0400

Speaking of the next issue------------my BJ8 has a brand new fuel pump installed and everything was going perfectly---then a few weeks ago I started getting fuel starvation (at times).  I'd blip the throttle and yank out the choke and it would run normal again ---for a while.  Then start sputtering and coughing---and I'd repeat the process.

I changed the in-line fuel filter and moved it to before the fuel pump and even added another filter just before going into the carbs.  I even opened the fuel bowls and checked to see if debris was in there.  Didn't see anything. 

The fuel pump seems to have its' normal click frequency.  I thought all this would have solved it----nope--it is back.

Years ago I pulled the sock filter off the intake line as it was clogging up and causing a similiar problem.

Ideas?

thanks
tom

[email-masked]