Subject: [Healeys] AH Club USA calendar screw up

From: [email-masked]
Date: Fri, 2 Jan 2015 15:41:45 -0800 (PST)

What's with the calendar? It looks like they took a 2014 and put new pictures on it and called it 2015. January 1 is not on Wednesday. I hope they send a new one soon.
Ken Freese
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Don Anglesey <[email-masked]>
Date: Fri, 2 Jan 2015 17:36:40 -0700

Mine is correct, you must of got a limited edition.
Don

--- Original Message ---

From: [email-masked]
Sent: January 2, 2015 4:50 PM
To: "HEALEY LIST" <[email-masked]>
Subject: [Healeys] AH Club USA calendar screw up

[email-masked]

[email-masked]