Subject: Re: [Healeys] BJ8 Air Filters.............which are the best?

From: Bluehealey <[email-masked]>
Date: Sat, 19 Oct 2013 20:09:03 +0100

Undoubtedly K&N's. 
The standard filters can keep out small birds and large stones.

Sent from my iPad

> On 19 Oct 2013, at 19:41, "Mitchell Simmons" <[email-masked]> wrote:
> 
> Hello ,
> 
> I am looking to upgrade the air filters on my
> Bj8...........................K&N...Dennis Welch......stay with original?
> 
> Any advice?
> 
> What are the best avail.?
> 
> 
> Mitchell
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Derek Job <[email-masked]>
Date: Sat, 19 Oct 2013 21:26:54 +0100

Mitchell

The originals are hopelessly inefficient and restrict power. I don't know much
about K & N but can recommend ITG filters.

I have Webers and for competition I don't use any air filters.

Derek

On 19 Oct 2013, at 19:41, Mitchell Simmons <[email-masked]> wrote:

> 1966 bj8
> 1959 bn4
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
>
> [email-masked]
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]