Subject: [Healeys] Steering wheel restoration

From: Michael Salter <[email-masked]>
Date: Fri, 2 Nov 2012 16:11:44 -0400

The Bluemel's 16.6" steering wheel on my very early BN1, although
structurally sound. is in poor condition. The rim is badly cracked and
faded with some fairly substantial hunks missing, very little of the
original coating on the hub remains however, fortunately, the chrome on the
spokes is in excellent condition.
Repro wheels of this type are unavailable so I'm considering trying to
restore the one I have.
I see that Eastwood sells a "Steering Wheel Restoration"
kit<http://www.eastwood.com/complete-steering-wheel-restoration-kit.html>and
I'm considering starting there.
Does anyone have experience with this kit or any other advice before I
start this project.

Many thanks,
-- 
Michael Salter

                         *I have BJ8 water pump kits!!*
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Jackson Krall <[email-masked]>
Date: Fri, 2 Nov 2012 16:24:16 -0700 (PDT)

Hello Michael, I've not used the Eastwood kit but I have used the PC7 epoxy that comes with the kit, for steering wheel repair to good effect on my TD. I didn't paint it, just laced on a leather cover and bob was my uncle. It's available at most hardware stores and now there is also a PC11 that is better suited for wet conditions. 
Best
JK

------------------------------
On Fri, Nov 2, 2012 4:11 PM EDT Michael Salter wrote:

>Support Team.Net http://www.team.net/donate.html
>Suggested annual donation  $12.75
>Forums: http://www.team.net/forums
>
>[email-masked]
>Unsubscribe/Manage: http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: Michael MacLean <[email-masked]>
Date: Sun, 4 Nov 2012 11:43:20 -0800 (PST)

I used Koch's Steering Wheel Restoration in Canyon Country, California for my
Bugeye and my BN2 wheels.  Excellent job on both.
Mike MacLean
56 BN2
60 AN5

--- On Sun, 11/4/12, Jim Lesher <[email-masked]> wrote:
Has anyone used www.steeringwheelbob.com? He is located in NJ. He does
excellent work, but it is pricy
Best  of Luck - Jim
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]