Subject: Re: [Healeys] John Fitch has passed

From: [email-masked]
Date: Thu, 1 Nov 2012 08:58:43 -0400 (EDT)

So sorry to hear this. We met John many times at Lime Rock Track.
 
Here is a site about him:
 
_http://www.voy.com/221392/108322.html_ 
(http://www.voy.com/221392/108322.html) 
 
Rudy Streng
Lenoir, NC
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: [email-masked]
Date: Thu, 1 Nov 2012 12:39:22 -0400 (EDT)

Sometimes things in life are somewhat serendipity. I opened my December issue
of Road & Track and there is a nice article about John Fitch on page 46 called
Almost Famous.
Aloha
Perry

-----Original Message-----
From: Jackson Krall <[email-masked]>
To: healeys <[email-masked]>
Sent: Wed, Oct 31, 2012 7:36 pm
Subject: [Healeys] John Fitch has passed

Sorry to report that the great driver and inventor of auto safety equipment
that
as saved countless lives passed this morning at age 95.
Speed On Dear John
Best
K
______________________________________________

-----Original Message-----
From: Jackson Krall <[email-masked]>
To: healeys <[email-masked]>
Sent: Wed, Oct 31, 2012 7:36 pm
Subject: [Healeys] John Fitch has passed

Sorry to report that the great driver and inventor of auto safety equipment
that
as saved countless lives passed this morning at age 95.
Speed On Dear John
Best
K
______________________________________________
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]