Subject: Re: [Healeys] Cheap tools

From: "m.fawcett" <[email-masked]>
Date: Mon, 26 Nov 2012 10:18:08 -0800

I would say "95% as good as Snap On at 1/3 the price".  Lifetime warranty.

Mark

On Mon, Nov 26, 2012 at 8:25 AM, HealeyRick <[email-masked]> wrote:

> 192 pc Craftsman mechanics tool set for $99 on cyber-Monday :
>
> http://www.sears.com/shc/s/p_10153_12605_00933192000P?vName=Tools&cName=Mecha
> nics&AutoTools&sName=Mechanics%20Tool%20Setsmv=rr<http://www.sears.com/shc/s/p_10153_12605_00933192000P?vName=Tools&cName=Mecha%0Anics&AutoTools&sName=Mechanics%20Tool%20Setsmv=rr>
>
>
> Not as good as Snap-On
> but better than Harbor Freight.
>
>
> Rick
>
>
> "Madman in a death machine"
> Follow
> My Nasty Boy Build:  http://tinyurl.com/yj52fwo
> _______________________________________________
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
>
> [email-masked]
> http://autox.team.net/mailman/listinfo/healeys
>
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Richard Ewald <[email-masked]>
Date: Mon, 26 Nov 2012 10:49:35 -0800

Bwahahaha!
Go on pull the other one it has bells on it.  I can tell you horror stories
about crapsman tools.

Sent from my iPhone

[email-masked]

---

From: "Greg Lemon" <[email-masked]>
Date: Tue, 27 Nov 2012 01:12:36 -0600

I got a Crafstman set for about $40 at a Christmas sale about 35 years ago, 
the ratchet and screwdrivers have been replaced a few times, free, no 
questions asked, no paperwork required, the only thing that really wore out 
were the phillips heads.  The standard screwdrivers would probably have 
lasted if not used and chisels and the ratchets would have at least lasted 
longer if not used as hammers.

The wrenches and sockets have also been often used and sometimes abused, but 
are still in great shape.  Crafstman handtools seem like a heck of a deal to 
me.

Greg Lemon

[email-masked]

---

From: Oudesluys <[email-masked]>
Date: Tue, 27 Nov 2012 10:02:44 +0100

Cheap tools can even be better than expensive professional tools, 
however they can be horrible as well. You simply cannot tell beforehand. 
Expensive professional tools are usually at least reasonable but do not 
be fooled, they sometimes are out of spec dimensionally  causing a bad 
fit on bolt heads and nuts and are not always hard enough. Channellock 
pliers e.g. had some hardness issues in the past. Snap-On is one of the 
best makes.
Kees Oudesluijs
NL

Op 27-11-2012 8:12, Greg Lemon schreef:
> I got a Crafstman set for about $40 at a Christmas sale about 35 years 
> ago, the ratchet and screwdrivers have been replaced a few times, 
> free, no questions asked, no paperwork required, the only thing that 
> really wore out were the phillips heads.  The standard screwdrivers 
> would probably have lasted if not used and chisels and the ratchets 
> would have at least lasted longer if not used as hammers.
>
> The wrenches and sockets have also been often used and sometimes 
> abused, but are still in great shape.  Crafstman handtools seem like a 
> heck of a deal to me.
>
> Greg Lemon
> http://autox.team.net/mailman/options/healeys/[email-masked]
>
>
>
> -----
> Geen virus gevonden in dit bericht.
> Gecontroleerd door AVG - www.avg.com
> Versie: 2013.0.2793 / Virusdatabase: 2629/5920 - datum van uitgifte: 
> 11/26/12
>
>

-- 
Kees Oudesluijs
Dorpsstraat 183
2995XG Heerjansdam
T: 078-677 1233
E: [email-masked]

Technische commissie Jensen Healey en GT
Het Jensen Genootschap Holland
www.jensenholland.nl
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]