Subject: Re: [Healeys] John Fitch

From: I Erbs <[email-masked]>
Date: Mon, 5 Nov 2012 10:46:33 -0800

Articles and sale material for the Phoenix
http://www.intermeccanica.org/vehicles/phoenix/phoenix.htm
Ira Erbs
Portland, OR
   _______                                  _______
     (______ \____1960 BT7____/ _______)
         (_________________________)

On Mon, Nov 5, 2012 at 10:08 AM, Jackson Krall <[email-masked]>wrote:

> Thankyou Simon, The Daily Telegraph told the story with a bit more
> accuracy and depth than either the Boston Globe or NY Times.
> The auto dealership in White Plains NY was, as far as I know, for Willys,
> not Mercedes, as stated in Globe and Times.
> I believe The Fitch Phoenix was to be a passenger sports car rather than a
> "race car". 200 orders were taken before Nader/GM pulled the plug.
> I have a series of photos taken a few years ago by a girlfriend at Lime
> Rock, of Mr Fitch with the Pheonix. John had just been told that something
> seemed to be leaking from the car. 90+ year old Mr Fitch gets down on the
> ground to look under car to verify, jumps up and gets in car saying he must
> get it back home(about 200 yards from the track) and speeds off. Inspiring!
> The first time I saw he and the Pheonix was when leaving the track one
> day. He was driving in front of me when I recognized the car, remembering
> those side mounted spare tires, different sizes front and rear, from the
> magazine articles back in the day. As the exit road turns left just after
> the bridge, he looked back at me, I waved and smiled, he did the same.
> The annual Jaguar Drivers Club meeting at Lime Rock is a low key non
> spectator event that was the perfect time to find him and converse. When it
> was discovered that my girlfriends mother was a cousin of his friend, and
> inventor of the racing stripe, Coby Whitmore, we had plenty to talk about.
> Once, when talking about the Pheonix, he suddenly said, "That reminds me, I
> need to call Roger Penske tomorrow". I was somewhat stunned to realize that
> I was talking to an icon that had a hotline to the titans of the industry.
> As others have said, he will be greatly missed at Lime Rock.
> Best
> JK
>
>
> ------------------------------
> On Mon, Nov 5, 2012 3:41 AM EST Simon Lachlan wrote:
>
> >Obituary in UK's Daily Telegraph:-
> >
> >
> http://www.telegraph.co.uk/news/obituaries/sport-obituaries/9654484/John-Fit
> >ch.html
> >
> >
> >
> >Simon.
> >_______________________________________________
> _______________________________________________
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
>
> [email-masked]
> http://autox.team.net/mailman/listinfo/healeys
>
> Unsubscribe/Manage:
> http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: HealeyRick <[email-masked]>
Date: Mon, 5 Nov 2012 14:03:39 -0800 (PST)

I've attended the vintage festivals at Lime Rock for just about 30 yrs and
have seen some memorable racing and racers.  But I'll never forget seeing Mr.
Fitch, well into his 80s, driving the downhill coming onto the main straight. 
He went a bit wide to the left then came back across the track to the right
and onto the grass, looking like he was going to collect the car into the
guardrail.  Somehow, driving on the grass, he managed to collect it all up and
come to a safe stop.  It would have been astounding for a driver in his
prime.  Raise a glass to a life well-lived.

Rick

"Madman in a death
machine"
Follow My Nasty Boy Build:  http://tinyurl.com/yj52fwo
________________________________
 From: Jackson Krall
<[email-masked]>
To: [email-masked] 
Cc:
[email-masked] 
Sent: Monday, November 5, 2012 1:08 PM
Subject: Re:
[Healeys] John Fitch

As others have said, he will be greatly missed at Lime
Rock.
Best
JK
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]