Subject: Re: [Healeys] Steering Box

From: andy pole <[email-masked]>
Date: Sun, 11 Nov 2012 12:45:50 +0000

Ric
I think you would be better trying the penrite steering box lube which is
especially made for worm type boxes , it's a cross between an oil and grease,
and many find it solves their leaks, you can also double up on the oil seal on
the box and idler as its usual that the shaft is pitted where the original one
rides, cheers andy

> Date: Sun, 11 Nov 2012 07:00:16 -0500
> From: [email-masked]
> To: [email-masked]
> Subject: [Healeys] Steering Box
>
> Is there any substantive reason not to use white lithium assembly grease in
> the steering box of my '65 BJ8?  I know this is not the optimal solution
> (it won't hold the hypo) but I'd prefer not to mess with it right now.  It
> steers easily, tracks perfectly and has virtually no play currently.
> Thanks,
> Ric
> _______________________________________________
> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
>
> [email-masked]
> http://autox.team.net/mailman/listinfo/healeys
>
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: "Greg Lemon" <[email-masked]>
Date: Mon, 12 Nov 2012 02:23:45 -0600

" Ric
 I think you would be better trying the penrite steering box lube which is
 especially made for worm type boxes , it's a cross between an oil and 
grease,
 and many find it solves their leaks, you can also double up on the oil seal 
on
 the box and idler as its usual that the shaft is pitted where the original 
one
 rides, cheers andy'

I agree, my box leaked even after the rebuild until I put the penrite in, it 
didn't stop the seepage completely, but it made it so slight as to allow me 
to easily convince myself that I had much better things to worry about.

Greg Lemon 

[email-masked]