Subject: Re: [Healeys] BJ8 Customized Radiator???

From: Oudesluys <[email-masked]>
Date: Mon, 29 Oct 2012 08:33:11 +0100

If you consider a custom radiator get the biggest cooling capacity that 
will fit. One can never have enough and it should give piece of mind 
under all circumstances. Do not forget to fit an overflow/expansion 
vessel and renew all hoses including the ones for the heater for silicon 
items. Check the condition of the heater radiator core. The engine 
temperature (sleeved thermostat 70C, 72C, 80C, 86C) can be chosen as you 
wish without the worry of overheating, 80C or 86C would be preferable, 
however do fit a proper thermostatically controlled electric fan with 
the switching on temperature about 95C and switching off temperature 
about 90C (for a 86C thermostat) and a 10psi rad cap to raise the 
boiling point.
Kees Oudesluijs

Op 29-10-2012 4:31, Robert Blair schreef:
> Listers,
>   
> I am considering a project that could involve replacing the std BJ8 radiator
> with a customized radiator - that is a different size/shape - probably
> somewhat wider and shorter in height.  The approx same area should be
> possible.  Better cooling efficiency would be a plus as that could allow a
> smaller area.
>   
> I have seen several Healeys with alloy rads - who makes them and who do you
> know in the US that does custom shape rads to order using normal cores?
>   
> Thx.
>
> Robert N. Blair
>    Yellow 65BJ8
>    [email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: HealeyRick <[email-masked]>
Date: Mon, 29 Oct 2012 03:25:12 -0700 (PDT)

Hi Robert,

I'd be interested to see what you come up with.  The available
space is really limited in width by the chassis uprights and the size of the
bottom tank is limited by the distance between the chassis and the suspension
mounting points.  I think one of the reasons our radiators are so tall is the
necessity to keep the radiator inlet higher than the thermostat housing in the
engine.  If the thermostat is higher than the radiator inlet, it can cause air
to be trapped in the system.  One manufacturer of custom alloy radiators is
Ron Davis:  http://www.rondavisradiators.com/

Rick

"Madman in a death
machine"
Follow My Nasty Boy Build:  http://tinyurl.com/yj52fwo
________________________________
 From: Robert Blair <[email-masked]>
To:
Healey List <[email-masked]> 
Sent: Sunday, October 28, 2012 11:31 PM
Subject: [Healeys] BJ8 Customized Radiator???
 
Listers,

I have seen several
Healeys with alloy rads - who makes them and who do you
know in the US that
does custom shape rads to order using normal cores

Robert N. Blair
  Yellow
65BJ8
  [email-masked]

[email-masked]

---

From: Chris Dimmock <[email-masked]>
Date: Mon, 29 Oct 2012 22:36:16 +1100

With all due respect, and sincerely  Robert,
Is it a Healey?
Healey engine?
If so, then Feel free to redesign it to the limits of your thermodynamics
education and experience.
If you have had your block & head seriously cleaned, I mean Redistriped.
And your timing is correct and yadadadad. And you know a bloke who gets more
horsepower per litre who says he can get more by redesigning the radiator?
Then.
Go for it.
No? Historic Racing? Limited by rules? Wondering How some of those historic
racers are so fast???
Without modern stuff??
Peter Jackson in Au??
Alloy radiators are all about less water. Lower weight at the front.
Reduce the weight of the radiator??
Easy. Make it smaller.
Hold less water.
Therefore it weighs less.
Easy. Rocket science 101
An alloy radiator holding less water will weigh less.
Make it out of plastic, and have an all alloy motor.
Think.
We have a big cast iron heat sink. It's an engine.
Lose weight? Most efficient method is removing trim, hoods, windscreens,
lighter batteries, alloy wheels, and drivers getting fitter. Last one made my
biggest lap time improvement.....
Oh. Redistrip the block. And the head.
Thats the thermal efficiency thing.
Weight loss and fitness. That's the other  thing.
Peter Jackson? One of the fittest blokes I've ever known. A man who has really
become one of the greatest Healey drivers globally in the past 15 years. And
is still a nice bloke!
 Totally focussed, and totally detail oriented. Legal car. Totally a dedicated
racer. Ask Peter why he doesn't run an alloy radiator.

Sincerely.
Chris

Sent from my personal bunker at NASA. No Bill. I don't want a cigar.

[email-masked]