Subject: [Healeys] John Fitch has passed

From: Jackson Krall <[email-masked]>
Date: Wed, 31 Oct 2012 15:47:26 -0700 (PDT)

Sorry to report that the great driver and inventor of auto safety equipment that has saved countless lives passed this morning at age 95.

Speed On Dear John

Best
JK
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Jackson Krall <[email-masked]>
Date: Wed, 31 Oct 2012 21:57:49 -0700 (PDT)

Full life indeed, and of the hip things the man did and achieved, there was a post WWII period when he used to commute to NYC from his home in Brewster NY in a seaplane. That is VERY cool!
Best
JK

------------------------------
On Wed, Oct 31, 2012 7:55 PM EDT Patton Dickson wrote:

>Sad news, but he certainly lived a full life
>
>Patton - Plano
>
>On Oct 31, 2012, at 5:47 PM, Jackson Krall <[email-masked]> wrote:
>

[email-masked]