Subject: Re: [Healeys] John Fitch has passed

From: "Patrick and Caroline Quinn" <[email-masked]>
Date: Thu, 1 Nov 2012 10:45:01 +1100

G'day John

That is sad news indeed.

Caroline and I had the pleasure of meeting John Fitch in 2008 and had dinner
with him at Carmel, CA. A most unassuming man, who was quite happy to talk
and share a laugh about his experiences.

Not only a loss to US Motorsport, but also the world.

Hoo Roo

Patrick Quinn
Sydney, Australia

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Jackson Krall
Sent: Thursday, 1 November 2012 9:47 AM
To: [email-masked]
Subject: [Healeys] John Fitch has passed

Sorry to report that the great driver and inventor of auto safety equipment
that has saved countless lives passed this morning at age 95.

Speed On Dear John

Best
JK
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]
http://autox.team.net/mailman/listinfo/healeys

---

From: Patton Dickson <[email-masked]>
Date: Wed, 31 Oct 2012 18:55:33 -0500

Sad news, but he certainly lived a full life

Patton - Plano

> Support Team.Net http://www.team.net/donate.html
> Suggested annual donation  $12.75
> Forums: http://www.team.net/forums
>
> [email-masked]
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/healeys/[email-masked]
_______________________________________________
Archive: http://www.team.net/archive

[email-masked]

---

From: HealeyRick <[email-masked]>
Date: Wed, 31 Oct 2012 17:37:01 -0700 (PDT)

And you left out P51 pilot, Corvette team manager, creator of the Fitch
Phoenix and a true gentleman.  Lime Rock won't seem without seeing John and
his Phoenix at the track.

Rick

"Madman in a death machine"
Follow My
Nasty Boy Build:  http://tinyurl.com/yj52fwo
________________________________
 From: Jackson Krall
<[email-masked]>
To: [email-masked] 
Sent: Wednesday, October
31, 2012 6:47 PM
Subject: [Healeys] John Fitch has passed
 
Sorry to report
that the great driver and inventor of auto safety equipment that has saved
countless lives passed this morning at age 95.

Speed On Dear John

Best
JK

[email-masked]

---

From: Michael Oritt <[email-masked]>
Date: Wed, 31 Oct 2012 21:24:17 -0400

The invention of the Jersey Barrier is sometimes erroneously attributed to
Fitch but in fact he did develop the Fitch Barrier or Yellow Barrel
commonly seen on highways--go here for more info:
http://www.racesafety.com/fitchbarr.html

Best--Michael Oritt

On Wed, Oct 31, 2012 at 8:37 PM, HealeyRick <[email-masked]> wrote:

> http://autox.team.net/mailman/options/healeys/[email-masked]

[email-masked]

---

From: "Greg Lemon" <[email-masked]>
Date: Wed, 31 Oct 2012 20:35:01 -0500

Pretty good bio here, http://www.racesafety.com/fitchbio.html  WWII fighter 
pilot, driver for Mercedes in their glory days, safety engineer quite a 
story, rest (or race?) in peace Mr. Fitch

Greg Lemon

[email-masked]

---

From: "Patrick and Caroline Quinn" <[email-masked]>
Date: Thu, 1 Nov 2012 12:52:30 +1100

G'day

For those of us who are into history trivia, there are two connections
between John Fitch and the Donald Healey Motor Company.

In May 1953 John co-drove a Nash-Healey with Ray Willday (DHMC mechanic) in
the Mille Miglia. 

Then in 1955 he was the co-driver with Pierre Levegh of the Mercedes Benz
that used the Macklin entered 100S (NOJ 393) to launch itself into the
spectator mound.

Hoo Roo

Patrick Quinn
Sydney, Australia

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Patrick and Caroline Quinn
Sent: Thursday, 1 November 2012 10:45 AM
To: 'Jackson Krall'; [email-masked]
Subject: Re: [Healeys] John Fitch has passed

G'day John

That is sad news indeed.

Hoo Roo

Patrick Quinn
Sydney, Australia

-----Original Message-----

Speed On Dear John

Best
JK

[email-masked]