Subject: Re: [Fot] From your event chair - our Return to Mosport is in the books

From: "[email-masked]" <[email-masked]>
Date: Thu, 25 Jun 2026 14:35:17 -0700

Great job Henry, sounds like everyone got to experience an amazing track, even the folks that broke. And nobody got killed though I imagine a few thought they might be. The third testicle is to go fast in 1 and 2. I’m not sure what it takes to go as fast as one should in turn 8. I never got anywhere close—we both know it’s a flat out kink, not a turn. In my case that’s just theoretical. Some very good racers have ended their careers (and lives) there. Sorry I couldn’t be there with Peyote, as you can imagine, it’s a lot of fun at Mosport, though Peyote was not impressed with my performance. I suspect you would have kicked my butt. I had minis blow by me in 8 with only three wheels on the track.

> On Jun 25, 2026, at 10:19, [email-masked] wrote:
> 
> Thanks to everyone who made the trip to Mosport, it was my pleasure to share my favorite event of the year. It was pretty amazing on so many levels, the track, the Canadian hospitality, having all our friends together again to race for the Cup.
> 
> Our neighbors to the north always put on a great event, and this year was no different. Being the featured marque, we had no less than 10 sessions available to us, but I was only able to do 9. By the time that last race of the weekend came around, I was spent. The car seemed ready and able, my mind was all in, but it was my body that that convinced me I was done! I was literally sore from tossing the car around all those laps at speed!
> 
> I wish I could have been more effective setting the schedule a little better, I did push back but we got what we got. One of the problems when we get so much track time having cars that run in 4 different groups is getting that track time spread out enough to be comfortable.
> 
> I feel our racers who were seeing the track for the first time at speed did a wonderful job. Congrats to all first timers for surviving turns 1, 2 and 8, plus figuring out how to get around 5B. It takes a very special person to be able to grow that third testicle on their first visit to Mosport, it took me years to be able to go all out in 1 and 2. I know there is still more speed for me in turn 8, but that risk to reward buzzer in my head goes off every time I try to find it!
> 
> A heartfelt thanks to Keith Files who came over from the UK to be our Grand Marshal, job well done Keith. It was a privilege to meet the lovely Louisa as well!
> 
> Kudos to Kallie Sukey, what a great job she did with only a handful of races under her belt. The former Bill Rampe Spit was looking great out there, I have no doubt Kallie will be mixing it up with the best of us soon!
> 
> The Darrow brothers came with that incredibly fast pair of matching Spits and put on quite a show. They Triumphed over adversity all weekend, great fun to watch.
> 
> Then there was Fireball Bob Kramer. Surviving the epic tow from Texas, he came trying to break the jinx of Mosport. He was unsuccessful, I am afraid. He just earned another nickname, Oily Bob! Sorry Bob, hopefully your next event goes better!
> 
> Then we have the luckiest person at the track, our most recent Kastner Cup winner Dave Gott. In one of the group races, we are circling the track under double yellow for an unrelated incident when I come around and see Dave's TR4 beached in a very peculiar place. I think nobody would pull off there if they had a choice. Next time around, the flatbed was there pulling the car backwards and I could see the left front wheel flopping down, it looked like he broke a ball joint! I shuddered thinking how the heck did that happen under yellow in the ONLY slow corner on the whole track when only moments before I know he was running right hand corners at full chat where that failure would be catastrophic. I suggested he buy a lottery ticket... Of course I have no clue if Canada even does the lottery thing! Turns out it was a snapped upright, it broke just above the threads that screw into the trunnion. Unfortunately, Dave was done for the weekend.
> 
> We had our share of mechanical issues on top of Dave's near calamity, I saw at least 3 head gasket replacements, a diff failure, a gearbox shredded some gears, and a blown out bespoke shock just to name a few. Most persevered to get things fixed, some became spectators not by choice but by necessity. A pretty typical showing for our group, as we know attrition is part of the sport.
> 
> Thanks to all the non-racers who showed up, we had no less than 10 of our Western Pennsylvania Triumph buds, plus our friends Irv Korey and Jay Holecamp came from Illinois. Dave Amys and his wife drove their beautiful TR6 all the way from Minnesota to be with us! Plus more I can't think of at the moment, sorry about that folks!
> 
> I'll post a couple of race reports shortly, and call it a wrap on my time as your race chair. I am thrilled that Jason and Brian are back on the task for Grattan next year, it's on my calendar for the middle of August, 2027!
> 
> Cheers
> 
> Henry Frye
> #29 TR250
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Chuck Gee <[email-masked]>
Date: Thu, 25 Jun 2026 20:41:55 -0400

Nice reporting Henry!  I had nothing for you, you are truly the master at Mosport.

Chuck

> On Jun 25, 2026, at 3:18 PM, [email-masked] wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>

---

From: [email-masked]
Date: Fri, 26 Jun 2026 05:55:22 -0400

Bill, no doubt you and Peyote are sorely missed by our paddock of the 
great unwashed!

I too am pleased that our gang behaved quite well under tenuous 
circumstances. It takes a very special person to master Mosport in a 
handful of laps, and while I truly believe our talent pool runs pretty 
deep, there is no substitute for experience at that track. I have had 
championship winning Mini drivers come up to me asking how do I gain on 
them in turn 2, it's like getting to Carnagie Hall... Practice. OK, and 
confidence in your equipment. And that third t... Oh, never mind!

As to turn 8, I think I have raced Mosport at least 20 times, a couple 
of sessions I have really focused hard on carrying more speed through 8. 
Hasn't helped yet!

Henry

On 2026-06-25 17:35, [email-masked] wrote:
> Great job Henry, sounds like everyone got to experience an amazing
> track, even the folks that broke. And nobody got killed though I
> imagine a few thought they might be. The third testicle is to go fast
> in 1 and 2. I’m not sure what it takes to go as fast as one should in
> turn 8. I never got anywhere close—we both know it’s a flat out kink,
> not a turn. In my case that’s just theoretical. Some very good racers
> have ended their careers (and lives) there. Sorry I couldn’t be there
> with Peyote, as you can imagine, it’s a lot of fun at Mosport, though
> Peyote was not impressed with my performance. I suspect you would have
> kicked my butt. I had minis blow by me in 8 with only three wheels on
> the track.
> 
> 
>> Thanks to everyone who made the trip to Mosport, it was my pleasure to 
>> share my favorite event of the year. It was pretty amazing on so many 
>> levels, the track, the Canadian hospitality, having all our friends 
>> together again to race for the Cup.

---

From: Dave Riddle <[email-masked]>
Date: Mon, 29 Jun 2026 16:23:49 +0000

It indeed is a great Track and my new favorite.  Loved passing cars inside and outside of T1, T2, T3, T4 and T5.  Not having enough top end power I got walked on the run to T8 but then made up lots of ground being flat in 4th for T8 after talking to Henry to give up speed at T9.  T8 was the most daunting Corner for me initially as you see the wall closing in from the left.  I started saying, jokingly, to myself "She can cash the policy" as I gradually built up the nerve to stay flat through there.

Dave Riddle
602.692.5276

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, June 25, 2026 2:35 PM
To: [email-masked]
Cc: Fot <[email-masked]>
Subject: Re: [Fot] From your event chair - our Return to Mosport is in the books

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Scott Janzen <[email-masked]>
Date: Mon, 29 Jun 2026 14:04:15 -0400

I agree - I don’t drive tracks new to me often enough, but I have been thinking about this one A LOT since that weekend.  So cool, especially since I feel like I semi-figured it out on the last laps of my last race on Sunday.

I’ll be back!

Scott
’68 GT6

On Jun 29, 2026, at 12:23 PM, Dave Riddle <[email-masked]> wrote:

Dave Riddle
602.692.5276

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, June 25, 2026 2:35 PM
To: [email-masked]
Cc: Fot <[email-masked]>
Subject: Re: [Fot] From your event chair - our Return to Mosport is in the books

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Ponostyle <[email-masked]>
Date: Mon, 29 Jun 2026 11:45:35 -0700

That wall has a lot of deep marks on it. The weekend before I raced Peyote there some locally well-known racer turned a vintage race car (I think it was an old F1 car, but my memory sucks) into a collection of not very useful parts and killed himself there. I think that was on my mind when I lifted slightly and even braked a few times. Peyote, of course was, calling me a sissy each time. 

> On Jun 29, 2026, at 9:23 AM, Dave Riddle <[email-masked]> wrote:
>

---

From: <[email-masked]>
Date: Mon, 29 Jun 2026 20:11:07 -0400

As crazy as this weather's gonna be I'd like to go further north to race if you know what I mean Anyway guys have a good race and stay cool
Craig

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of Scott Janzen
Sent: Monday, June 29, 2026 2:04 PM
To: Dave Riddle <[email-masked]>
Cc: 'Friends of Triumph' Triumph <[email-masked]>
Subject: Re: [Fot] From your event chair - our Return to Mosport is in the books

I’ll be back!

Scott
’68 GT6

Dave Riddle
602.692.5276

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, June 25, 2026 2:35 PM
To: [email-masked]
Cc: Fot <[email-masked]>
Subject: Re: [Fot] From your event chair - our Return to Mosport is in the books

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]