Subject: [Fot] From your event chair - our Return to Mosport is in the books

From: [email-masked]
Date: Thu, 25 Jun 2026 13:19:14 -0400

Thanks to everyone who made the trip to Mosport, it was my pleasure to 
share my favorite event of the year. It was pretty amazing on so many 
levels, the track, the Canadian hospitality, having all our friends 
together again to race for the Cup.

Our neighbors to the north always put on a great event, and this year 
was no different. Being the featured marque, we had no less than 10 
sessions available to us, but I was only able to do 9. By the time that 
last race of the weekend came around, I was spent. The car seemed ready 
and able, my mind was all in, but it was my body that that convinced me 
I was done! I was literally sore from tossing the car around all those 
laps at speed!

I wish I could have been more effective setting the schedule a little 
better, I did push back but we got what we got. One of the problems when 
we get so much track time having cars that run in 4 different groups is 
getting that track time spread out enough to be comfortable.

I feel our racers who were seeing the track for the first time at speed 
did a wonderful job. Congrats to all first timers for surviving turns 1, 
2 and 8, plus figuring out how to get around 5B. It takes a very special 
person to be able to grow that third testicle on their first visit to 
Mosport, it took me years to be able to go all out in 1 and 2. I know 
there is still more speed for me in turn 8, but that risk to reward 
buzzer in my head goes off every time I try to find it!

A heartfelt thanks to Keith Files who came over from the UK to be our 
Grand Marshal, job well done Keith. It was a privilege to meet the 
lovely Louisa as well!

Kudos to Kallie Sukey, what a great job she did with only a handful of 
races under her belt. The former Bill Rampe Spit was looking great out 
there, I have no doubt Kallie will be mixing it up with the best of us 
soon!

The Darrow brothers came with that incredibly fast pair of matching 
Spits and put on quite a show. They Triumphed over adversity all 
weekend, great fun to watch.

Then there was Fireball Bob Kramer. Surviving the epic tow from Texas, 
he came trying to break the jinx of Mosport. He was unsuccessful, I am 
afraid. He just earned another nickname, Oily Bob! Sorry Bob, hopefully 
your next event goes better!

Then we have the luckiest person at the track, our most recent Kastner 
Cup winner Dave Gott. In one of the group races, we are circling the 
track under double yellow for an unrelated incident when I come around 
and see Dave's TR4 beached in a very peculiar place. I think nobody 
would pull off there if they had a choice. Next time around, the flatbed 
was there pulling the car backwards and I could see the left front wheel 
flopping down, it looked like he broke a ball joint! I shuddered 
thinking how the heck did that happen under yellow in the ONLY slow 
corner on the whole track when only moments before I know he was running 
right hand corners at full chat where that failure would be 
catastrophic. I suggested he buy a lottery ticket... Of course I have no 
clue if Canada even does the lottery thing! Turns out it was a snapped 
upright, it broke just above the threads that screw into the trunnion. 
Unfortunately, Dave was done for the weekend.

We had our share of mechanical issues on top of Dave's near calamity, I 
saw at least 3 head gasket replacements, a diff failure, a gearbox 
shredded some gears, and a blown out bespoke shock just to name a few. 
Most persevered to get things fixed, some became spectators not by 
choice but by necessity. A pretty typical showing for our group, as we 
know attrition is part of the sport.

Thanks to all the non-racers who showed up, we had no less than 10 of 
our Western Pennsylvania Triumph buds, plus our friends Irv Korey and 
Jay Holecamp came from Illinois. Dave Amys and his wife drove their 
beautiful TR6 all the way from Minnesota to be with us! Plus more I 
can't think of at the moment, sorry about that folks!

I'll post a couple of race reports shortly, and call it a wrap on my 
time as your race chair. I am thrilled that Jason and Brian are back on 
the task for Grattan next year, it's on my calendar for the middle of 
August, 2027!

Cheers

Henry Frye
#29 TR250
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Bob Kramer <[email-masked]>
Date: Mon, 29 Jun 2026 16:43:53 -0500

I don’t think you are wrong one bit and that is the approach I used . In an earlier email on this problem I mentioned that I was concerned about how loose the filter was on the threads on the adapter nipple. 
I originally thought the theads were wrong until I compared them to the one that had pulled out of the filter head. I tried to clean up the 5/16-18 threads and reuse that one that came out but I couldn’t get those threads cleaned up. The 3/4-16 filter threads on that one were quite a bit tighter on the filter. I think this is a case of crappy new parts. Turns out I had 2 adapter kits back at home and both of them had threads that fit the filter better than the one that let go of the filter. So tightening, with an oil filter wrench, which shouldn’t be needed, is the only way to go in this case. But, I’m not using that adapter……so I should be okay going forward.

You only get one chance at life, make it a TRIUMPH.

> On Jun 29, 2026, at 2:45 PM, Ponostyle <[email-masked]> wrote:
> 
> I could be out of date or simply wrong with this comment, but Oil filters shouldn’t leak when they are tightened by hand. and in fact they should NOT be tightened with a wrench. The can and mating surface of an oil filter is just thin metal. Distort that with overtightening and it’s likely to leak.  The seal on oil filters is not just an O-ring—it’s a fairly wide soft closed foam seal that should not require heavy torque to seal. The wrench is for getting them off—a firm twist by hand and a few heat cycles is enough to make them very hard to get off just by hand. If you have a sealing problem I’d take a close look at your spin-on adapter and also use ONLY the recommended filter. Safety wiring the filter is belt and suspenders, certainly not a bad idea but not intended to prevent the filter from leaking. My recollection for the ones I use is a specific purolator filter, and when I use those it never leaks. I substituted one that was larger in the can but looked identical for the sealing surface—blew oil all over the floor.
> 
>> On Jun 29, 2026, at 10:39 AM, Bob Kramer <[email-masked]> wrote:
>> 
>> I used to do that. I think the SVRA or maybe the SCCA required it. I’ll start doing it again. Thanks
>> 
>> 
>> 
>> You only get one chance at life, make it a TRIUMPH.
>> 
>>>> On Jun 29, 2026, at 11:37 AM, Joe <[email-masked]> wrote:
>>> 
>>> Bob, something else you can do to help keep the oil filter in place is to safety wire it.  Put a hose clamp on the filter and then attach the wire to the clamp and an anchor point.  Keep tension on the wire so that it keeps tightening the filter.
>>> Joe(B)
>>> 
>>> Sent from my iPhone
>>> 
>>>> On Jun 29, 2026, at 4:31 AM, Bob Kramer <[email-masked]> wrote:
>>>> 
>>>> After I blew the engine at Mosport in 2003 my fellow Texas racers rewarded me with a decal for my race car door with my name and “Fireball” in the middle. It stayed there until I sold the car. I can promise you this, if “Oily Bob” finds it way to my door it won’t stay there! What a painful experience.
>>>> 
>>>> We drove to Connecticut after the weekend and visited family so I just got home last night. I had a lot of time behind the wheel to theorize what caused the second oil drop and even with all that time I got it wrong.
>>>> 
>>>> The borrowed oil filter adapter to replace the one that is in the weeds at turn 5c was given to me with the qualifier that he didn’t know if it had the right o-rings. It was also a newer edition of the adapter than the one that broke and I saw that it had a longer threaded section to screw on the filter. Both of those things went caused me trouble. At home, with the benefit of the Moss instructions I now know that the kit has 2 sizes of the larger filter head o-rings. The thinner one wasn’t thick enough to hold oil pressure at full tilt and it was making a mess. The leak was easy to see with the car on the lift and the engine  reved up. .  It’s got the thicker one in there now and all is good.
>>>> 
>>>> The bigger problem is that I didn’t fully tighten the oil filter. Mind you I tightened it as much as I dared with the pliers style oil filter wrench I had with me, but at home, with a ring style wrench I found that it needed more than another full turn after what I thought was fully tight. So it’s no longer a surprise that the filter came loose on track and caused the second oil dump.
>>>> 
>>>> So the events were unrelated in causation. The first oil dump was caused by failed threads inside the Purolater filter head, nothing else. I guess it’s time was up. The WIX 51516 filters were not hitting anything and turn out to be the same length as the FL400’s. Sorry WIX for blaming you.
>>>> 
>>>> The left side bottoms of the car is cleaner than it has been in a long time and has a nice shine to it. I don’t recommend the process.
>>>> 
>>>> Anyhow, I hated that I cost led everyone racing laps and felt owed you all an explanation or maybe a confession.
>>>> 
>>>> And that’s all folks.
>>>> 
>>>> Bob
>>>> 
>>>> BTW, even with all my troubles I still had fun. It’s a great track.
>>>> 
>>>> 
>>>> 
>>>> 
>>>> You only get one chance at life, make it a TRIUMPH.
>>>> 
>>>>>> On  Jun 25, 2026, at 10:39 PM, Chuck Gee <[email-masked]> wrote:
>>>>> 
>>>>> Nice reporting Henry!  I had nothing for you, you are truly the master at Mosport.
>>>>> 
>>>>> Chuck
>>>>> 
>>>>>>> On Jun 25, 2026, at 3:18 PM, [email-masked] wrote:
>>>>>> 
>>>>>> Thanks to everyone who made the trip to Mosport, it was my pleasure to share my favorite event of the year. It was pretty amazing on so many levels, the track, the Canadian hospitality, having all our friends together again to race for the Cup.
>>>>>> 
>>>>>> Our neighbors to the north always put on a great event, and this year was no different. Being the featured marque, we had no less than 10 sessions available to us, but I was only able to do 9. By the time that last race of the weekend came around, I was spent. The car seemed ready and able, my mind was all in, but it was my body that that convinced me I was done! I was literally sore from tossing the car around all those laps at speed!
>>>>>> 
>>>>>> I wish I could have been more effective setting the schedule a little better, I did push back but we got what we got. One of the problems when we get so much track time having cars that run in 4 different groups is getting that track time spread out enough to be comfortable.
>>>>>> 
>>>>>> I feel our racers who were seeing the track for the first time at speed did a wonderful job. Congrats to all first timers for surviving turns 1, 2 and 8, plus figuring out how to get around 5B. It takes a very special person to be able to grow that third testicle on their first visit to Mosport, it took me years to be able to go all out in 1 and 2. I know there is still more speed for me in turn 8, but that risk to reward buzzer in my head goes off every time I try to find it!
>>>>>> 
>>>>>> A heartfelt thanks to Keith Files who came over from the UK to be our Grand Marshal, job well done Keith. It was a privilege to meet the lovely Louisa as well!
>>>>>> 
>>>>>> Kudos to Kallie Sukey, what a great job she did with only a handful of races under her belt. The former Bill Rampe Spit was looking great out there, I have no doubt Kallie will be mixing it up with the best of us soon!
>>>>>> 
>>>>>> The Darrow brothers came with that incredibly fast pair of matching Spits and put on quite a show. They Triumphed over adversity all weekend, great fun to watch.
>>>>>> 
>>>>>> Then there was Fireball Bob Kramer. Surviving the epic tow from Texas, he came trying to break the jinx of Mosport. He was unsuccessful, I am afraid. He just earned another nickname, Oily Bob! Sorry Bob, hopefully your next event goes better!
>>>>>> 
>>>>>> Then we have the luckiest person at the track, our most recent Kastner Cup winner Dave Gott. In one of the group races, we are circling the track under double yellow for an unrelated incident when I come around and see Dave's TR4 beached in a very peculiar place. I think nobody would pull off there if they had a choice. Next time around, the flatbed was there pulling the car backwards and I could see the left front wheel flopping down, it looked like he broke a ball joint! I shuddered thinking how the heck did that happen under yellow in the ONLY slow corner on the whole track when only moments before I know he was running right hand corners at full chat where that failure would be catastrophic. I suggested he buy a lottery ticket... Of course I have no clue if Canada even does the lottery thing! Turns out it was a snapped upright, it broke just above the threads that screw into the trunnion. Unfortunately, Dave was done for the weekend.
>>>>>> 
>>>>>> We had our share of mechanical issues on top of Dave's near calamity, I saw at least 3 head gasket replacements, a diff failure, a gearbox shredded some gears, and a blown out bespoke shock just to name a few. Most persevered to get things fixed, some became spectators not by choice but by necessity. A pretty typical showing for our group, as we know attrition is part of the sport.
>>>>>> 
>>>>>> Thanks to all the non-racers who showed up, we had no less than 10 of our Western Pennsylvania Triumph buds, plus our friends Irv Korey and Jay Holecamp came from Illinois. Dave Amys and his wife drove their beautiful TR6 all the way from Minnesota to be with us! Plus more I can't think of at the moment, sorry about that folks!
>>>>>> 
>>>>>> I'll post a couple of race reports shortly, and call it a wrap on my time as your race chair. I am thrilled that Jason and Brian are back on the task for Grattan next year, it's on my calendar for the middle of August, 2027!
>>>>>> 
>>>>>> Cheers
>>>>>> 
>>>>>> Henry Frye
>>>>>> #29 TR250
>>>>>> Donate: http://www.team.net/donate.html
>>>>>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
>>>>>> 
>>>>>> 
>>>>> Donate: http://www.team.net/donate.html
>>>>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
>>>>> 
>>>>> 
>>>> Donate: http://www.team.net/donate.html
>>>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
>>>> 
>>>> 
>>> 
>> Donate: http://www.team.net/donate.html
>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
>> 
>> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Philip Gott <[email-masked]>
Date: Tue, 30 Jun 2026 06:19:22 -0400

Bob (et al)
Some good advice in this thread. I wonder, however, why move away from the stock canister filter (other than the bloody mess it can make when changing filters)? If of course your oiling system has totally eliminated the Purolator or Tecalmit oil management casting then you have no choice. The stock canister gives you equal or better filtration as the Wix cartridge filters at 25 microns, much finer than many remote and spin on filters. An adapter head allowing a spin on filter does not eliminate the filter bypass valve in the stock system, and adds the bypass in the spin on filter. In other words, you get twice the filter bypass possibilities in such a system.  And of course the stock canister gives a good look at what debris has been captured when you clean it out.
No system is error proof.  Careful assembly needed for either system, but if it ain’t broke, don’t fix it!
Regards,
Phil

Sent from my iPhone

> On Jun 29, 2026, at 10:30 PM, Bob Kramer <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>