Subject: Re: [Fot] Non-Triumph suspension component question

From: Philip Gott via Fot <[email-masked]>
Date: Sat, 30 Dec 2023 20:51:04 -0500

Scott;
As a pure guess, I would call Pegasus to see if they can provide a replacement as they cater to “specialty” race cars. 
Phil

Sent from my iPhone

> On Dec 30, 2023, at 4:33 PM, Scott Janzen via Fot <[email-masked]> wrote:
> 
> I’m working on an old sports racer. The front uprights use a lower ball joint I’m hoping someone will recognize. It has a capital N in a circle and three triangles stamped on it.
> Any ideas?
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "John H. Hasty via Fot" <[email-masked]>
Date: Sun, 31 Dec 2023 02:33:46 +0000

The year that the car was built might help as well.

John H. Hasty
Of Counsel
Mullen Holland & Cooper P.A.
301 S. York St., 
P.O. Box 488
Gastonia, NC 28053
704.864.6751 (p) 704.861.8394 (f)
mhc-law.com | [email-masked]

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of Philip Gott via Fot
Sent: Saturday, December 30, 2023 8:51 PM
To: Scott Janzen <[email-masked]>
Cc: 'Friends of Triumph' Triumph <[email-masked]>
Subject: Re: [Fot] Non-Triumph suspension component question

Scott;

Sent from my iPhone

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]