Subject: [Fot] Paging Mark Bradakis.

From: JOSEPH ALEXANDER via Fot <[email-masked]>
Date: Thu, 30 Mar 2023 09:46:31 -0500

Mark, please contact me for an important message.

Best Regards,
Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Chuck Gee via Fot <[email-masked]>
Date: Thu, 30 Mar 2023 11:28:51 -0400

Very ominous 😄

Sent from my iPhone

> On Mar 30, 2023, at 10:54 AM, JOSEPH ALEXANDER via Fot <[email-masked]> wrote:
> 
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]