Subject: [Fot] Connecting rod question

From: Walt Hollowell via Fot <[email-masked]>
Date: Wed, 25 Jan 2023 11:28:04 -0700

This is a multipart message in MIME format.

--===============1090730075669840822==
	boundary="----=_NextPart_000_0528_01D930B0.18981E20"
Content-Language: en-us

This is a multipart message in MIME format.

------=_NextPart_000_0528_01D930B0.18981E20
	charset="us-ascii"
Content-Transfer-Encoding: 7bit

I have built a few full race engines for my TR6 using MaxSpeeding connecting
rods with acceptable results. For my next build I am considering Carrillo
rods which run about $650 more than the MaxSpeeding rods. 

Do and FOT members feel that the Carrillo rods are worth the extra bucks or
should I be happy with the MaxSpeeding considering the affordability?

Thanks,

Walter Hollowell

Albuquerque, New Mexico

-- 
This email has been checked for viruses by AVG antivirus software.
www.avg.com
------=_NextPart_000_0528_01D930B0.18981E20
	charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<html xmlns:v=3D"urn:schemas-microsoft-com:vml" xmlns:o=3D"urn:schemas-micr=
osoft-com:office:office" xmlns:w=3D"urn:schemas-microsoft-com:office:word" =
xmlns:m=3D"http://schemas.microsoft.com/office/2004/12/omml" xmlns=3D"http:=
//www.w3.org/TR/REC-html40"><head><meta http-equiv=3DContent-Type content=
=3D"text/html; charset=3Dus-ascii"><meta name=3DGenerator content=3D"Micros=
oft Word 15 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
	{font-family:"Cambria Math";
	panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
	{font-family:Calibri;
	panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0in;
	font-size:11.0pt;
	font-family:"Calibri",sans-serif;}
span.EmailStyle17
	{mso-style-type:personal-compose;
	font-family:"Calibri",sans-serif;
	color:windowtext;}
=2EMsoChpDefault
	{mso-style-type:export-only;
	font-family:"Calibri",sans-serif;}
@page WordSection1
	{size:8.5in 11.0in;
	margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
	{page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext=3D"edit" spidmax=3D"1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext=3D"edit">
<o:idmap v:ext=3D"edit" data=3D"1" />
</o:shapelayout></xml><![endif]--></head><body lang=3DEN-US link=3D"#0563C1=
" vlink=3D"#954F72" style=3D'word-wrap:break-word'><div class=3DWordSection=
1><p class=3DMsoNormal>I have built a few full race engines for my TR6 usin=
g MaxSpeeding connecting rods with acceptable results. For my next build I =
am considering Carrillo rods which run about $650 more than the MaxSpeeding=
 rods. <o:p></o:p></p><p class=3DMsoNormal>Do and FOT members feel that the=
 Carrillo rods are worth the extra bucks or should I be happy with the MaxS=
peeding considering the affordability?<o:p></o:p></p><p class=3DMsoNormal>T=
hanks,<o:p></o:p></p><p class=3DMsoNormal>Walter Hollowell<o:p></o:p></p><p=
 class=3DMsoNormal>Albuquerque, New Mexico<o:p></o:p></p></div><div id=3D"D=
AB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2"><br /><table style=3D"border-top: 1px =
solid #D3D4DE;"><tr><td style=3D"width: 55px; padding-top: 13px;"><a href=
=3D"http://www.avg.com/email-signature?utm_medium=3Demail&utm_source=3Dlink=
&utm_campaign=3Dsig-email&utm_content=3Demailclient" target=3D"_blank"><img=
 src=3D"https://s-install.avcdn.net/ipm/preview/icons/icon-envelope-tick-gr=
een-avg-v1.png" alt=3D"" width=3D"46" height=3D"29" style=3D"width: 46px; h=
eight: 29px;"/></a></td><td style=3D"width: 470px; padding-top: 12px; color=
: #41424e; font-size: 13px; font-family: Arial, Helvetica, sans-serif; line=
-height: 18px;">Virus-free.<a href=3D"http://www.avg.com/email-signature?ut=
m_medium=3Demail&utm_source=3Dlink&utm_campaign=3Dsig-email&utm_content=3De=
mailclient" target=3D"_blank" style=3D"color: #4453ea;">www.avg.com</a></td=
></tr></table><a href=3D"#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2" width=3D"1"=
 height=3D"1"> </a></div></body></html>
------=_NextPart_000_0528_01D930B0.18981E20--

--===============1090730075669840822==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

--===============1090730075669840822==--

---

From: Don Couch via Fot <[email-masked]>
Date: Wed, 25 Jan 2023 21:07:13 -0600

Walter, 

I’d say you tell us. 
If the MaxSpeed rods are working, WHY would you want to spend the extra $$$?
I’ve always wondered about those rods but never wanted to risk a build on them.
If you are happy, why would you want to go Carrillo?

I’m currently running Carrillo rods but if the MaxSpeed rods hold up… let us know, 
Don

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Charly via Fot <[email-masked]>
Date: Wed, 25 Jan 2023 23:09:34 -0600

Walt, I have been using Max Speed rods for about 10 years.  I have never had a rod failure since I've started using them. 
When I first saw them and decided to try them, I asked the FoT what the thought was about them and the general consensus then why are you buying Chinese rods?  
My first set I took to my machine shop and they looked them over and found they were very well balanced, all equal in weight and the only difference was there were to slots to index 
the bearings.  
I have only used stock lightened and balanced rods and the MaxSpeed rods and have nothing else to compare them to.  I probably don't make as much power or rev my motor as high as 
others, I have been using a billet crank I bought with the group from Farndon Industries, about 50 lbs. and only am revving to about 7k rpm, my CR is about 12:1 or less and I use a 
lightened alloy (not aluminum) flywheel, about 12 lbs.  I have not had any rod bolt failures, maybe I'm lucky. I'm also using a Tilton 7 1/2 clutch.
The cam I've used the majority of the time is a D9 grind, mainly because it's friendlier with the fuel injection.  I use the Goodparts header as it's a thing of beauty. The head is 
about 3.30 thick uses gas flowed valves and TR5 springs with titanium retaines.  I alsp use a 1.65 : 1 roller rocker set, also from Goodparts.
I don't know if I can call my motor full race, but I've used it with Webbers, PI and triple ZS carbs.  Never been on a dyno, but guessing close to 190 hp.

On Wed 25/01/23 10:28 AM , Walt Hollowell via Fot [email-masked] sent:
> I have built a few full race engines for my TR6 using MaxSpeeding
> connecting rods with acceptable results. For my next build I am
> considering Carrillo rods which run about $650 more than the
> MaxSpeeding rods. 
> 
> Do and FOT members feel that the Carrillo rods are worth the extra
> bucks or should I be happy with the MaxSpeeding considering the
> affordability? 
> 
> Thanks,
> 
> Walter Hollowell
> 
> Albuquerque, New Mexico
> [1]
> Virus-free.www.avg.com [2]
> [3]
> 
> Links:
> ------
> [1]
> http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_cam
> paign=sig-email&utm_content=emailclient[2]
> http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_cam
> paign=sig-email&utm_content=emailclient[3]
> http://webmail.centurylinkoffice.net/#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2
> 
>

---

From: Charly via Fot <[email-masked]>
Date: Wed, 25 Jan 2023 23:13:24 -0600

--=_ca0cce46f5ef10ed2c9fe6e242870aa3
Content-Transfer-Encoding: quoted-printable

Oops, forgot signature.
Charly Mitchel=20
TR6 #44

On Wed 25/01/23  9:09 PM , Charly [email-masked] sent:
> Walt, I have been using Max Speed rods for about 10 years.  I have never
> had a rod failure since I've started using them. When I first saw them an=
d decided to try them, I asked the FoT what the
> thought was about them and the general consensus then why are you buying
> Chinese rods?  My first set I took to my machine shop and they looked the=
m over and found
> they were very well balanced, all equal in weight and the only difference
> was there were to slots to index the bearings. =20
> I have only used stock lightened and balanced rods and the MaxSpeed rods
> and have nothing else to compare them to.  I probably don't make as much
> power or rev my motor as high as others, I have been using a billet crank=
 I bought with the group from
> Farndon Industries, about 50 lbs. and only am revving to about 7k rpm, my
> CR is about 12:1 or less and I use a lightened alloy (not aluminum) flywh=
eel, about 12 lbs.  I have not had any
> rod bolt failures, maybe I'm lucky. I'm also using a Tilton 7 1/2
> clutch.The cam I've used the majority of the time is a D9 grind, mainly b=
ecause
> it's friendlier with the fuel injection.  I use the Goodparts header as
> it's a thing of beauty. The head is about 3.30 thick uses gas flowed valv=
es and TR5 springs with titanium
> retaines.  I alsp use a 1.65 : 1 roller rocker set, also from
> Goodparts.I don't know if I can call my motor full race, but I've used it=
 with
> Webbers, PI and triple ZS carbs.  Never been on a dyno, but guessing clos=
e
> to 190 hp.
>=20
>=20
>=20
>=20
> On Wed 25/01/23 10:28 AM , Walt Hollowell via Fot fot@autox.
> team.net sent:> I have built a few full race engines for my TR6
> using MaxSpeeding> connecting rods with acceptable results. For my
> next build I am> considering Carrillo rods which run about $650
> more than the> MaxSpeeding rods.=20
> >=20
> > Do and FOT members feel that the Carrillo rods
> are worth the extra> bucks or should I be happy with the MaxSpeeding
> considering the> affordability?=20
> >=20
> > Thanks,
> >=20
> > Walter Hollowell
> >=20
> > Albuquerque, New Mexico
> > [1]
> > Virus-free.www.avg.com [2]> [3]
> >=20
> > Links:
> > ------
> > [1]
> > http://www.avg.com/email-signature?utm_medium=3Demail&utm_sou
> rce=3Dlink&utm_cam>
> paign=3Dsig-email&utm_content=3Demailclient[2]> http://www.avg.com/email-=
signature?utm_medium=3Demail&utm_sou
> rce=3Dlink&utm_cam>
> paign=3Dsig-email&utm_content=3Demailclient[3]> http://webmail.centurylin=
koffice.net/#DAB4FAD8-2DD7-40BB-A1B8-4
> E2AA1F9FDF2>=20
> >=20
>=20
>=20
>=20
>=20

--=_ca0cce46f5ef10ed2c9fe6e242870aa3
Content-Transfer-Encoding: base64
 name="106987817_1024145578047711_7373533897443916473_o.jpg"; 
Content-Disposition: attachment;
 filename="106987817_1024145578047711_7373533897443916473_o.jpg"; 

--=_ca0cce46f5ef10ed2c9fe6e242870aa3
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--=_ca0cce46f5ef10ed2c9fe6e242870aa3--

---

From: Charly via Fot <[email-masked]>
Date: Wed, 25 Jan 2023 23:15:02 -0600

--=_1e34184acccfb381b188f4c77c46adc6
Content-Transfer-Encoding: quoted-printable

m over and found
ecause
 with
e
> E2AA1F9FDF2>=20

--=_1e34184acccfb381b188f4c77c46adc6
Content-Transfer-Encoding: base64
 name="2012-10-17_22-09-29_391.jpg"; 
Content-Disposition: attachment;
 filename="2012-10-17_22-09-29_391.jpg"; 

--=_1e34184acccfb381b188f4c77c46adc6
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--=_1e34184acccfb381b188f4c77c46adc6--

---

From: Charly via Fot <[email-masked]>
Date: Wed, 25 Jan 2023 23:19:10 -0600

On Wed 25/01/23  9:09 PM , Charly [email-masked] sent:
> had a rod failure since I've started using them. When I first saw them and decided to try them, I asked the FoT what the
> Chinese rods?  My first set I took to my machine shop and they looked them over and found
> was there were to slots to index the bearings.  
> power or rev my motor as high as others, I have been using a billet crank I bought with the group from
> CR is about 12:1 or less and I use a lightened alloy (not aluminum) flywheel, about 12 lbs.  I have not had any
> clutch.The cam I've used the majority of the time is a D9 grind, mainly because
> it's a thing of beauty. The head is about 3.30 thick uses gas flowed valves and TR5 springs with titanium
> Goodparts.I don't know if I can call my motor full race, but I've used it with
> Webbers, PI and triple ZS carbs.  Never been on a dyno, but guessing close
> to 190 hp.
> 
> 
> 
> 
> more than the> MaxSpeeding rods. 
> > 
> considering the> affordability? 
> > 
> > Thanks,
> > 
> > Walter Hollowell
> > 
> > Albuquerque, New Mexico
> > [1]
> > http://www.avg.com/email-signature?utm_medium=email&utm_sou
> rce=link&utm_cam>
> paign=sig-email&utm_content=emailclient[2]> http://www.avg.com/email-signature?utm_medium=email&utm_sou
> rce=link&utm_cam>
> paign=sig-email&utm_content=emailclient[3]> http://webmail.centurylinkoffice.net/#DAB4FAD8-2DD7-40BB-A1B8-4
> E2AA1F9FDF2> 
> > 
> 
> 
> 
>

---

From: Charly via Fot <[email-masked]>
Date: Thu, 26 Jan 2023 00:25:19 -0600

Just to let you know, I've been running them in my 6 for 10 years with no failures, actually a good product.  Them seem to be better now than when they first came out.
Charly Mitchel
TR6 #44
On Wed 25/01/23  7:07 PM , Don Couch via Fot [email-masked] sent:
> Walter, 
> 
> I’d say you tell us. 
> If the MaxSpeed rods are working, WHY would you want to spend the extra
> $$$?I’ve always wondered about those rods but never wanted to risk a
> build on them.If you are happy, why would you want to go Carrillo?
> 
> I’m currently running Carrillo rods but if the MaxSpeed rods hold
> up… let us know, Don
> 
> fot@autox.
> team.net
> Donate: http://www.team.net/donate.htmlArchive: http://autox.team.net/archive
> http://www.team.net/pipermail/fotUnsubscribe/Manage: http://autox.team.net/mailman/options/fot/ch
> [email-masked]
> 
> 
> 
>

---

From: James Palmer via Fot <[email-masked]>
Date: Thu, 26 Jan 2023 06:29:06 -0500

They lasted over 7000 race miles in my endurance racing Marina (MGB engine) with no issues at all. Now I’m building a TR6 endurance engine (LDRL) and using MS rods again.  Debut in September, I hope.

Jamie Palmer
RiffRAF Racing

Sent from my iPad

> On Jan 26, 2023, at 5:07 AM, Charly via Fot <[email-masked]> wrote:
> 
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]