Subject: Re: [Fot] DEVELOPING: Jay Leno Badly Burned in Car Fire... Serious Injury to His Face

From: Greg Hilyer via Fot <[email-masked]>
Date: Mon, 14 Nov 2022 15:23:27 -0700

Bummer!
Wonder if it was a ICE or steam? I recall a snippet of his about how many more ways steam power could kill you compared to internal combustion.
Several years ago Connie and I got to spend some time with him and his collection - he’s every bit the “good” guy everyone says he is.
Wishing him all the best! 
Greg “Lunker” Hilyer
Albuquerque NM

> On Nov 14, 2022, at 2:44 PM, J Wagner via Fot <[email-masked]> wrote:
> 
> 
> https://www.thegatewaypundit.com/2022/11/developing-jay-leno-badly-burned-car-fire-serious-injury-face/
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Dave Riddle via Fot <[email-masked]>
Date: Mon, 14 Nov 2022 16:04:00 -0700

Gasoline...

https://variety.com/2022/tv/news/jay-leno-burned-car-fire-face-injuries-severe-1235432183/

Dave Riddle
[email-masked]
602.692.5276

-----Original Message-----
From: Fot [mailto:[email-masked]] On Behalf Of Greg Hilyer via Fot
Sent: Monday, November 14, 2022 3:23 PM
To: J Wagner
Cc: FOT
Subject: SPAM-MED: Re: [Fot] DEVELOPING: Jay Leno Badly Burned in Car Fire... Serious Injury to His Face

Bummer!

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]