Subject: [Fot] Anybody Going To PRI?

From: Joe Alexander via Fot <[email-masked]>
Date: Wed, 30 Nov 2022 10:09:02 -0600

FOT:

We have fair amount of business to take care of at PRI, so we are going to try to attend.  Friday & Saturday.

Any FOT going to be there?

Regards,

Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: David Kettler via Fot <[email-masked]>
Date: Wed, 30 Nov 2022 11:39:51 -0600

Will be there at the Flis Performance booth.

Would like to see you Joe!

Dave Kettler - Technical Director, Andersen Promotions
Mazda MX-5 Cup presented by BF Goodrich Tires
C: 920-946-7491    [email-masked]

   |           

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of Joe Alexander via Fot
Sent: Wednesday, November 30, 2022 10:09 AM
To: [email-masked]
Subject: [Fot] Anybody Going To PRI?

FOT:

We have fair amount of business to take care of at PRI, so we are going to
try to attend.  Friday & Saturday.

Regards,

Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
http://autox.team.net/mailman/options/fot/[email-masked]

---

From: "John H. Hasty via Fot" <[email-masked]>
Date: Wed, 30 Nov 2022 19:54:37 +0000

How about RR on 12/9-11?

Sent from my iPhone

> On Nov 30, 2022, at 12:46 PM, David Kettler via Fot <[email-masked]> wrote:
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage:
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]