Subject: [Fot] British grease zerk

From: DENNIS WALJE via Fot <[email-masked]>
Date: Mon, 7 Jun 2021 12:04:12 -0500

Does anyone know where I can purchase the grease zerk to fit the steering rack on a GT6?  

The threads appear to be non standard. Does the rack take the British grease thread (3/8 x 19 or 3/8 x 20)?

Thanks 

Dennis Walje
1966 GT6
Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: Brad Eells via Fot <[email-masked]>
Date: Mon, 7 Jun 2021 13:06:46 -0400

I’ve always used what ever I could find at the hardware store. It needs to go in just enough to not pop out when pumping your favorite Triumph steering rack grease…

Brad Eells
Sent from my iPhone

> On Jun 7, 2021, at 1:04 PM, DENNIS WALJE via Fot <[email-masked]> wrote:
> 
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Christopher A Kantarjiev via Fot <[email-masked]>
Date: Mon, 7 Jun 2021 12:08:10 -0700

Memory says that it's a straight thread, because it's a bolt that 
normally fills the hole. Remove the bolt, insert zerk, pump, replace bolt.

I've got one in my tool chest that I'm pretty sure I bought from TRF 
when dinosaurs roamed the earth.