Subject: [Fot] RIP Randall Young. FOT.

From: Joe Alexander <[email-masked]>
Date: Fri, 24 Jul 2020 06:45:11 -0500

FOT:

Many of you did not know Randall, but he was on the FOT List since the late 90s.

He was one of exceptions to the list preference for “racers only”. He had superior Triumph knowledge and was very helpful to many of us over the years.

And so it goes.......

Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

_______________________________________________
[email-masked]

http://www.fot-racing.com

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: Mark J Bradakis <[email-masked]>
Date: Fri, 24 Jul 2020 08:45:43 -0600

> He was one of exceptions to the list preference for “racers only”. He had superior Triumph knowledge and was very helpful to many of us over the years.

Yes, 2020 delivers yet another solid kick to the groin.  Randall was the 
exception to many rules, no doubt.

And here's a shot in the dark.

On 7/24/20 3:46 AM, Lawarence Schwartz wrote:

> Hello, Such sad news indeed. I was introduced to Randall many years 
> ago by the late “FT” Fred Thomas . Such two true blue fine gentlemen. 
> Randall, there is a special place for you in heaven, RIP.   Lawrence 
> Schwartz 

So does anyone have a photo of Fred and Randall together?  I had an idea 
for a project some years ago, and maybe I should get back to work on it.

http://autox.team.net/memory.html

mjb.