Subject: Re: [Fot] Automotive Forged Racing Pistons - JE Pistons

From: "Barr, Scott via Fot" <[email-masked]>
Date: Tue, 3 Dec 2019 14:42:28 +0000

I always bought my JE pistons directly from JE.

Scott (B.)

-----Original Message-----
From: Fot <[email-masked]> On Behalf Of Joe Alexander via Fot
Sent: Tuesday, December 03, 2019 8:01 AM
To: [email-masked]
Subject: [Fot] Automotive Forged Racing Pistons - JE Pistons

FOT,

Does anyone buy JE 89mm pistons?
If not, where do you get them?

I have a friend in France who is looking for 12 of them.

Thank you.

https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.jepistons.com%2FCatalogs%2FAutomotive%2FIndex.aspx&amp;data=02%7C01%7Csbarr%40mccarty-law.com%7Ce9ddba7ed57e4055592808d777f98290%7C5027ac9b577b4efca8a99ee22eb53484%7C0%7C0%7C637109785841496186&amp;sdata=GimoZIT60LacPqvGv0%2Be4bB%2FQp05DIg7ygjEPcbN1Mo%3D&amp;reserved=0

Joe Alexander
4505 Donald Dr
Cedar Falls, IA 50613
The-vintage-racer.com
Gasketinnovations.com
Cell:  319.464.4711

_______________________________________________
[email-masked]

https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.fot-racing.com&amp;data=02%7C01%7Csbarr%40mccarty-law.com%7Ce9ddba7ed57e4055592808d777f98290%7C5027ac9b577b4efca8a99ee22eb53484%7C0%7C0%7C637109785841501184&amp;sdata=7lSZiUS%2FEvPch6zMGAAXEDlNaS%2FZmMqDRNYu3kFhRwg%3D&amp;reserved=0

Archive: https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fautox.team.net%2Farchive&amp;data=02%7C01%7Csbarr%40mccarty-law.com%7Ce9ddba7ed57e4055592808d777f98290%7C5027ac9b577b4efca8a99ee22eb53484%7C0%7C0%7C637109785841501184&amp;sdata=dXUu4mRbgp6mJXhUO7ky7kJbJO%2FnH%2BUvfDgEUfqKYxA%3D&amp;reserved=0 https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.team.net%2Fpipermail%2Ffot&amp;data=02%7C01%7Csbarr%40mccarty-law.com%7Ce9ddba7ed57e4055592808d777f98290%7C5027ac9b577b4efca8a99ee22eb53484%7C0%7C0%7C637109785841501184&amp;sdata=pSN7oJ0VVYdzCXuzumnqN7zfTKCqrzbZyvWkusmVlBU%3D&amp;reserved=0

_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot

---

From: JAMES GRAY via Fot <[email-masked]>
Date: Tue, 3 Dec 2019 09:40:56 -0700 (MST)

Wiseco makes all my pistons, I use pop ups and they will give me any size dome I want.
Sue Nash has been great to work with. I've always bought them through BFE but technical
coordination has been between myself and Sue.  Nash, Sue <[email-masked]>

Jim G.

> On December 3, 2019 at 7:00 AM Joe Alexander via Fot <[email-masked]> wrote:
> 
> 
> FOT,
> 
> http://www.jepistons.com/Catalogs/Automotive/Index.aspx
> 
> 
> Joe Alexander
> 4505 Donald Dr
> Cedar Falls, IA 50613
> The-vintage-racer.com
> Gasketinnovations.com
> Cell:  319.464.4711
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>

---

From: Bill Tobin via Fot <[email-masked]>
Date: Tue, 3 Dec 2019 13:09:42 -0500

I think Wiseco ans JE are located in the same building east of 
Cleveland. They are competitors but also work together on projects.

I got a tour one day; spectacular shop.

Cheers Bill

On 12/3/2019 11:40 AM, JAMES GRAY via Fot wrote:
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
>
>

---

From: Brad Eells via Fot <[email-masked]>
Date: Tue, 3 Dec 2019 11:45:25 -0800

JE is located right around the corner from my office in Cypress CA...

Brad Eells
Sent from my iPhone

> On Dec 3, 2019, at 10:09 AM, Bill Tobin via Fot <[email-masked]> wrote:
> 
> I think Wiseco ans JE are located in the same building east of Cleveland. They are competitors but also work together on projects.
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://autox.team.net/archive http://www.team.net/pipermail/fot
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]

---

From: DAVE HOGYE via Fot <[email-masked]>
Date: Tue, 3 Dec 2019 12:29:00 -0800 (PST)

JE purchased Wiseco from the Kipp family. Mentor, Ohio.  I think I called Wiseco fairly recently and they answered the phone as JE.  Tom Kipp was a top tier AMA motorcycle racer back in the '90s-2000s. I grew up very near the town of Mentor. 
Dave H.  
> On December 3, 2019 at 10:09 AM Bill Tobin via Fot <[email-masked]> wrote:
> 
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>

---

From: Bill Tobin via Fot <[email-masked]>
Date: Tue, 3 Dec 2019 15:40:10 -0500

That's correct. But they are manufactured in Kirtland Ohio in the same 
plant as Wiseco. Just talked to Wiseco. Cheers Bill

OBTW: Sue Nash has been there about 40 years!

---

From: Bill Tobin via Fot <[email-masked]>
Date: Tue, 3 Dec 2019 15:40:10 -0500