Subject: [Fot] Group 44 car

From: MACDONALD via Fot <[email-masked]>
Date: Sat, 30 Mar 2019 19:30:06 -0400

Does Bill Warner still have the Group44 TR8?
Sent from my iPhone
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/pipermail/fot

---

From: Allen Washatko via Fot <[email-masked]>
Date: Sun, 31 Mar 2019 13:47:50 -0500

It appeared in Vintage Motorsports recently.

Allen Washatko
TR6 - #6

> On Mar 30, 2019, at 6:30 PM, MACDONALD via Fot <[email-masked]> wrote:
> 
> 
> Donate: http://www.team.net/donate.html
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>