Subject: Re: [Fot] GT6 Connecting rods

From: Greg Blake <[email-masked]>
Date: Fri, 11 Dec 2015 15:36:13 -0600

Sounds like a deal considering what we pay Dennis these days which does not include the nitriding process. 

Can you specify bearing clearances and radius treatment?

Sent from my iPhone

> On Dec 9, 2015, at 9:46 AM, [email-masked] wrote:
> 
> Does anyone have experience with APT nitrided cranks? They list a fully race prepped and nitrided 6 cylinder crank at just under a grand.
> Bob Kramer
> [email-masked]
> 
> ---- Brian Schirano <[email-masked]> wrote: 
>> 2 Cents from a modest built GT6 racer (IE 10:1 CR, stock rods, crank, Good GP3 cam, etc).  Russ's comments are dead on - building the car is one expense, racing it is a recurring one and his estimate of $1000 per event is good. So build in margin of safety in the motor (and other components) where you can.
>> aluminum flywheel and clutch & PP I went to Ted Shumaker, TSI - TS Imports
>> RE the rods - at the time of my first (only) rebuild a couple years ago I couldn't afford carrillos or Pauters, but did spend some long green on nitriding and polishing the crank, balancing everything, and of course the ARP hardware everywhere that counts . My car is NOT a high rev machine, I self limit at 6200 - 6300 RPM and it seems all the straights are uphill so she never redlines there anywise!
>> So to me, it can be done, but has to be consistent with the rest of your build. my next build will be a higher CR and hotter cam, so will be upgrading rods, and pistons as well. But the first build was built conservative for longevity.
>> Brian 26A GT6+, 28 TR6Brian Schirano
>> 585-305-0349 Cell 
>> [email-masked]
>>      From: Spitfire Racing <[email-masked]>
>> To: 'Jamie' <[email-masked]>; 'McKearn McKearn' <[email-masked]> 
>> Cc: 'FOT list' <[email-masked]>
>> Sent: Wednesday, December 9, 2015 8:02 AM
>> Subject: Re: [Fot] GT6 Connecting rods
>> 
>> A properly built and modified race engine represents a mighty investment not
>> only of dollars but of time. Is that really where you want to pinch pennies?
>> After all, with the exception of pistons and crank that is one of the
>> primary components and all it takes is one piece inside an engine to reduce
>> all your work and investment to nothing more than scrap metal. One seized
>> valve, or substandard bolt even can be a disaster. It doesn't take much.
>> Realize all the ancillary invested expenditures that are also at risk like a
>> weekend's entry fee you lose in an engine failure; the cost of time off from
>> work to go to a race weekend; the cost of food and lodging for the race
>> outing and the cost of just getting there. When asked, I usually advise
>> folks to figure a race weekend is ~$1000 minimum when you roll all in.
>> 
>> A number of racers have run Pauter rods as stated before by Bill and these
>> do present a less expensive alternative. I had the opportunity to rebuild an
>> engine last year with Pauter rods and they were quite substantial and were
>> well designed, constructed and balanced. Personally I have seen far too many
>> Chinese knock-offs; reproductions (call them what you will), that fail to
>> come close to the parts they try to mimic. 
>> I suggest you perhaps delay your build until your war chest allows for top
>> quality internals. Do it once and do it right the first time and reduce the
>> potential for disappointing expensive disaster.
>> 
>> Russ Moore
>> Spitfire #49
>> 
>> -----Original Message-----
>> From: Fot [mailto:[email-masked]] On Behalf Of Jamie
>> Sent: Wednesday, December 09, 2015 6:22 AM
>> To: McKearn McKearn
>> Cc: FOT list
>> Subject: Re: [Fot] GT6 Connecting rods
>> 
>> Although I was initially very wary, they have worked well for over 1,000
>> race miles in our (horror) MGB engine.
>> 
>> Jamie Palmer
>> 
>> 
>>> On Dec 8, 2015, at 11:52 PM, McKearn McKearn <[email-masked]> wrote:
>>> 
>>> Hi Gents.
>>>     I am looking for feedback on the MaxSpeeding connecting rods for GT6.
>> Can't afford Carrillos and I'm hoping these are good. Also am still
>> searching for an aluminum flywheel without having something custom made. and
>> would like input on what type of clutch to use as well . Lets call it a race
>> car for the sake of argument....
>>>                                 Thanks.  P.J.
>>> _______________________________________________
>>> [email-masked]
>>> 
>>> http://www.fot-racing.com
>>> 
>>> Donate: http://www.team.net/donate.html
>>> Archive: http://www.team.net/archive
>>> Forums: http://www.team.net/forums
>>> Unsubscribe/Manage:
>> http://autox.team.net/mailman/options/fot/[email-masked]
>> _______________________________________________
>> [email-masked]
>> 
>> http://www.fot-racing.com
>> 
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/archive
>> Forums: http://www.team.net/forums
>> Unsubscribe/Manage:
>> http://autox.team.net/mailman/options/fot/[email-masked]
>> 
>> 
>> 
>> _______________________________________________
>> [email-masked]
>> 
>> http://www.fot-racing.com
>> 
>> Donate: http://www.team.net/donate.html
>> Archive: http://www.team.net/archive
>> Forums: http://www.team.net/forums
>> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> _______________________________________________
> [email-masked]
> 
> http://www.fot-racing.com
> 
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Duncan Charlton <[email-masked]>
Date: Fri, 11 Dec 2015 20:06:17 -0600

Dennis sent my Ford 1500 crank to a guy in Colorado for nitriding.  He said it would be about $800, including final straightening and grinding to spec (Monday I’ll pick it up and find out what the final cost is).

Duncan

> On Dec 11, 2015, at 3:36 PM, Greg Blake <[email-masked]> wrote:
> 
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
> 

Donate: http://www.team.net/donate.html
Archive: http://www.team.net/archive
Forums: http://www.team.net/forums
Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]