Subject: [Fot] George Barris died yesterday

From: Scott Janzen <[email-masked]>
Date: Fri, 06 Nov 2015 21:30:04 -0500

He did some kitschy stuff, but also some really beautiful work.

Sent from my mobile device 
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: D V <[email-masked]>
Date: Sat, 7 Nov 2015 18:53:08 +0000

Awww. I met him at autorama a few years ago. He had some interesting stuff....I felt like a lot of his designs were chemically enhanced. But they were cool. 

There is a tribute corvette going on the auction block this weekend at COTA.

Sent from my iPhone

> On Nov 6, 2015, at 8:48 PM, Scott Janzen <[email-masked]> wrote:
> 
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>