Subject: [Fot] Traction Bars (Torque Rods) TR3/4

From: Brad Eells <[email-masked]>
Date: Thu, 5 Sep 2013 21:11:13 -0700 (PDT)

Hello FOT,

Long, long time since my last post but I found something perhaps worth sharing...

I was able to acquire an original set of rear axle traction bars/torque rods that were removed from a TR4 being parted out in the mid-west via Ebay. The bars prevent leaf spring wind up on hard acceleration.

Kas had these made up in the early 60's and he authenticated my set. I was able to determine via casting marks the set was made by Traction Masters in Burbank CA. The company exists to this day...Amazingly, they make traction bars for vintage cars. I am still able to acquire a set of poly bushings from them to fit my bar set.

I inquired if they could still make up bar sets for the Triumph TR3/TR4. They said they would be happy too, though they no longer had the plan set for our cars. They could create sets using my bars and mounts as a pattern. A one off set will run around $175. A group buy could potentially lower the set price.

I had considered these traction bars as "unobtainium" having never seen a set come up on Ebay until I found the set I now have.

The question for the group is if there is any interest in creating some new Traction Master Bars from the original manufacturer?? I am happy to share my set for the pattern making as the car is a long way from needing them.

Cheers,

Brad Eells
Meridian ID
62 TR4 Racer
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: <[email-masked]>
Date: Mon, 9 Sep 2013 21:15:32 -0400

I have a set from a TR3. Probably the same as TR4.

Bob

---- Brad Eells <[email-masked]> wrote: 
> Donate: http://www.team.net/donate.html
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/fot/[email-masked]
> 
>