Subject: [Fot] SEMA Show Las Vegas.

From: Joe Alexander <[email-masked]>
Date: Mon, 30 Sep 2013 17:32:01 -0500

Any FOT going to the SEMA show in LV?

Sent from my iPad
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Russell Westfall <[email-masked]>
Date: Mon, 30 Sep 2013 16:40:12 -0700 (PDT)

Yes, I will be there. I fly in on Sunday and leave Thursday evening. It&#x27;s a business trip for me, meetings and booth duty all week.
Russ Westfall
_______________________________________________
[email-masked]