Subject: Re: [Fot] Front Engine mounts

From: John Hasty <[email-masked]>
Date: Tue, 3 Sep 2013 21:37:01 -0400

Bolts.....

Sent from my iPhone

On Sep 3, 2013, at 8:25 PM, Todd Redmond <[email-masked]> wrote:

> FoT,
>
>
> What are we using for front engine mounts for a racing TR 3? B I have one
> of ARE's new rear mounts. B Are the stock mounts up to the task? B Does
> anyone sell an uprated one? B Has anyone tried using a solid mount?B
>
> Any info is appreciated.
>
>
> Thanks
> Todd Redmond
> _______________________________________________
> [email-masked]
>
> http://www.fot-racing.com
>
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage:
http://autox.team.net/mailman/options/fot/[email-masked]
_______________________________________________
[email-masked]

http://www.fot-racing.com

Archive: http://www.team.net/archive

---

From: Tony Drews <[email-masked]>
Date: Tue, 03 Sep 2013 22:26:49 -0500

After breaking a couple of sets of the round ones the Moss sells, I 
got some heavy duty ones from Cambridge Motorsports in 
England.  Shipping was about the same as the mounts themselves, but 
they've been in the car for years without issue.  I replace a rear 
mount about every 2 years, but that should change with Shawn's new rear mount.

I also got rid of the tilton clutch, that probably helped some - that 
was pretty hard on the mounts when it engaged, I'm sure.

Tony Drews