Subject: [Bmcu] impromptu drive EARLY tomorrow

From: Kevin Cowan <[email-masked]>
Date: Fri, 3 Jul 2015 12:01:34 -0600

One way to beat the heat is to go out early.  With that in mind a group will meet at the park and ride at the mouth of the little cottonwood at 7:30AM.  At 7:45AM we will drive up to Snowbird for the annual pancake breakfast.  I expect to be back home by 10AM which leave plenty of time for other holiday activities.

Kevin

Sent from my iPad
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Kevin Cowan <[email-masked]>
Date: Fri, 3 Jul 2015 13:51:10 -0600

For those that don't ski Alta or Snowbird, the park and ride we will meet at is on route 210 near the intersection of route 209 and 210 on the left side if you are driving towards Snowbird.

Sent from my iPad

> On Jul 3, 2015, at 12:01 PM, Kevin Cowan <[email-masked]> wrote:
>