Subject: [Bmcu] spitfire transmission

From: Robert Hendricks <[email-masked]>
Date: Sat, 13 Jul 2013 10:59:33 -0600

Looking for someone in Utah that rebuilds spitfire transmission -- any recommendations?  Also looking for S U's for Spit.

Thanks

Bob
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Mark J Bradakis <[email-masked]>
Date: Sat, 13 Jul 2013 21:57:24 -0600

> Looking for someone in Utah that rebuilds spitfire transmission -- any recommendations?  Also looking for S U's for Spit.

If my garage was cleaned up a bit more I'd offer my services.  I've done 
a few Triumph
gearboxes over the last 30 years or so.  What year is the car, is it a 3 
rail or single?
Looking for a particular size of SUs?

mjb.