Subject: Re: [Bmcu] 1967 MGB Roadster

From: Hugh Larratt-Smith <[email-masked]>
Date: Mon, 3 Jun 2013 16:21:43 -0600

I have brand new roll bars from Moss for a 1977 MGB, if  that works

Hugh Larratt-Smith
c 646-541-3115
(sent from iph)

On Jun 3, 2013, at 3:03 PM, Mitch Hendricks <[email-masked]> wrote:

> Good afternoon,
> I recently purchased a 1967 MGB convertible. It has been sitting the last 10+ years. I was told it was running when put away but since then the brakes have semi locked up and it has deteriorated in many other ways. 
> 
> Before I reach out to the various catalog companies for parts I thought I'd throw this out and see if anyone has any parts kicking around?
> 
> Brakes - master, caliper and cylinders, rebuild parts
> Clutch - master and slave, rebuild parts
> Inner door and window cranks.
> Fuel pump - rebuild
> Batteries! - Twin 6V setup
> Battery trays.
> Any rear interior 
> Cap and rotor
> Seat covers
> Hub Caps
> 
> Thank you all for your time!
> 
> 
> Thanks,
> Mitch
> 801-674-0069
> _______________________________________________
> [email-masked]
> Donate: http://www.team.net/donate.html
> Archive: http://www.team.net/archive
> Forums: http://www.team.net/forums
> Unsubscribe/Manage: http://autox.team.net/mailman/options/bmcu/[email-masked]

_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: Andrew Lundgren <[email-masked]>
Date: Mon, 03 Jun 2013 16:25:32 -0600

Inlined my comments.

> I recently purchased a 1967 MGB convertible. It has been sitting the last 10+ years. I was told it was running when put away but since then the brakes have semi locked up and it has deteriorated in…
If you aren't bent on original, you get a 2.5 psi after market one for 
around $50 locally.

> Batteries! - Twin 6V setup

Some group 26 batteries 12v will fit in a single battery hole.  You can 
just switch to a single and be happy.  Just make sure it goes in. Some 
have more plastic around them than others...

> Battery trays.
Is your bucket (for lack of a better term) rusted out?  I don't even 
know what the material in the bottom of mine are...

> Cap and rotor
I have a pertronics ignitor in both of my Bs and they are happy. (They 
do cost more, but the maintenance aspect is gone.)

> Hub Caps
Are you running rostyles?  I would go that route unless you like what 
you are running.