Subject: [Bmcu] Benji's Auto Repair

From: B B <[email-masked]>
Date: Tue, 30 Apr 2013 10:24:14 -0700 (PDT)

I am looking for referrals concerning the work from Benji's Auto Repair. I am in the process of getting my 69B on the road and I am hoping to get it done relatively quickly. Bailey's is a minimum of 6 weeks out just to get a car scheduled. Are there other shops in the SLC valley that repair little British sports cars?

Brian
_______________________________________________
[email-masked]
Archive: http://www.team.net/archive

---

From: "gary" <[email-masked]>
Date: Tue, 30 Apr 2013 19:57:26 GMT

--===============1790775817==
	charset=utf-8
Content-Transfer-Encoding: base64

--===============1790775817==
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--===============1790775817==--